Chrome extension not installed, and cannot uncheck the box

Since I let Chrome update to release 14, I've lost my 1pw extension. At least, that's my guess when things started malfunctioning, but I'm not 100% certain that the update is the cause.

When I go into 1pw Preferences and try to UNcheck the Chrome extension and hit OK, there are no messages or anything. Then, when I re-open the Preferences, the box is still checked. It looks like something is not getting saved or updated somewhere.
1pw_prefs.png



Looking in Chrome, the extension is not shown:
chrome_extensions.png

I have used Browse and selected the chrome.exe, but the behavior remains the same - I cannot uncheck the extension and it doesn't show-up.

On my Mac, the Chrome 14 upgrade did not break 1pw's extension.

1password: 1.0.8.216
Chrome: 14.0.835.163
Windows 7 x64 with all updates as of today, 9/17/2011.

Any ideas how I can fix this?

Thanks,
Mike

Comments

  • I am having the same problem. I read the Full Circle with 1Password + Chrome article and decided to implement those steps. After taking those steps, Chrome was still loading the old extension, so I decided to uninstall the 1Password extension. Now I'm a getting the same scenario as Mike where I can't install my 1Password Extension to Chrome. I've re-installed both Chrome and 1Password to no avail. Please help!

    Kenji
  • I was able to get my 1Password extension installed. What needs to be done is uninstall Chrome and select the option to remove the user data (User Profile). Once uninstalled, re-install again, check 1Password and the Chrome option should now be unchecked. Check this box and the extension will be installed correctly. If you don't want to loose all your user data info (extension, apps,bookmarks, etc.), I recommend you use Chrome's Sync account option, to fully restore your profile.

    Good Luck
    Kenji
  • DBrown
    DBrown
    1Password Alumni
    Kenji, welcome to the forum, and thanks for the useful tip!

    If you use 1Password and Chrome on the Mac, too, be careful with the sync feature built into Chrome: if you sync extensions, you could end up with the 1Password (Mac) extension on your PC or the 1Password (Windows) extension on your Mac, and they won't work on the wrong platform.

    Mike, please let us know whether Kenji's tip helps you.
  • Thanks Kenji,

    Yes, the uninstall worked. HOWEVER, I would not consider that a "solution" - requiring the removal of an entire browser and reconfiguring of all extensions/history/etc. is pretty inconvenient. I work supporting enterprise virtualization software, and if I told my customers to uninstall another party's tool to fix a plugin my tool should be installing correctly, I'd get called to the mat.

    I believe that Agile needs to investigate this issue further and try to find an actual solution that isn't as impactful to the customer. For now, this is the first problem I've had with 1pw, so I'm willing to overlook it, but if this kind of thing happens again, I'll be opening a support ticket.

    Anyway, I'm working again. David, please see that this issue gets looked into and doesn't just die, so it doesn't happen again when Chrome 15 or whatever comes-out. It's a genuine product enhancement opportunity.

    Mike
  • DBrown
    DBrown
    1Password Alumni
    Mike, the problem is that we can't reproduce the problem here...any of us, on any of our test machines. For example, I've gone through each Chrome revision since 7 or 8, and I haven't seen this problem once.

    Obviously, it's hard to fix a problem when we can't see it, because there's no way to find out what's causing it. So we're thrilled that Kenji found a workaround, albeit inconvenient.

    We really are sorry not to have a more satisfying answer.
  • svondutch
    svondutch
    1Password Alumni
    If someone is having this problem, can you please send me this file?

    C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default\Preferences

    Thanks!

    stefan AT agilebits DOT com
  • Thank You for the Tips.

    After Re-Install Chrome, i can install the extension. Good! :-)
  • DBrown
    DBrown
    1Password Alumni
    That's great news, codepiX. Thanks for letting us know, and welcome to the forum!
  • micsaund
    edited September 2011
    David - I understand. There have been many times I've had to work "blind" on an issue like this. However, it is something to keep an eye out for (put an "alert" on internally, or however you manage issues) and collect more data for a full resolution. codepiX's response just since my post indicates this is not a one-off thing.

    Please, don't think I'm blowing this up into anything huge at all, but I do love 1pw and when I have an issue like this, it's a real thorn in the side simply due to the level of perfection that I've come to expect. My analogy would be the A+ student who gets a C is "bad" but the C student who gets an A is "great". You guys are the A+ students ;)

    Stefan - if I see this again, I'll capture that file for you.

    Mike
  • DBrown
    DBrown
    1Password Alumni
    edited September 2011
    Thanks for your follow-up, Mike!
  • dougb
    dougb
    Community Member
    I just experienced this and fixed it but for some reason overlooked this post when I was looking for answers. I was syncing everything in Chrome and use both Mac OS and Windows.

    Anyway, I used Sysinternals' Process Monitor to see what 1Password was looking at when you went to the browser settings. That got me to the Chrome Preferences file. I searched for 1Password in there and found that there was a lingering reference even though the extension wasn't installed. I deleted that section and restarted 1Password. The box was no longer checked and I was able to re-install. Unfortunately, I didn't capture the state of the Preferences file prior to making the change and there were no line breaks in the file (not even Unix line breaks) so I can't say exactly where it was. Based on the current state (which now has line breaks), I believe it was in the "plugins" section and I deleted something like:

    {
    "enabled": true,
    "name": "1Password"
    [... there was other stuff here I think, but there isn't now]
    },

    Hope this helps.
  • DBrown
    DBrown
    1Password Alumni
    Thanks, Doug.
  • svondutch
    svondutch
    1Password Alumni
    If someone is having this problem, can you please send me this file?

    C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default\Preferences

    Thanks!

    stefan AT agilebits DOT com
  • elvaen
    elvaen
    Community Member
    I was having this exact same issue -- Stefan, I just sent you an email with my preferences file.

    I then uninstalled Chrome, including user data, and reinstalled and my extension is working again.

    I've turned on chrome sync again, but this time I've left the "extensions" part of the sync disabled.
  • DBrown
    DBrown
    1Password Alumni
    Yes, it's only extensions that Chrome shouldn't be allowed to sync between the Mac and the PC, if you're also using 1Password on both platforms.
  • svondutch
    svondutch
    1Password Alumni
    elvaen wrote:

    I was having this exact same issue -- Stefan, I just sent you an email with my preferences file.


    Thanks! Unfortunately, I do not see anything wrong with the preferences file you have sent me.

    Initially, the checkbox is off (Chrome extension is not installed). When I install the Chrome extension, then it appears in Chrome and the checkbox stays on, not matter how often I visit the 1Password preferences.

    The same goes for uninstalling the Chrome extension; when I uncheck the box, then the Chrome extension is uninstalled and the checkbox stays off on subsequent visits to the 1Password preferences.

    Am I missing something?
  • DBrown
    DBrown
    1Password Alumni
    Stefan, the problem being reported is that 1Password shows its Chrome extension as enabled, but Chrome doesn't list 1Password on the Extensions page, and the 1Password tool isn't present in the Chrome tool bar. Folks in this situation can't use 1Password to enable the extension, because 1Password already shows it as enabled.

    The only workaround mentioned so far is to uninstall Chrome (and all its user data), which folks understandably find less than optimal.

    I saw this problem myself, months ago (with Chrome 11 or 12?), but I haven't been able to reproduce it in any recent update of 1Password.
  • svondutch
    svondutch
    1Password Alumni
    David, I understand the problem but cannot reproduce it using elvaen's preferences file.
  • DBrown
    DBrown
    1Password Alumni
    Your post described the way it worked for you (which is the way it's supposed to work) and asked whether you were missing something. I guess I misunderstood what you meant by the question. Sorry about that!
  • I had exactly this problem: Unchecked Chrome Extension in the 1Password Application but the checkmark reappeared when opening the Preferences/Browsers Dialog again and the Chrome Extension was away.
    Yes, I sync the Chrome Profile between my Windows Computers and my Chromebook including all Extensions. Currently I do not sync with a Mac.

    I was able to solve it by searching for "1Password" in the Chrome Preferences File and delete it. It was there 2 Times!
    You can download my Preferences File before and after here: https://www.yousendit.com/download/T2dmaXRLeFhVVGtPd3NUQw
  • DBrown
    DBrown
    1Password Alumni
    Welcome to the forum, cpohle, and thanks for that information!

    That may help the developer figure out whether it's 1Password or Chrome doing something wrong. At a minimum, it provides another tool to anyone in the same situation.
  • svondutch
    svondutch
    1Password Alumni
    edited October 2011
    cpohle,

    You're a life saver. Thanks to your preferences file, I have reproduced (and hopefully fixed) the problem. To be included with 1.0.8.220.

    Can you please download 1.0.8.220 and confirm the fix?

    Thanks!

    Stefan.
This discussion has been closed.