No matter what I do, 1Password extension won't work in Firefox on a single computer

edited June 2018 in 1Password 4 for Windows

Hi all,

I have three computers running 1Password in my office. In Chrome, it works fine on all three. In Firefox, it works fine on my desktop, but not on my laptop. The only difference between the two Firefox setups is one is Windows 10 (PC) and one is Windows 7 (laptop). On the W7 computer, the icon in Firefox remains grey. I have tried:

  • turning off all extensions
  • switching from web sockets to native messaging (which makes it stop working in Chrome)
  • clearing my cookies and cache
  • reinstalling both the main program and the browser extension

I've checked and both computers are running the same version of the main program ( and extension (

I paid for 1Password, this is not a demo version.

Thank you for any advice you can give!

1Password Version:
Extension Version:
OS Version: Windows 7
Sync Type: Dropbox


  • GregGreg

    Team Member

    Hi there @spamgirl,

    Sorry for the troubles! Please try to do the following on your Windows 7 computer:

    1) Install the latest .NET Framework 4.7.2 from here.

    2) Reboot your PC.

    3) Open 1Password 4 and go to Help > Advanced and make sure that you have Native Messaging enabled there.

    4) Go to 1Password 4 > Help > Restart 1Password Helper.

    5) Launch Firefox and let me know if it works for you after that.

    Thanks! :+1:


  • spamgirlspamgirl
    edited June 2018

    When I try #1, it says "The .NET Framework 4.7.2 is not supported on this operating system." I can't install SP1 because my computer stops working when I do. I assume that's the issue, thanks for your help.

  • Adding to this thread, I have two MacBook Pros running High Sierra and 1Password 7 with fully paid license. The extension works fine in Chrome and Safari, but it remains grayed out in Firefox in both.

    I haven't been able to figure out what to do to get it to work.

  • While I do not have 1Password 7, I do have 1Password 6.8.8 and I also downloaded Firefox v60.0.2 (recently) and enabled the 1Password extension only to see it grayed out and not responding to my requests (okay, mouse-clicks). I was able to bring the 1Password extension for Firefox to life by restarting the 1Password mini application.

    In 1Password (v6.8.8), go to Help -> Troubleshooting -> Restart 1Password mini

    Following this, the 1Password extension in Firefox immediately lit up, asked for my Master Password and I was in. I tested several sites and all is well with the 1Password extension in Firefox.

    I hope this helps!

  • GregGreg

    Team Member

    Hi @spamgirl,

    Windows 7 is quite old and we do not recommend you to use it without SP1. Is there a particular reason why it doesn't work on your PC? Please let us know.

    @Eschel: This topic is about 1Password 4 for Windows, not 1Password for Mac. Could you please try to follow the steps that @ddyof3 provided above and let us know if 1Password extension works for you after that?

    Thanks in advance! :+1:


  • I have no idea why SP1 causes my laptop to constantly do blue screens of death, but it started after the Intel chip issues and my guess is the fix is at fault. If I format my computer and don't install and windows or system updates, it works. If I install SP1, it becomes unusable. Since I don't use that laptop for more than Netflix, I'm not super worried about it. I'll just continue to type in my password manually.

  • @Greg Apologies. I didn't see that until afterward. Thanks for the pointer.

  • brentybrenty

    Team Member

    @Eschel: Thanks for the update. I'm glad that helped! :)

  • brentybrenty

    Team Member

    @spamgirl: I'm sorry to hear that. Indeed, while I've been lucky in that regard, I know others have had some trouble with some recent Windows 7 updates. I'm not sure exactly how you would proceed, but I do believe that Microsoft pulled those so it may be worth looking into, especially with the manufacturer. Service Pack 1 was released in 2011, so it predates all of this by a wide margin. I couldn't tell you precisely what to do in your case, but I suspect that someone has found a solution to the problem you're having since then.

This discussion has been closed.