1P 7.1 Beta: Cancel During Edit Does Not Revert To Previously Saved Data

go2jogo2jo Junior Member

Seems this was an issue in previous release & seems to have returned with current 7 beta.

I was trying to troubleshoot an issue with my personal blog 1Password login.

At one point I decided to cancel a change I had made to the URL. To my surprise, the first attempt, I did not get a "Do you want to save ..." sheet and the change was saved anyway. I then tried to edit the same 1P Login. I deleted the URL and saved then empty field change. I then hit edit, pasted the url back and then hit cancel. This time I got the save sheet. clicked "Don't Save" and rather than revert to the empty URL field of the previous save, it saved the URL I had pasted into the blank field. This is so wrong!

So I tried this a few more times, and got the same results. The last time I tried it—and this is VERY odd—rather than a Save sheet, I got an Emptying The Trash sheet that would not go away. I ended up force quitting 1P.

I'm totally baffled why data is saved, and not truly canceled & reverting back to what was previously saved before I hit the Edit button.

Any ideas?

1Password Version: 7.1.BETA-1 (70100001)
Extension Version: 7.1.BETA-1 (70100001)
OS Version: macOS 10.13.6
Sync Type: 1P-Cloud
Referrer: forum-search:cancel does not revert change


  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @go2jo ,

    Thanks for reporting this. It appears though it is reverting the changes, but it just continues to display the new change. If you lock and unlock, you'll see it has reverted to the original value.

    Nonetheless, this is still a bug, and we will be fixing it as soon as possible.


    ref: apple-1922

This discussion has been closed.