Password Generator sliders unresponsive in Firefox [Resolved in 3.8.9.BETA-6]

edited December 2011 in 1Password 3 – 6 for Mac
Hi guys!

Maybe I found a problem with the Firefox extension:
I want to create a password using the extension. To change the length of the password suggested by the extension I move the slider, but the password doesn't change. Also the other two sliders (Digits, Symbols) have no effect.
The password is being updated though when I chech and uncheck the "Pronouceable"-Checkbox.

I'm using 1PW 3.8.11 (build 31205), Firefox 8.0.1 and Mac OS X 10.7.2. Restarting Firefox didn't solve the problem.

Any ideas?

PS: Maybe the same problem like in this post?


  • khadkhad Social Choreographer

    Team Member
    Can you tell me what version of the 1Password extension you are using in Firefox?

    Also, are you running the PopClip app when this happens?
  • I'm using the extension version 3.8.8.b4.
    No PopClip app.
  • khadkhad Social Choreographer

    Team Member
    Please try updating to 3.8.9.b2 and let me know if that helps. I remember seeing this issue in older versions of the extension, but I haven't seen it in quite some time. I am unable to reproduce it at this time on my own machine.

    Could you list the other extensions you have installed (or take a screenshot), and try disabling them to see if that helps.

    Thanks for you help in tracking this down!
  • JuliusHJuliusH
    edited December 2011
    khad wrote:

    Please try updating to 3.8.9.b2

    Done, didn't help!

    khad wrote:

    Could you list the other extensions you have installed

    - 1Password 3.8.9.b2
    - Adblock Plus 1.3.10
    - Translation 3.2
    - DownloadHelper 4.9.7
    - Evernote Web Clipper
    - Extension List Dumper 1.15.2
    - FxIF 0.4.4
    - Mehr Leistung und Videoformate für dein HTML5 <video>
    - News360 Periscope 1.0 (deaktiviert)
    - pdf.js 0.1
    - Readability 2.0
    - Tab Badge 1.7
    - Tab Mix Plus
    - 2.5.7
    - Xmarks 4.0.2

    Disabled all of them (except for 1P of course), didn't help either.
    Sorry, that I don't have better answers right now...
  • nachalniknachalnik Junior Member
    edited December 2011
    I just noticed this problem with the password generator and FF 8.01 as well. Currently using 1PW 3.1.12b4 with FF extension 3.8.9b2 on 10.6.8. If I open password generator, it shows settings I may have used in the past (length, digits, symbols). I can adjust these parameters with the sliders .... but nothing changes in the password fill box (the password remains the same as when the windows was open with those older parameters). The only way I can get the generator to create a new password is to first adjust the sliders to the parameters I want .... next check pronounceable ..... then uncheck pronounceable. When the window changes back to the unpronounceable password state .... a new generated password is there based on the new parameters. This behavior us only happening in FF (8.01). Everything works as it should in my other frequently used browsers: Safari/Web Kit and Iron (as well as in iCab and OmniWeb). Not sure when this problem started in FF (as I don't ever recalling it being a problem). Have not used Firefox to generate a secure PW for quite some time ..... until today. I've attached a compilation of screen shots.
    Other installed extensions: Adblock Plus, Cool Previews, Flashblock, NoScript, Readability, Vacuum Places Improved
  • khadkhad Social Choreographer

    Team Member
    If you disable the other extension, does the problem still occur? In fact, for testing purposes, if you are able to create a new OS X user account and only install the 1Password extension in Firefox in that new account, that will help narrow it down.

    The Guest account is perfect for this kind of testing since it is automatically created fresh each time you use it. (All the files associated with the Guest account are deleted when you log out of the Guest account.) Open the Users & Groups pane in System Preferences, click on the Guest User, and check "Allow guests to log in to this computer." Guests can then log in without a password and their data is deleted when they log out.
  • nachalniknachalnik Junior Member
    edited December 2011
    Is it possible that only JuliusH and I are having this problem? He's having the problem on Lion and I'm having it on SL. Did some further testing this morning. Turned on my daughter's computer (running 10.6.8 and using FF 8.0.1 with 1PW 3.8.11 and FF extension 3.8.8b1. Password generator worked fine .... sliders functioned as they should and generating a new password based on input variables. I then updated the FF extension to the latest beta (3.8.9.b3). Password generator sliders stopped working. I next updated the 1PW application to the latest beta (3.8.12b4) (same configuration as on my Mac). No change .... password sliders not working (unless, of course, you perform the work around of checking and unchecking the pronounceable box). Next, tried your suggestion of using a new guest account. Did so using FF extension 3.8.8 (since I no longer had access to the original 3.8.8b1 extension she had on her computer). Sliders would not function. Upgraded the extension to the latest 3.8.9b3 .... no effect, sliders would not function. Logged out and went back to her account. Thinking that maybe something was being done to FF .... reinstalled a fresh copy of FF8.0.1. No effect. Sliders still not functioning. Seems that everything was fine with the 3.8.8b1 extension .... after that .... problems. As pointed out .... not a huge problem, since it can be worked around with the pronounceable box. Just can't explain why this is happening. I also should note that I ran all of the troubleshooting routines in 1PW with no effect.
  • khadkhad Social Choreographer

    Team Member
    Is it possible that only JuliusH and I are having this problem?

    So far that is the case. I have not seen a single other report of this from any other user. :S

    That said, I think we may start seeing more reports. :P I am able to reproduce the problem here as well now. Perhaps there was a version mismatch before. In any event, I'll make sure the developers are on top of this.

    Thank you so much for providing that additional information, by the way. That seems to narrow down the introduction of the problem to a version between 3.8.8.b1 and the 3.8.8 final version. Very helpful!
  • Thanks for taking care of this! If you need further information, please let me know!

    btw... Why is the forum not notifying me of new posts even if I follow the topic`?
  • I'm having it, too, so there are at least three of us...

    1Password extension 3.8.9b2, 1Password 3.8.12.BETA-4 (build 31214), Firefox 8.0.1. Of the extensions JuliusH listed, I also have AdBlock Plus and Evernote Web Clipper.

  • khadkhad Social Choreographer

    Team Member
    Thanks for the additional info, John. As I mentioned above, we are able to reproduce the issue. It is something we need to fix on our end.

    Thanks for your patience!
  • WilDieterenWilDieteren Junior Member

    Changing password generating settings is not working reliably anymore, see the screen shot included. Changing Length, Digits and\or Symbols values do not change the password. The password only changes when either of the options Pronounceable, Avoid... and\or Allow... is changed. Additionally I have not been able to figure out how to get the password generator to repeat generating a password. Anybody else having this problem?

    I am on OSX 10.7.2, using MAS 3.9.2, extension 3.8.9b3 and firefox 9b5.

    Wil Dieteren
  • khadkhad Social Choreographer

    Team Member
    Hey Wil,

    I merged your post with this existing thread. Please see above and let me know if you have any other questions or concerns.

  • nachalniknachalnik Junior Member
    Thanks ..... PW generator slider unresponsiveness problem seems to have been fixed with the release of 1PW 3.8.13 (final) and/or Firefox extension 3.8.9b6. Tested and working fine under FF 9.0.1.
  • khadkhad Social Choreographer

    Team Member
    Thanks for letting me know it is working of you. I know Dave spent a lot of time resolving this as Firefox was giving us a lot of pain regarding this specific issue. I'm glad to know that his hard work was not in vain, and he will be happy to know it as well. :)
  • khadkhad Social Choreographer

    Team Member
  • Ken BruckerKen Brucker Junior Member
    I'm seeing this problem as well running 3.8.13 build 31233. I'm a bit perplexed about the versioning though since the previous post claims this is fixed in a build of 3.8.9 which would be an older release train, although with a new beta, that what I'm running.

    Running FF 8.0.1 with FF extension 3.8.8. Ah... now I think I see the answer. Previous post is referencing the Plugin version, not 1P core.
  • khadkhad Social Choreographer

    Team Member
    Previous post is referencing the Plugin version, not 1P core.

    Sorry for the confusion. This thread is in the browser extension forum, but I could have made that clearer.

    The screenshot above is from the Browser Extension Release Notes. You can find a link to them along with the beta extension(s) on our Browser Extensions page.

  • Thank you for fixing this!
  • khadkhad Social Choreographer

    Team Member
    Thank you for using 1Password! :D
This discussion has been closed.