1Password 5 and Safari 12 - Browser Extension Does Not Populate


I'm using 1Password 5.4.3 and I just started using the latest version of MacOS with Safari 12.0.1. The browser extension for Safari will not populate passwords. The password generator does work successfully, however.

I have tried uninstalling the browser extension, uninstalling 1Password, reinstalling 1Password, and reinstalling the browser extension. This did not work.

Any idea how to resolve the issue?

1Password Version: 5.4.3
Extension Version: 4.7.3
OS Version: 10.14.1
Sync Type: Dropbox


  • dancodanco Senior Member Community Moderator
    edited November 2018

    I can't answer your exact question, but wonder why you are on 1PW5. 1PW6 was a free upgrade to 1PW5, and you can still download it.

    1PW7 is the current version, but is a paid upgrade, either a one-time purchases or a subscription. If you want 1PW7, take a look at https://support.1password.com/why-membership/ for the subscription advantages.

  • I'm upgrading to a new Mac and I didn't know my license entitled me to 1PW6. I upgraded, and this solved the problem. Thanks!

  • brentybrenty

    Team Member

    @slueck: Just keep in mind that it's only a temporary respite. Apple has announced that it will be removing support for the old Safari extensions and also no longer maintaining their extension gallery in the near future. Only the new Safari App Extensions (which we added support for in 1Password 7.2) will work once that happens (next year is what they've said).

This discussion has been closed.