Windows & Mac - conversion from agile to opvault

I purchased 1Password quite some time ago. I started with 1Password on Windows and have version 4.6.4.626 installed on my Windows 10 machine. My vault was stored on Dropbox. I have been able to use that vault on my iPhone and iPad without any issues. Everything was working fine.

Today I set up a new Mac laptop and installed iPassword 7 from the app store. I also set up Dropbox and when I tried to access my vault it told me I needed to update the vault from agile to opvault. This message was received on the Mac Laptop, so I clicked to perform the upgrade. I assumed it would convert the vault and I would still have all my previous entries, but when I view the vault on the laptop it is completely empty.

When I try to access it on one of my other Apple devices (which had worked previously), it says that the 1Password.agilekeychain file cannot be found in Dropbox and syncing has been disabled.

When I try to access it on the windows machine, the same thing happens and the vault is completely empty.

On Dropbox I see a folder called 1Password.legacyagilekeychain and a file called 1Passsword.opvault.

No, I did not backup my file before updating to opvault, because that tip was on the web in the document I found after the fact, and was not indicated in the app on the Mac where I was originally told to perform the upgrade.

Can you help me get this working again? I use the app all my accounts and thus have a large number of records in it.

Thank you,
Alison


1Password Version: 4.6.4.626 and 7
Extension Version: Not Provided
OS Version: Windows 10 and macOS Mohave 10.14.1
Sync Type: Dropbox

Comments

  • @acairns you vault was stored in Dropbox folder 1Password.agilekeychain, after conversion your vault is now stored in 1Password.opvault and all your devices must open this vault instead. To prevent accidental mistakes of having both old and converted vaults working in parallel your original vault folder was renamed to 1Password.legacyagilekeychain.

    I'm not sure why you see nothing in the app that converted your vault, please send us a diagnostics report from that app so we can figure out what went wrong.

    Your best choice is to try and open 1Password.opvault and use it. In case it doesn't work - you can always copy 1Password.legacyagilekeychain (consider it as a backup) to 1Password.agilekeychain and use it the old way.

    Hope this helps, please let us know if you need more assistance and have a happy holidays!

  • Hi. I did try to open the opvault file previously, but it was then, and is now, still empty.

    I copied 1Password.legacyagilekeychain and renamed it 1Password.agilekeychain, and was able to open that to find my 320 logins and 33 notes. Whew! Thank you. :)

    Is there a link to a walkthrough that I should follow to do the upgrade properly? Do I need to upgrade to a newer version of the Windows desktop program?

    Thanks very much, and happy holidays to you as well.

    Alison

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @acairns,

    We're glad to hear that and on behalf of Serg, you're welcome.

    I hope you don't mind, I've noticed you've also written in via email and we'll reply to your email there as how to proceed because it is a bit complex when you have multiple devices in the mix and we should update one device at a time once it is working properly.

    ref: YDH-64662-463

  • Thank you. I will keep an eye out for that email.

    Happy new year.

  • MikeTMikeT Agile Samurai

    Team Member

    You're welcome and a Happy New Year to you as well.

This discussion has been closed.