Syncing issues between 1Password X Beta 1.18.2 and MacOS Desktop app 7.4.2.BETA



  • cryptochromecryptochrome Junior Member


    I want to chime in here because I had (and still have) the exact same issue. I had a very lengthy discussion and troubleshooting sessions with support in January 2019 and the problem has never been fixed. Here are some details from my case back then, maybe it's helpful for 1P staff looking into it:

    Case number: #REZ-51426-242

    There was a second case shortly after that, which was only discussed via direct email, so I don't have a case number. The email thread subject was "There are syncing issues. Again." and it started Feb. 4th, 2019.

    The jist of it and the conclusion was this:

    Many network firewalls and advanced routers have a session state table that gets cleared out if there is no traffic for a certain amount of time (differs from device to device). 1P is not keeping the existing sync session (over TCP) alive, so it times out. After a while, it tries to communicate again but the firewall has already dropped the connection.

    During the troubleshooting, 1P (Kyle Swank) created a special version of 1P that had a "Session keep alive" built in that I was asked to test for them. Unfortunately I never came around testing it and communications with 1P ceased (was my fault).

    I think you guys (1P) should pick up on that old support case (I am available to answer questions) as I am certain this is the same problem here is in this case.

    To the original poster: Do you use a hardware firewall in your environment or something similar?

    Also, I have been using this workaround ever since: When you change something in 1PX, go into 1P Desktop, switch between two vaults (select another one, then go back to the first one) and it immediately starts syncing.

  • ag_yaronag_yaron

    Team Member

    Hey @cryptochrome ,

    I dug out your old conversations with us and read through them. Too bad you haven't kept the communication alive at the time, as this issue might have been resolved by now :chuffed:

    I can definitely send you that special version they made for you back then so you can test it and see if you experience any improvement. If you'd like that, send us an email to [email protected] with a link to this forum discussion, then notify me here with the support ticket's code you received and I'll reply back with the link.

  • cryptochromecryptochrome Junior Member

    Hey @Yaron - I can test this but isn't that version utterly outdated by now?

  • ag_yaronag_yaron

    Team Member

    @cryptochrome In theory it should have still worked, but I just tried it and there's an expiration date on it, so it doesn't launch the app after installation.
    I'll contact our devs and see if we can get this test fix into a more recent build.

  • cryptochromecryptochrome Junior Member

    Sounds good, thank you.

  • This is happening again. I've attached a diagnostic report to my previous support case for further reivew. I've tried restarting just the 1password for Mac app and it's still not showing up so hopefully the diagnostics reveal some info about it.

  • ag_yaronag_yaron

    Team Member
    edited June 2020

    @cryptochrome Can you please email us with a link to this discussion to [email protected] so we can continue there?

    ref: KTN-85181-262

    @bradical Thanks for sending a new diagnostics report, our team will be with you shortly.

    ref: CLD-29938-213

  • Good stuff guys I thought I was going crazy every time I say the password it doesn't sync to my other devices and I have been looking for a fix for months however I still don't see a fix or is there some of the settings that I need to change anyone got a screenshot of how they should look?

  • Hey @dehek. Just to clarify, is it from 1Password X that you're saving? If, after you save a login, you check your account on the web at, do you see the item in question?

  • Yes all the passwords are saving online, however they are not synchronising back to my other apps.

    How do I broadcast new logins to my other devices?

  • ag_anaag_ana

    Team Member


    Have you logged in to your 1Password account on your other devices already?

    How to add your 1Password account to the apps

  • dehekdehek
    edited October 2020

    I was hoping that would be pretty obvious. I can see all my other passwords just when I save a new password it doesn’t turn up on the other devices straight away.

    So the problem I am having in short... when I’m on a web browser on my desktop and I create a new password it doesn’t sync with my other devices.

    My other devices are working I can see all my password and user names but not the recent ones that have just been added from my desktop that was my question sorry I didn’t make it very clear

  • ag_yaronag_yaron

    Team Member

    Hey @dehek ,
    Thanks for clarifying.

    In order to figure this out, let's try to trace the newly created item and see where it gets stuck.
    Please try the following:
    1. Save a new login in your browser.
    2. Log into your account at, select the vault you saved the new login in and see if it is actually there.
    3. If the login is not there, then you probably saved it in a local vault that exists in your 1Password desktop app, which means it doesn't sync to other devices. If the new login item is indeed present in your account, then it synced to our cloud service correctly and we should move on to inspect other devices.

    Let me know which of these options occurred on your computer.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file