I deleted the 1Password account credentials from 1Password...

edited August 27 in Windows

and also from the archive.

I then used my emergency kit to login back again, but when I save the new login to 1Password it stores the Master Key in clear text, as shown on this image:

Before this, there has been a password field for this named "Secret Key"... Am I supposed to create that by hand? Because I tried that, but then it does not get used on login, leaving the field on the website empty.

How do I get this working again without having my Master Key in clear text.

1Password Version: 8.2.2-6.BETA
Extension Version: Not Provided
OS Version: Win10


  • @Atndlr Changing the field type of the Secret Key to "Password" should hide the text.
    Login in to my.1password.eu, click on the 1Password account login item and click on Edit in the bottom right hand corner of the screen.
    Click on the three dots (...) next to the Secret Key, click on Password in the dropdown list and then click on Save in the bottom right hand corner of the screen.

  • AtndlrAtndlr
    edited August 27

    Oh, I see... why can this not be done from the windows client?
    Thank you very much!

  • @Atndlr Glad that fixed it. You can do it from the Windows app, but the layout is different and I'm not using 1Password v8, so I thought it safer to give you the instructions for the website.

  • Okay, to clarify. It can not be done in v8. Unless there is some very obscure trick to do it, it is not possible now to change the type of a field afterwards.

  • PeterG_1PPeterG_1P

    Team Member
    edited August 28

    Hi @Atndlr , I'm sorry to hear about the trouble regarding this. I have noted your request for the ability to change these fields and have put in an issue with our developers. Thank you for your feedback here!

    ref: dev/core/core#9759

  • Thank you @PeterG_1P!

    I have an addition to this case.
    When doing what was proposed (changing the text field to a password field for the master key), the master key does not get filled in on my.1password.eu anymore.

    So, the master key is protected from view by changing it to a password field, but it makes loggin in to 1password a chore, as you have to copy the field manually.

  • ag_anaag_ana

    Team Member


    Just to make sure we have all the details: you mentioned that you are not able to fill the master key automatically on the website after changing it to a password field. However, in your first screenshot it shows that the password field was already marked as a password field, and you changed the type of the Secret Key field instead.

    Which one of the two fields is not filling for you automatically?

  • I needed to create a new entry for my 1password account, after I accidentically deleted it (also from the archive).
    After creation of the new entry the value for the secret key (sorry for the confusion) was saved as text-field in 1password, which I wanted to change. Which was not possible in the v8 client of 1password. I then changed that field on the website to a password field.
    After doing this, the secret key does not get filled in automatically anymore and the field on the login is left empty.
    When I change back the secret key to a text field, it does get filled in automatically again.

    What I do not understand: On my initial entry of the 1password account, the secret key was a password field, but obviously, as I found out it was previously filled using the saved webform data, which does not seem to exist on newer 1password entries anymore. What I want to achieve is that my 1password account can get stored in 1password with the secret key hidden from view again.

  • ag_anaag_ana

    Team Member


    Thank you for reporting this! I was able to reproduce this issue on my machine, so I will open an internal issue so that the developers can look at this :)

    ref: dev/core/core#3988

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file