Webpage keyboard scrolling issue in Safari

fishbertfishbert Junior Member
Community Member

Ever since updating from 1P7 to 1P8 and installing the Safari extension, I've had this issue where using the up/down arrows to scroll a webpage (say Google News, Reddit, this forum, etc.) doesn't work properly. The down arrow may shoot you all the way to the bottom, the up arrow may shoot you all the way to the top, or they may do nothing at all. When it happens, every window and every tab have the issue. To fix it, you have to quit and restart Safari.

The issue doesn't happen right away, and I wish I had some specific steps that would cause it. But I can say that I never experienced this issue before installing 1P8 and the Safari extension, and in normal usage of the computer since 1P8 release day, it's happened multiple times each day – super annoying.

I'm hoping others have seen this as well and may know more about how to get it to misbehave in a troubleshooting-friendly reliable manner.


1Password Version: 8.7.0
Extension Version: 2.3.3
OS Version: macOS 12.3.1

Comments

  • fishbertfishbert Junior Member
    Community Member
    edited May 5

    Ah, there we go... it appears this issue occurs any time I use the auto-fill hotkey (⌘+).
    And it happens whether auto-filling a login or not.

    For example:
    1. I open Google News website
    2. keyboard scroll to my heart's content
    3. hit the auto-fill hotkey
    4. 1P8 Quick Access pane appears
    5. I dismiss the Quick Access pane
    6. keyboard scrolling is borked in Safari until I quit & restart

  • ry319ry319
    Community Member
    edited May 9

    I'm also having this issue on two computers (both MacBook Air, M1, macOS 12.3.1, 1Password 8.7.0). I've also confirmed the same steps let me reproduce the issue: if Safari scrolling is working correctly, and then I open the 1P8 Quick Access pane, Safari scrolling breaks immediately after.

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @fishbert / @ry319:

    I was able to replicate this on my end, so I've filed an issue to see if we can get this sorted out. Thanks for letting us know about this!

    Jack

    ref: dev/core/core#15151

  • DancingTableDancingTable
    Community Member

    I am also having this issue. Hoping for a fix soon. For now I turned off the keyboard shortcut for auto fill but that makes 1password significantly worse to use

  • paul.m_1ppaul.m_1p

    Team Member

    Hey @DancingTable! Thanks for the further feedback.

    Our team is actively working on implementing a fix for this issue. If you're keen to see it as early as possible, it may be worth getting on the Nightly or Beta channel for a sneak peek. Here is a guide on getting on those update channels -> Use 1Password beta releases - (for Nightly, you can select that from the 'Release channel' selector referenced in the guide).

    I hope this helps! 🙂

  • DancingTableDancingTable
    Community Member

    Is the fix currently in the Beta channel? As soon as it is there, I will happily switch over to it, but not until it is there.

  • nickv2002nickv2002 Junior Member
    Community Member
    edited May 24

    I can confirm this still happens with

    1Password for Mac 8.8.0 (80800094), on BETA channel
    With 1Password for Safari version 2.3.3 from the Mac App Store

    It also seems to prevent me from navigating forward and back using command left/right arrow keys.

  • ag_tommyag_tommy

    Team Member
    edited May 24

    @DancingTable

    My apologies it looks like the team is still looking into this.

  • jsorgejsorge Junior Member
    Community Member

    I'm also seeing this consistently and have chatted with support. The way I fix it is:
    1. Quit Safari
    2. Open the System Preferences to Security & Privacy
    3. Toggle 1Password in the Accessibility Privacy column
    4. Open Safari back up

    What's crazy is that the problem resurfaces even if I auto-fill in one of the apps (my VPN for example which requires me to log in every day. It's so great that 1Password can now auto-fill it, but it's maddening that it also breaks Safari).

    Hope this workaround is helpful in the meantime. I wish there were some way to automate it.

  • DancingTableDancingTable
    Community Member

    This honestly should be the #1 issue to fix, but it seems it isn't. If it isn't soon, I will have no choice but to jump ship to bitwarden or another competitor. I love 1password, but I cannot continue using broken software.

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @DancingTable / @nickv2002 @ry319 / @fishbert:

    I just wanted to follow up and let you all know that beta 8.8.0-104 contains the fix for this! If you'd like to give the beta releases a try, follow the steps here: Use 1Password beta releases

    Jack

  • nickv2002nickv2002 Junior Member
    Community Member

    Beta 8.8.0-104 is working well for me and seems to have fixed the issue thanks

  • Jack.P_1PJack.P_1P

    Team Member

    Glad to hear it @nickv2002! Feel free to get in touch if there's anything else we can help you with.

    Jack

  • jerroldpjerroldp
    Community Member

    Can confirm here too - Beta 8.8.0-80800143 is working again 🥳

  • Jack.P_1PJack.P_1P

    Team Member

    Glad to hear it @jerroldp! Feel free to get in touch if there's anything else we can help you with. 😀

    Jack

  • godboutgodbout
    Community Member

    i'm on 80800183, on BETA channel and it's still not working for me. even without log in, my shortcuts are broken when 1Password is launched.

  • godboutgodbout
    Community Member

    can you say hi to Matt for me? thanks a ton. xx

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file