How can I stop 1Password X from asking me to "Click OK to fill your 1Password item on..."?

24

Comments

  • ag_yaronag_yaron
    1Password Alumni

    Thanks for the clarification @chesterdesmond .

    Can you please test the following:
    1. Open Safari and go here: https://fill.dev/form/identity-simple
    2. Try to autofill an identity from the 1Password icon in your Safari's toolbar.

    Does it trigger the confirmation prompt?
    If so, would you mind testing this on our latest beta (which I'm using currently, and there's no confirmation prompt there)? You can install the beta from here: https://support.1password.com/betas/

  • chesterdesmondchesterdesmond
    Community Member

    There is no prompt upon Autofill, but the prompt comes up every time I click in a field after it's filled in. I will try the beta. Thanks.

  • chesterdesmondchesterdesmond
    Community Member

    Beta installed ... same exact behavior as before.

  • ag_yaronag_yaron
    1Password Alumni
    edited May 2021

    There is no prompt upon Autofill, but the prompt comes up every time I click in a field after it's filled in.

    That's what I was looking for. I was able to replicate the issue with that clarification.
    I have filed it internally for our devs.

    Thank you kindly for sticking through it with me! Hopefully that will be fixed soon :)

    ref: dev/core/core#7107

  • chesterdesmondchesterdesmond
    Community Member

    @ag_yaron The latest update seems to address the repeated prompts after Autofill, but at least in Safari, there is still on additional prompt after the first prompt (upon Autofill) when you click in any of the form fields. Some progress, so thank you.

  • kaitlynkaitlyn

    Team Member

    Thanks for the update, @chesterdesmond. I don't have much info for you at the moment, but I've nudged the developers to see if there's anything new to share. We appreciate your patience! ❤️

  • grahambgrahamb Junior Member
    Community Member

    I ended up on this thread after encountering this popup for the first time. I don't expect much, but if you're keeping count, add a +1 to get rid of this annoying feature.

    I've been a 1Password user since the very beginning. I was clinging to 6.8 for some specific workflow reasons but recently bit the bullet and "upgraded" to 1P 7 and a family subscription. As a developer I fully realize that there's a user-adjustment phase after a major upgrade, but from what I've seen so far I'm very much regretting my decision and am considering canceling my subscription and going back to my beloved 6.8, even if it means running in Rosetta on M1. The old 1Password did its job without getting in my way; the new version has a big "HAY IM 1PASSWORD LOOK AT ME!!!!11111one" problem. There's simply too much friction in 1P 7.

  • ag_yaronag_yaron
    1Password Alumni

    Hey @grahamb ,
    Thank you kindly for the feedback and input, much appreciated.

    If I'm not mistaken, it sounds like you might not enjoy the new inline menu where 1Password shows up inside/under fields to help you autofill and save new logins. You can turn that off if you'd like. Simply open your 1Password 7 desktop app -> Preferences -> Browsers -> Turn off the "Automatically show inline menu when selecting a field".

    That will make 1Password less intrusive and provide you with an experience you might like better.
    Thanks for adding your voice to the request here for removing the verification prompt!

  • marshallbumarshallbu
    Community Member

    I'm still getting the numerous (or most frequently never ending) prompts for "Click OK to fill your 1Password item on ". Before digging backwards on this thread, was there an update to address this? I actually like the inline menu, but the above prompt is maddening as I have to refresh the entire page to get out of the loop (and sometimes that doesn't work either).

  • ag_yaronag_yaron
    1Password Alumni

    Hey @marshallbu ,
    Can you please elaborate on that loop you're in? If you can provide me with a step-by-step instructions on how to reproduce it (including information on your setup), that would be most helpful.

  • marshallbumarshallbu
    Community Member

    @ag_yaron thanks the reply!

    I usually get stuck on forms when filling out CC info, especially when using the Privacy Card feature. Most recently, I tried creating a Privacy card for a Google Pay payment method. Once getting to the step of "Create and Fill", I get stuck with never ending prompts for "Click OK to fill your 1Password item...", on both hitting cancel or ok. Hitting either just results in a new prompt popping up. I usually have to reload the page or close/reopen the tab to get out of this state (haven't opened the JS console to see if there are any errors or useful output).

    In this scenario, I restarted Safari and 1Password, and now I don't get in a loop, but hitting okay doesn't save the new Privacy card or fill the form. I'd say in my usage of this feature especially, 70% of the time I get in this state and just resort to using the Privacy app directly, or the other 30% it works as expected.

    Currently using Safari 14.1.2, 1Password 7.8.7 (70807003), Mac OS X 11.5.1 (20G80)

  • BonesBones
    Community Member
    edited September 2021

    This topic has had lots of input and i suspect i am not fully understanding all of it. I have 7.7.810, & Chrome on Windows
    This thread says 1password X - i presume it is talking about all the browser experiences - sooo...

    I do NOT get pop-ups on passwords entered via the Web page field 1PW icon - Inline i presume that is called - this feels OK and expected - nice even

    I DO get pop-ups for Identities & CC (maybe more) entered via the Web page field 1PW icon - but NOT from the Browser addin menu

    This feels totally inconsistent on both fronts - Deference between passwords/logons & Identities/CC ? not sure its a significant distinction in reality. Also difference between inline and Menu initiated - absolutely zero - in both cates i am selecting the item and EXPECTING it to fill the form - ready for me to read and submit.

    I appreciate the loyalty to "security" - no compromise. However, the key value in 1PW is the safe storage and EASY use of important that secured info. It feels a pity to want to go back to Google for all but Passwords cos of usability differences.

    Anyway will watch with anticipation of yet another magical solution to the intractable problem of keeping ALL users happy :)

  • ag_yaronag_yaron
    1Password Alumni

    Hey @marshallbu ,
    Thanks for clarifying and for the screenshot.

    Seems like you're encountering a known issue in Safari with Privacy Cards at the moment. I added your report to our internal tracking log of this issue, hopefully it will be resolved in the next few updates of 1Password 7.

    An alternative solution would be to try the new "1Password For Safari" extension, which you can download from the App Store. The downside would be that this extension will not connect to the 1Password 7 desktop app, so you'll need to unlock it separately. However, the issue with the Privacy cards should not exist there.

    ref: apple-5232

  • ag_yaronag_yaron
    1Password Alumni

    @Bones ,

    The prompt to confirm autofilling of personal information / credit cards is a failsafe to make sure you weren't clickjacked to autofill that info on a hostile page.
    Some malicious websites can simulate a mouse click on the inline menu (although extremely rare and you probably won't ever encounter it), and sometimes the users just accidentally autofill by clicking the inline menu by mistake when it shows up with suggestions.

    We don't want users to fill in their full name, address and especially not their credit card by mistake or allow any possible malicious action to get a hold of that information, which is why when autofilling identities or credit cards via the inline menu will show the confirmation prompt.

    This prompt will only show if autofilling from the inline menu's suggestions, because that is where these situations can occur. Clickjacking is not possible via the extension's menu, and accidentally autofilling an identity/credit card via the extension's menu is a lot less likely to occur, which is why we don't show that confirmation prompt there.

    I hope that clarifies why we've implemented that confirmation prompt and when will it trigger :)

  • BonesBones
    Community Member

    Thanks yaron for the response and all yr patience.
    I do appreciate the logic - and the clarity of explanation.
    Also appreciate the judgement call on protecting us gooses from our selves :)
    i will continue to be hopeful that the bulk of opinion will inspire a change - until then will enjoy what i have in a great tools

  • ag_yaronag_yaron
    1Password Alumni

    Thank you kindly for the input and feedback here as well @Bones !
    It is much appreciated. We always consider users feedback so the more the better :)

  • FragTaggerFragTagger
    Community Member

    I'm using the 1password 8 beta with 1password for Safari extension and came here looking for relief from the confirmation window that pops up as shown by @ag_yaron above. Unfortunately, it's still doing it in 1password 8 with the safari extension. (I moved from 7 hoping it would be gone). I always assumed it was something Safari does, not 1 password. Is it? Because it is turning me into a rage monster.
    EDIT... to leave this comment, I had to create an account and I got the extra prompt again! See pic.

  • ag_yaronag_yaron
    1Password Alumni

    Hey @FragTagger ,

    As I noted in my comment above, this is a security mechanism we implemented to prevent websites from clickjacking you and autofilling your identities/credit cards into their malicious forms and websites.

    This prompt only shows up when you autofill an identity or credit card from the inline menu suggestions dropdown. It will not show up if you autofill an identity or credit card from the extension's icon in the browser's toolbar, since that location is safe from clickjacking and other malicious actions.

    I hope that clarifies the situation. Better safe than sorry :)

  • davenelsondavenelson
    Community Member

    @ag_yaron These popups make me want to stop using 1Password in my web browser, please add a way to disable it. I just filled out a form where I had the click that stupid OK button 6 times... ON ONE FORM! At least make it once per page.

  • ag_yaronag_yaron
    1Password Alumni

    Hey @davenelson ,

    Is that form publicly available? Can you send a link over so I can forward it to the developers as an example?

  • Hello @davenelson,

    Thank you very much for the link. I only need to select the OK button once to fill in my personal information on your site. In this case, can you please confirm if this issue occurs on all sites or just the one you sent us? If that happens on all sites, can you please try 1Password on a new browser profile to see if it makes a difference?

  • ag_yaronag_yaron
    1Password Alumni

    @davenelson In addition to what Nhat_Nguyen said, can you please also let us know which browser you are using and what is the 1Password extension version that is installed in it? :)

  • davenelsondavenelson
    Community Member

    I am using Big Sur and Chrome Version 95.0.4638.54 (Official Build) (x86_64) with 1Password extension version 4.7.5.90. I am sending a video to support to demonstrate the issue. On this form it asks twice https://rogueamoeba.com/soundsource/buy.php

  • ag_yaronag_yaron
    1Password Alumni

    Hey @davenelson ,
    Looks like you are using 1Password Classic in Chrome (version 4.7.5.9.0), which does not have a confiramtion prompt when autofilling at all.

    Did you get an automated reply from our system that contains a ticket number? If so, please post it here so I can locate it and view your video.

  • davenelsondavenelson
    Community Member

    Miles Parker did not include a ticket number in the email to me.

  • ag_yaronag_yaron
    1Password Alumni

    The ticket's number is included in the email's title. It should look similar to this format: [xxx-xxxx-xxx].
    In any case, if you've already gotten a response via email, let's continue the conversation there :)

  • laurenlaurenlaurenlauren
    Community Member

    Came here to add a +1 to all those that have commented. @ag_yaron and @ag_ana. I recently switched over from LastPass and am finding this popup to drive me crazy. I have never experienced anything like it with any password manager or autofill. I will likely switch back to LastPass unless this is fixed!

  • ag_yaronag_yaron
    1Password Alumni

    Hey @laurenlauren ,
    Thanks for chiming in.

    As mentioned above, if you autofill your identity item from the extension's icon on your browser's toolbar you will not see this prompt, it will only show up when you autofill your personal details (email, address, phone number, credit card) via the inline menu suggestions that show up under/inside fields, as a security mechanism.

    I will note your feedback and forward it as needed to the team though, thanks for sharing!

  • uliphantuliphant
    Community Member

    I too will switch if this is not fixed. It has to be functional, secure and user friendly. I don't want to pick just 2.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file