1Password 7.7.beta8 keeps asking me to turn on the safari extension

I've already turned on the safari extension.
Every time I clicked the 1password button, I saw the message in the window asking me to turn on the extension.


1Password Version: 7.7.beta8
Extension Version: 7.7.beta8
OS Version: macOS 11.0 Beta (20A5364e)
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @seanzxx!

    Can you please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and then relaunch 1Password? Do you see the same behavior now?

    1. Quit 1Password Completely
    2. Restart macOS
    3. Remove ~/Library/Containers/agilebits, ~/Library/GroupContainers/agilebits, ~/Library/Preferences/agilebits and Restart macOS

    I still see the same behavior.

  • Same issue on my side; the plugin loads as it will ask you to load a 1password login while entering an account or password.

  • ag_anaag_ana

    Team Member

    @seanzxx, @1safe093:

    Is the 1Password inline menu (the one that appears when you click directly in a form field) working for you instead?

  • Hi @ag_ana yes that is working for me. However, unlocking only works via de main menu in Safari (not unlock with the inline option).

    I'm happy to do some more testing if required.

  • There are two issues:
    1. The inline unlock doesn't work.

    1. The inline menu works while being asked to turn on the safari extension
  • That is the same issue as I have, but if you unlocked it in the main app; it will work in the browser (as shows above at @seanxx)

  • WildCatWildCat
    edited September 9


    When I pressed CMD + \ to trigger 1Password, it always show this screen.


    1Password Version: 7.6
    Extension Version: 7.6
    OS Version: 11.0 Beta (20A5364e)
    Sync Type: Dropbox

  • ag_anaag_ana

    Team Member

    Hi @WildCat! Welcome to the forum!

    Can you please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and then relaunch 1Password? Do you see the same behavior now?

  • I don't think this is a 1Password issue. I'm using 7.7-BETA8 and the inline menu completions appear just fine (but I get the same message as above when clicking the toolbar icon or using the keyboard shortcut).

    The only other extension I use is AdGuard - and clicking on the toolbar icon for that also gives a message that the extensions are not enabled. However, they clearly are enabled and still working properly.

    My conclusion is that Safari in the latest Big Sur beta either has some issues, or some changes were made that mean updates are required to extensions that have toolbar icons. However, there's nothing in the release notes that suggest either of these things.

  • ag_anaag_ana

    Team Member

    @SpookyMacSpook:

    My conclusion is that Safari in the latest Big Sur beta either has some issues, or some changes were made that mean updates are required to extensions that have toolbar icons. However, there's nothing in the release notes that suggest either of these things.

    I think you might be right. I am also using 7.7-BETA8, but I am on Catalina 10.15.6 at the moment, and I have never managed to get this message to appear for me. So far I have only seen this in Big Sur beta.

  • BenBen AWS Team

    Team Member

    That part (the inline menu showing as locked when it is not) is a known issue. We hope to have that fixed up soon. :+1:

    Ben

  • Awesome @Ben don’t leave us devs in the dark taking the BigSur jump :)

  • ag_anaag_ana

    Team Member

    We will do our best so this doesn't happen @1safe093 ;)

  • I know. I’ve been with you for years. Never been let down! I cheated with Dashlane, came back quickly.

  • ag_anaag_ana

    Team Member

    @1safe093:

    And it's good to have you back :D

  • I have a similar issue.. But, the workaround is if I completely quit 1Password and then restart, it works fine. However, I have to repeat this process after every reboot. I am on:

    1Password 7
    Version 7.7.BETA-8 (70700008)
    1Password Beta

    Thanks

  • r8ders2kr8ders2k Junior Member

    @ag_ana That (finally) worked for me as well.

  • jkratzjkratz Junior Member

    I'm using 1password 7 on the Big Sur beta 6 (public beta 3) and quitting 1pass completely from the menu and restarting it fixed the Safari issue for me.

  • jkratzjkratz Junior Member

    Just to note after a bit more testing. After I restart of the machine and logging back in I have to "quit completely" again before it works, every time. Which is odd since I just restarted the machine and haven't done anything as of yet.

  • BenBen AWS Team

    Team Member

    (thread moved to our Mac Beta category and merged with existing thread on the topic)

    Thanks for the reports on this, folks. :+1: We're looking into this.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file