Can't enable Safari extension on MacOS 11 Big Sur beta 6

On latest Big Sur developer beta build, (20A5364e) and 1Password 7 Version 7.7.BETA-8 (70700008), if I enable extension helper in the 1PW app and then enable the Safari extension, it initially opens showing logins, but after one restart, clicking on the extension in Safari brings up "turn on 1PW extension" which is already checked as being on. Turning extension or helper off and back on doesn't help.
Fix coming? I realize lots of beta here...


1Password Version: 7.7.BETA-8 (70700008)
Extension Version: Not Provided
OS Version: OS 11 dev beta (20A5364e)
Sync Type: Not Provided
Referrer: forum-search:big sur

Comments

  • ag_anaag_ana

    Team Member

    Hi @josephwit! Welcome to the forum!

    Thank you for reporting this! Our developers are aware of this bug on macOS Big Sur, hopefully it will addresses in one of the next betas :+1:

  • Great, thank you.

  • ag_anaag_ana

    Team Member

    You are welcome @josephwit! I am glad I could help :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • Ah, though it was fixed with 7.7.BETA-9 (70700009) - Safari extension installed and worked - asked to fill in blanks, love it! - until restart...
    Now again, clicking on the 1PW icon in Safari menu bar brings up "turn on the 1Password extension" though it is already enabled, as is the helper.
    (Now on Big Sur Beta 7).
    Keep at it! Can't wait!

  • ag_anaag_ana

    Team Member

    We will definitely do our best so this is ready for when Big Sur comes out @josephwit :+1:

  • Big Sur beta 9 seems to have fixed the issue of Safari 1PW extension working - but lost unlocking 1PW with Apple Watch, which was working before. 1PW opens with "Touch ID is unavailable with the cover of your MacBook closed"... I am running an iMac, no Touch ID. Option to set up Apple Watch is offered, but it is already turned on, and unlocks the iMac (but not 1PW),,,

    Just want to make sure your engineers are aware... Thanks!

  • Good follow up - Apple Watch issue FIXED by holding iMac power switch down 10 seconds, then restarting, per initial Apple instructions for resetting SMC. Everything working!

  • BenBen AWS Team

    Team Member

    Glad to hear things are working better for you, @josephwit. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file