7.7 Extensions not working with Mac OS Sierra

Hi,
Mac OS 10.12.6 (16G2136)
1Password 7 Version 7.7 (70700015)
Chrome Latest update Version 87.0.4280.67 (Official Build) (x86_64)
Safari Version 12.0.3 (12606.4.5.3.1)

Extensions have stopped working on both these browsers, I think this is due to the 7.7 update. I see that someone else has the same issue with another browser but same MAC OS so I suspect an incompatibility with Sierra.

Any suggestions other than an OS upgrade (I can't do that yet on this machine).

Thanks, Kevin.


1Password Version: 7.7
Extension Version: 4.7.5.90
OS Version: OS X 10.12.6
Sync Type: Not Provided

Comments

  • geekevgeekev
    edited November 19

    FYI - I have MAC OS 10.12.6 and 7.7 has stopped browser extensions working in Chrome and Safari , so given your experience I am pretty sure it is related to the 7.7 update and Sierra.

  • ag_anaag_ana

    Team Member

    Hi @geekev! Welcome to the forum!

    Can you please elaborate on what you mean by "stopped working"? What do you see/what happens exactly when you try to use the browser extensions in Chrome and Safari?

  • Hi @ah_ana,
    Thanks for replying. Yes,I should have been more specific :)
    CMD-\ seems to have no effect.
    Clicking on the extension button also seems to have no effect.
    This is with the desktop app open and unlocked.

  • ag_anaag_ana

    Team Member

    @geekev:

    Thank you! I wonder if refreshing things will be enough to help here. Can you please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and then relaunch 1Password? Are the extensions working again now?

  • Hi
    Same problem here: Safari works, Brave, Firfox and the menubar widget don't. Quitting and restarting and even restarting my Mac don't help.
    Little detail: in the main app 2 german translations miss: Edit -> Bearbeiten and Convert to login -> in Login umwandeln

  • ccstoneccstone
    edited November 23

    Greetings,

    1Password 7.7 is completely discombobulated on my macOS 10.12.6 (Sierra) system.

    1Password Google Chrome Extension 4.7.5.90.

    The app seems a bit slow.

    Mini will not open reliably either via mouse-click or keyboard shortcut. At some point it completely quits responding, unless the 1Password app is open and frontmost.

    Mini will NOT fill passwords in Google Chrome (87.0.4280.66).

    The Chrome browser extension fails to connect to 1Password, and when error-collecting is turned on it throws continuous errors.

    The global Mini keyboard shortcut (if it works) makes the 1Password application visible when it has previously been hidden. (This also happens in 1Password v7.6.) Bad behavior in my opinion. If I want to see the app, I'll activate or otherwise unhide the app myself. Mini should not do it for me...

    Thank heavens I kept 1Password 7.6, or I'd have been left completely twisting in the wind...

    Yes, I tried:

    Reinstalling the 7.7 app.
    Reinstalling the Chrome extension.
    Rebooting.

    I went through this whole process twice and other investigative efforts. Overall I wasted about 2 hours of my time.

    No amount of troubleshooting solved the problem -- ONLY reverting to 1Password 7.6 got me up and running again.

    Not fun.

    -Chris

    ref: INY-91252-577

  • ag_anaag_ana

    Team Member

    @o99, @ccstone:

    I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    We will be happy to help you with this. To avoid sharing your account information here, can you send us an email to [email protected] from your account's registered email address so we can continue the conversation there?

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Tony_OTony_O
    edited November 21

    ag_ana, your tip to quit 1Password completely and then restarting it again, worked for me (Big Sur). The extensions are correctly linked into browsers again allowing use of short keys. Thank you

  • ag_anaag_ana

    Team Member

    You are welcome @Tony_O! Thank you for letting me know :)

  • Same problem after latest Google Chrome update. Nothing happens when I click the mini in the extension. I am using OS Sierra. Extension version 4.7.5.90. Using 1Password 7.7
    I can open it in Safari sometimes but it no longer autofills. Have restarted everything (my laptop, quit and rebooted Chrome, quit 1Password.

  • The problem only started after I updated Chrome to Version 87.0.4280.67

  • sammyassammyas
    edited November 23

    I have the same problem. OS Sierra, Chrome version 87.0.4280.67. I tried to uninstall and reinstall the latest versions of 1password Chrome extension and then tried to uninstall the 1password extension and use 1passwordX browser extension. The 1password chrome extension work at all (nothing happens when I click on the extension icon), and the 1password Mini doesn't open at all. 1password X does work to autofill passwords but doesn't prompt to save passwords on new logins. Have restarted my laptop and uninstalled and reinstalled 1password app on desktop.

  • I'm also having problems with 7.7 on MacOS Sierra (10.12.6). The 1Password application opens fine, but the menu-bar icon only opens 1Password Mini occasionally -- mostly, it just highlights the icon momentarily. Browser extension 4.7.5.90 in Brave V1.17.73 also does not open, just highlights. Same behavior in Firefox 83.0 and Opera 68.0.3618.173.

    Also, once I open the 1Password app itself, it does not display its menu bar. Instead, I still see the previous application's menues (Firefox, Finder, etc).

    And I'm rather worried by seeing this on the Mac download page (https://1password.com/downloads/mac/):

        Requires macOS High Sierra 10.13 or later. 
    

    If that's so, then why did the previous version of 1Password offer to update itself to 7.7 on my system at all?

  • Requires macOS High Sierra 10.13 or later.
    If that's so, then why did the previous version of 1Password offer to update itself to 7.7 on my system at all?

    Quite. I didn't see the download page, because I updated from the app itself.

    When I did go to the downloads page I was looking for an updated Chrome browser extension not the app itself, and I totally missed the "Requirements" line.

    As @chinfuzzy observes the 1Password app itself seems to have functioned on my system, although it was a trifle slow.

    Mini and Chrome extension dead in the dirt.

    -ccs

  • And I've just emailed a diagnostics report to [email protected], and got back ticket ID [#UJF-73641-249].

  • BenBen AWS Team

    Team Member

    Hi folks,

    1Password 7 does indeed have a "soft" requirement of macOS High Sierra. This is not new with v7.7. 1Password 7 will allow you to install it on Sierra, but it is not officially supported. Because it isn't officially supported, we don't test against it.

    We have seen an uptick in reports of problems with the extensions working on Sierra. We are investigating these reports. In the meantime, if at all possible, I'd highly recommend upgrading macOS. That may ultimately be the only supported resolution here, but we do want to at least see if we can determine what the difficulty is, and then we can go from there.

    Ben

  • Ben, Is there a way to uninstall 7.7 and reinstall 1password 7.6 on my Mac? The older version worked beautifully. I'm in OS Sierra 10.12.6

  • I was also surprised by this. I'm on Sierra and the auto-upgrade caused extensions to stop working. I realize it's an old OS and maybe hard to support. Can I downgrade 1pw? (I'm on MacOS 10.12.6; latest Chrome).

    Upgrading the OS on this computer not a good solution for me. I run the old OS because I have discontinued apps I use for my work that require it. Thanks!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file