1Password doesn’t work on my oppo

I’ve had on my OPPO A73. I’ve posted about this before about a year ago and the issue is still not resolved. I can make it work temporarily by going to accessibility in settings and turning on 1Password in services but it doesn’t last. It ends up just turning itself back off again. Does anyone know how to fix this? I googled it and went through a process but it doesn’t work.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • periperi

    Team Member

    Hey @asukulu. Sorry to hear you're having trouble using 1Password's accessibility service on the OPPO A73. Unfortunately, it sounds like your device is disabling our service in the background, which isn't something 1Password can get around. However, you can adjust some settings on the device to see if it stops this from happening. Please follow all of the following steps:

    1. Pin 1Password to the recent apps screen.
    2. Go to the device's Security app, and from there enable 1Password in the app list inside startup manager and floating app list.
    3. Turn off battery optimizations.
    4. Go to the device's Accessibility settings, and give the 1Password service a persistent notification to remain in the foreground.

    Hopefully that helps!

  • It works but as soon as I put phone screen to sleep then wake back up accessibility turns off again.

  • ag_audreyag_audrey

    Team Member
    edited November 2020

    Hey @asukulu, I'm sorry to hear that didn't work out for you.

    We've found that the above steps that Peri listed usually work for most devices. If you go to your Oppo device's Security Center > Privacy permissions > Startup manager, were you able to enable Autostart for 1Password?

  • There is no setting called 'startup manager/enable autostart' . Floating windows is inside security not as peri has suggested inside startup manager but can see no 'autostart' option. I have switched on floating window for 1password but accessibility never remains enabled.

  • ag_audreyag_audrey

    Team Member

    Hey @asukulu, if you open up Startup manager, do you see a list of your apps? Is 1Password enabled?

    This is from Oppo's support website:

    Go to [Phone Manager] or [Security Center] or [Security] > [Privacy Permissions] > [Startup Manager] and turn on the button to allow the application to start on boot and start in background.

    Let us know how that goes!

  • As i already said there is no setting called "startup manager"

  • periperi

    Team Member

    Hi @asukulu Do you have App Optimization settings on your device? According to OPPO's user manual, there should be an option for this in the settings app on ColorOS 7.2. If so, can you make sure those options are turned off?

  • I found startup manager. It was in a difficult place to find. So I changed the setting you said and it made no difference.

  • ag_audreyag_audrey

    Team Member

    @asukulu, thanks for the update. Can you try locking 1Password in the background: https://support.oppo.com/au/answer/?aid=neu1313.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file