Unreliable WLAN sync with Mac

Mac OS version: 10.15.7 (Catalina)
Mac app version: 7.7 (70700015)

Android OS version: 11 (Pixel 4a phone)
Android app version: 7.7.2

This has been going on for years, the Android app has a hard time finding the Mac WLAN server to sync with. Sometimes it works, other times it does not, it's random. It appears that if I kill all 1Password processes on Mac and start 1Password it works.
Of course, both devices are on the same WiFi LAN.

I suspect this Bonjour discovery is problematic.

Suggestion: can you please add an option to the Android app where I can just enter the IP of the Mac WLAN server as a fallback plan for this unreliable Bonjour discovery?

(Please do not suggest that I move to a cloud account, I'm all aware of that but it just isn't for me, I just want local sync to work reliably)


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_audreyag_audrey

    Team Member
    edited November 2020

    Hey @411pass, I'm sorry to see you're having issues with WLAN sync on your Android device.

    To help us further dig into this issue, would you mind sending a diagnostic report from your Android device: https://support.1password.com/diagnostics/?android.

    Please attach the diagnostic to an email addressed to [email protected].

    With your email, please include:

    • A link to this thread: https://1password.community/discussion/117259/unreliable-wlan-sync-with-mac
    • Your forum username: 411pass

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here, so I can track down the diagnostic report and ensure that this issue is dealt with.

    Once I see the diagnostic report, I'll be able to better assist you. Thank you in advance!

  • I just got a Pixel 4a running Android 11 and have the same issue. Worked fine with my Moto G6 running Android 9.

    The message that is displayed on Android is as follows:

    Sync Results
    Resolving service: name: long [email protected], type: _1password4._tcp., host: null, port 0, txtRecord: ) …
    Discovery started for _1password4._tcp.
    Service resolved
    Can’t connect. Open 1 Password on your computer and ensure WLAN server is running.

    I can sync my iPad with no issues.

    I have been in email contact with [email protected] with trouble report LNE-59785-373. Basically I get told "I'm sorry for the trouble you're experiencing with WLAN sync, unfortunately, this syncing method is something we have very little control over." Which to me is an unsatisfactory answer. Even if WLAN server is some 3rd party code that Agile Bits has integrated into 1Password, they have to take responsibility.

    I agree with 411pass to add the option enter IP/Port. The WLAN server window could display it.

  • AgileBits does not care about local sync anymore. It's all about cloud subscriptions and recurring revenue.

  • I've had the same problem for at least a year too. I'm not on a new fancy phone. Just on Android 10. Syncing with a macbook is almost impossible. Sometimes you get lucky though when the planets align.

  • periperi

    Team Member

    WLAN server sync is the most technical sync method we support, and as such, most error prone. While there are some things we can help with, there's a lot outside of our control when using this method. For instance, the error could be happening between Apple's Bonjour service and Android's Network Service Discovery, it could be a result of some VPN, proxy, or firewall on your device or router, the strength and frequency of the Wi-Fi signal, or any number of other things.

    To add to that, there are a number of caveats to syncing 1Password for Android with the WLAN server, which we note on our sync page. You can only sync with one computer. Automatic sync isn't supported, and so sync needs to be manually triggered (by tapping Sync or swiping the page to refresh) on Android, and you can't sync directly between mobile devices.

    Because of this, we've published an extensive troubleshooting guide, which covers known solutions. I'm afraid if these don't work, the issue is beyond our ability to help. I'd recommend switching to a more reliable sync method.

    That said, I've tested WLAN sync on my Android 11 device and am able to sync reliably. I strongly recommend going through each thing on our troubleshooting list if you continue to have problems, or consider switching to another sync method. We'd be happy to offer a discount if you'd like to switch to a membership, so just reach out over email to let us know.

  • Simple solution to the extensive troubleshooting guide: add an advanced option to the app that lets me enter the IP and port of my Mac. Discovery problem solved.

    I can assure you that it's not the case there are firewalls, VPNs, etc. It's just random, unreliable discovery, that's all there is to it. It can be easily solved with my suggestion, if you have any interest in making it better.

  • @peri it could be an issue with discovery so let's bypass it and implement's @411pass suggestion since it seems the only purpose of discovery is to get the WLAN server ip/port for the app to connect. On my 1Password app for Android (v7.7.2), the only sync option from Settings>Sync for those without an account is WLAN server.

  • ag_audreyag_audrey

    Team Member
    edited December 2020

    We really appreciate the suggestion @411pass and the input @ZombyWoof!

    I've alerted our developers to investigate this, so we will let you know what we find.

    ref: dev/android/onepassword-android#1344

  • @411pass it looks like we are out of luck. Dave Teare's last email about 1Password for M1 Macs stated at the end "... please let me know if there’s anything we can can help with." So I took him up on it an replied and cited this thread. I got a reply from Amber "I'm sorry but there is nothing we can currently do and our troubleshooting is still limited to the steps in our troubleshooting guide." She did offer me a free year of the subscription but I'm not interested. I expect them to terminate the WLAN capability in the near future (1Password 8?).

  • periperi

    Team Member

    We've shared your request to bypass network discovery with our developers. Let us know if you need anything else.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file