1Password asking for master password to enable TouchID every time I invoke it

swittersswitters Junior Member
edited December 2020 in Mac Beta

I am being asked to enter my password in order to enable TouchID every time I invoke 1Password, whether opening the app or via the Chrome extension and or Apple menu bar. I have it set to only ask for the master password once every 2 weeks in the preferences.


1Password Version: 7.7.1.BETA-3 (70701003)
Extension Version: Not Provided
OS Version: OS X 11.0.1
Sync Type: Not Provided

«1

Comments

  • gillesgilles Junior Member
    edited December 2020

    I am experiencing the same issue with 1Password 7 Version 7.7.1.BETA-3 (70701003). I am running Mac OS X Big Sur 11.1 Beta (20C5048l).

  • I am also having this issue with 1Password 7 Version 7.7.1.BETA-3 (70701003), running macOS Big Sur 11.0.1 (20B29). My 1Password is set to prompt me for my master password once per week.

  • I am experiencing the same thing even though the prompt is set to weekly. I have tried toggling the prompt on / off, completely quitting 1P, and rebooting. It has been happening for about 4 days. Thank you.

    Big Sur 11.0.1
    1Password 7
    Version 7.7.1.BETA-3 (70701003)
    1Password Beta

  • I came here to find a solution for precisely this.

    I am using:
    1Password 7
    Version 7.7.1.BETA-3 (70701003)
    1Password Beta

    on:
    Big Sur 11.0.1

  • I have the same problem on my MacBook Pro 16" 10.15.7 with version 7.8 (70700015). Setting it to 1 or 2 weeks, I started getting prompted to enter the master password more often maybe a couple of weeks ago. Up to then, there was no problem. The frequency of the prompts doesn't display an obvious pattern.

  • rwarwa Junior Member

    Same issue

    7.7.1.BETA-3 (70701003)
    11.0.1
    M1 MacBook Pro

  • ag_tommyag_tommy

    Team Member
    edited December 2020

    The issue is being looked into by the developers. Hopefully, they can address this issue soon. I wish I had better news to share.

  • Same issue. Being asked for master password more frequently than every 2 weeks (despite settings). Pattern is not obvious but has often been once a day.

    1Password 7
    Version 7.7 (70700015)
    1Password Store

    MacOS Catalina 10.15.7 (19H15)
    MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports)

    (Aside from that, awesome product. Keep it going!)

  • ag_anaag_ana

    Team Member

    Thank you for letting us know your experience as well @damienh, hopefully our developers will be able to address this soon :+1:

  • I'm also experiencing this issue.

    1Password 7
    Version 7.7.1.BETA-3 (70701003)
    1Password Beta

    macOS Big Sur v11.0.1
    MacBook Pro (16-inch, 2019)
    2.6 GHz 6-Core Intel Core i7

    Thanks!

  • ag_anaag_ana

    Team Member

    Thank you for the system information as well @shelbourn :+1: And thank you also for your patience while our developers investigate this :)

  • @ag_ana You're very welcome! Thanks for such an awesome product! :smile:

  • ag_anaag_ana

    Team Member

    We appreciate the kind words @shelbourn :)

  • I had the App Store version with touch and watch enabled. The pop-up happened every time. I turned touch/watch off, deleted and reinstalled from the 1Password Store. Updated to 1Password 7 Version 7.7.1.BETA-3 (70701003) and re-enabled touch and I am not getting the pop-up any longer. Big Sur 11.0.1 2017 Macbook Pro 13-inch

  • ag_tommyag_tommy

    Team Member
    edited December 2020

    The developers have released a new 1Password beta 7.7.1 beta 4 that we hope resolves those pesky issues you have been facing once and for all. Please update and let us know how it goes.

  • Problem still exists with 7.7.1.BETA-4

  • Same problem on:
    Version 7.7.1.BETA-4 (70701004)

  • ag_tommyag_tommy

    Team Member
    edited December 2020

    @mtissington and @iamecho

    Can you try the following and let me know if you continue to experience issues?

    1. Disable Touch ID and/or Apple Watch unlock in 1Password Preferences > Security and in System Preferences
    2. Check for and install any available macOS updates.
    3. An SMC reset. https://support.apple.com/HT201295 (* if applicable to your device)
    4. Restart the Mac.
    5. Setup your unlock method(s) again.
  • @ag_tommy Worked for me! Thanks.

  • ag_tommyag_tommy

    Team Member

    Outstanding!

  • I installed beta 4 and and updated my OS to Big Sur 11.1 yesterday and so far it seems like the problem has been resolved for me!

  • No improvement with 7.7.1-BETA-4 (70701004) on my 10.15.7 MBP.

  • My AppleWatch worked fine to unlock 1Password last week with beta 4. Now it is not. And I have to enter the master password EVERY time I launch. I've got preferences set to ask for password once a week. I have an M1 Mac mini, so it's not a TouchBar issue: I either have to use my Watch (great function, thank you!) or type in manually.

  • XipperXipper Junior Member

    I am on an M1 Mini and have been having this problem since Beta4 updated, it is very frustrating. I have tried all of the steps outline, rebooting, resetting Apple Watch unlock, resetting SMC, etc.

  • I don't want to jinx it, but since I originally reported the early failure of 70701004, the overly frequent prompts to re-enter the password seem to have slowed down or even stopped.

  • And ... 1Password is once again asking to use my AppleWatch to unlock. What happened here? Why are things working again?

  • I also still have the same problem :(
    I tried resetting my SMC multiple times.

  • ag_tommyag_tommy

    Team Member

    @JeroenVdb

    Are you using the beta?

  • JeroenVdbJeroenVdb
    edited July 29

    I use:
    1Password 7
    Version 7.8.7.BETA-0 (70807000)
    1Password Beta

    MacOS Big Sur 11.4 (20F71)

    Can I switch to non-beta easily if that would solve the problem?

  • ag_tommyag_tommy

    Team Member
    edited July 29

    @JeroenVdb

    Sure you can stop the beta if you wish. It may be a good first step to take and make sure we are working from a solid platform. Here's how.

    1Password Support - Stop using the 1Password beta releases

    Here are the steps you'll need to take. * Step 8 is important. :smile:

    1. Quit all open web browsers.
    2. Look for our helper in the menu bar near the WiFi indicator and the clock. Right-click on the helper and select quit 1Password completely.
    3. Drag 1Password from the Applications folder to the Trash. Do not use an "app cleaner" or "uninstaller" tool to remove the app or additional files. If prompted, enter the password you use to sign in to your Mac.
    4. Restart the Mac.
    5. Download the latest version of 1Password from the 1Password website.
    6. Quit any open web browsers and then install 1Password.
    7. Open and unlock 1Password.
    8. Open 1Password > Preferences > Updates and uncheck the option for Include beta builds.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file