Why does Ctrl+Shift+X shortcut not work on Edge (Chromium version of edge) but works on Chrome?

xantarixantari
Community Member
edited January 2021 in 1Password in the Browser

The 1Password X extension does not obey the Ctrl+Shift+X shortcut within Edge (Chromium based version of edge) like it does in Chrome.

In fact the popup window actually doesn't show the Ctrl+Shift+X shortcut.

Why the feature differences when they are basically the same browser using the Chromium?

What it shows in Edge:

What it shows in Chrome:


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron
    1Password Alumni
    edited January 2021

    Hey @xantari ,

    In Edge it seems that the first installation of 1Password X is unable to set the keyboard shortcut in Edge's settings, but you can manually set it up like so:

    1. Right click the 1Password X extension icon on the top right corner of Edge and select "Settings".
    2. In the settings page, find the shortcuts section and click the "Change on the extension page" link. You'll reach Edge's extensions shortcuts.
    3. Click the 1Password X's field and press CTRL+SHIFT+X to set it as the active shortcut.
    4. Close the tab, go to one of your websites and see if that shortcut now works.

    Let me know if that helped.

    ref: dev/core/core#4017

  • chuckfromclechuckfromcle
    Community Member

    I'm having the same/similar issue myself. I've reset the shortcut several times, but Ctrl+Shift+X doesn't seem to be taking...I'm not seeing it set as the Open with shortcut key combination in the extension settings. I was able to set it to Ctrl+Shift+1 but don't want to keep that because it's different than I have elsewhere. I've tried removing and reinstalling the shortcut, too, but that didn't help. Any ideas?

  • ag_anaag_ana
    1Password Alumni

    @chuckfromcle:

    Our developers will be investigating this as soon as possible, they are aware of the reports ;)

  • chuckfromclechuckfromcle
    Community Member

    Ah, thank you!! :)

  • ag_yaronag_yaron
    1Password Alumni

    Hey @chuckfromcle ,

    It seems that Edge is now using CMD+SHIFT+X for one of its features, so you'll need to set up a different shortcut until we figure out what we can do.
    You can try using CMD+. (Command + Period) like 1Password in Firefox uses, or you can try several different shortcuts until you find the one you like most (and that works) :)

This discussion has been closed.