1Password now shares lock state with 1Password in the browser

Hi all,
can anyone explain me what does mean "1Password now shares lock state with 1Password in the browser."? I've seen it in the changelog of last beta 7.8.2.BETA-0 (build #70802000).

When I unlock the 1Password app, the Chrome Extension (version 1.25.5) is not unlocked accordingly. But I tend to have not got the sense of the new feature.


1Password Version: 7.8.2.BETA-0
Extension Version: 1.25.5
OS Version: macOS 11.3.1 (20E241)
Sync Type: 1Password cloud

Comments

  • edited May 5

    I'm seeing the same. The classic extension still shares it's state, but not the 'current' one
    Could require a beta update for the Chrome Extension?

    Edit: Yes, you need the beta version of the Chrome Extension - see: https://chrome.google.com/webstore/detail/1password-beta-–-password/khgocmkkpikpnmmkgmdnfckapcdkgfaf

  • edited May 5

    @limegorilla 1.25.5 is already the last beta version of the Chrome extension.

  • Huh. I did a fresh install - only thing I can think of. It's now working for me!

  • ag_anaag_ana

    Team Member

    @limegorilla, @wizard86pz:

    In other words, it means that the 1Password in the browser extension can now be unlocked automatically when the 1Password desktop app is unlocked :)

  • Great, I got it right so. But this is not happening @ag_ana...I see that @limegorilla seems to have fixed it re-installing the Chrome Extension...do you suggest the same?

  • ag_anaag_ana

    Team Member

    @wizard86pz:

    That would not hurt, but you can also try these suggestions from my colleague Yaron first :+1:

  • Thanks, before to reach this post I've simply rebooted the machine, and now it works good.

  • ag_anaag_ana

    Team Member

    Nice! Thank you for the update :)

  • edited May 15

    First time MAC user here:
    I have been loving the integration between 1Password X and the desktop App with my old Windows laptop and Vivaldi Browser.

    Just tried the same on MAC and it only seems supported with Chrome NOT Vivaldi?

    1Password 7
    Version 7.8.3.BETA-0 (70803000)
    1Password Beta

    1Password X
    Version
    1.25.6

  • ag_tommyag_tommy

    Team Member

    @Thomas_Griffiths

    Try using the Chrome link to install the extension within Vivaldi. It should work. I just installed it here an unlock indeed happen with the Mac app. Please let us know what you find.

  • @ag_tommy Restarted my macbook and all working as expected now :) thought that was just a windows thing.... :p

  • rudyrudy

    Team Member

    @Thomas_Griffiths,

    It normally is, in this case tommy could have said "quit your browser, quit 1Password completely (cmd + opt + control + q), launch 1Password and then launch the browser". logging out or restarting the machine works too. There is a rare scenario where the XPC connections between the various 1Password processes just don't work (returning an error code of -4099, NSXPCConnectionInvalid) and in that particular scenario the only thing i've found to resolve it is a reboot.

  • FogCityNativeFogCityNative Junior Member

    Thank you for implementing this . . . I still need to have 1Password in the menu bar, but I am using 1Password in the browser much more often when it is present and works.

  • ag_anaag_ana

    Team Member

    Thank you for the kind words @FogCityNative :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file