autofile broken after 7.8.4.beta-1 just installed

mlawdawgmlawdawg
edited May 21 in Mac Beta

autofill was working fine before auto-update from beta-0 to beta-1 occurred today.

Google Chrome is up to date
Version 90.0.4430.212 (Official Build) (x86_64)


1Password Version: 7.8.4.beta-1
Extension Version: 4.7.5.90
OS Version: 11.3.1
Sync Type: dropbox

«1

Comments

  • oops, autofill. sorry...

  • doetraardoetraar Junior Member

    Can confirm - it's also in Brave as a browser. Hitting command-\ will create a new tab in Brave with the same URL loaded that I was visiting when I tried to autofill.

    Version 1.24.86 Chromium: 90.0.4430.212 (Official Build) (x86_64)

  • Hello -

    On Catalina, Edge and Chrome (latest on all). I believe that following a browser update in the past day or so, the 1password extension stopped filling credentials and instead loads a new tab with the URL and doesn't autofill. Only way to fill the fields is copy and paste. Everything works properly in Safari. Please let me know what other info I can provide to assist with troubleshooting. Thanks!


    1Password Version: 7.8.4 Beta 1
    Extension Version: Not Provided
    OS Version: Not Provided
    Sync Type: Not Provided

  • Confirming @doetraar's report for Brave.

  • Same on Firefox/macOS. Opens a new tab instead.

  • faceface Member

    +1 the same issue on Chrome here (mac os x)
    filing credential open a new tab and not fill data in the opened tab

  • brentybrenty 1Password Alumni

    Thanks for reaching out! I'm sorry for the inconvenience. We're looking into what might be causing this.

    ref: dev/apple/issues#5360

  • +1
    Yep - same here!

  • Same.

    • 1Password 7
      Version 7.8.4.BETA-1 (70804001)
      1Password Beta

    • Version 90.0.4430.212 (Official Build) (x86_64)

    • OSX Big Sur 11.3.1 (20E241)
  • doofdoof

    Same here on Firefox with Temporary containers add-on - thought it might be to do with the add-on but maybe not?

  • renfororrenforor
    edited May 22

    I've been using 1P for many years, but all of a sudden cmd-\ no longer works in the browser. It lets me select a login, but instead of filling the form, it opens a new browser tab and shows the form empty. Same in Brave as in Chrome. Same in different sites (even logging in to this forum caused the same behaviour, no autofill).

    Safari, however, works.

    I've quit the menubar 1P, the browser, then tried again, same thing. It's the 7.8.4.BETA-1 (70804001) version, and I don't know when it installed.

    Brave Version 1.24.86 Chromium: 90.0.4430.212 (Official Build) (x86_64) does not work.
    Chrome Version 90.0.4430.212 (Official Build) (x86_64) does not work.
    Safari 14.1 (15611.1.21.161.5, 15611) with 1P extension 7.8.3.BETA-0 actually works.

    Maybe I have the wrong extensions?


    1Password Version: 7.8.4
    Extension Version: 4.7.5.90
    OS Version: OSX 10.15.7
    Sync Type: iCloud

  • Same here with 1Password 7 Version 7.8.4.BETA-1 (70804001) using Chrome 90.0.4430.212 and chrome extension version 4.7.5.90

  • wagneronewagnerone Member

    Came here to +1 this.

  • sfwaltersfwalter Junior Member

    Hi,

    In Chrome and Firefox when I press cmd+\ to auto fill it is opening the current browser window in a new tab and not autofilling. This just started to happen in the last couple of days


    1Password Version: 7.8.4.BETA-1
    Extension Version: 4.7.5.90 (Firefox Versions)
    OS Version: 11.3
    Sync Type: iCloud

  • Same here, I reverted to 7.8.4.BETA-0 to confirm the behavior was introduced in 7.8.4.BETA-1.

    MacOS
    Microsoft Edge
    Version 90.0.818.62 (Official build) (64-bit)

  • edited May 21

    I'm having the same issue, came here to post about it, but will add to the thread instead. This is extremely annoying. Something basic like this should not get broken.

    Happening on Chrome and Firefox as well (88.0.1)

    1Password 7 - Version 7.8.4.BETA-1 (70804001)
    macOS 10.15.7

    Update: I uninstalled and reverted to 7.8.3 version, which fixed this behavior, thankfully. Not a good present on a Friday, Agilebits.

  • same

    Firefox 89.0b15
    1Password Version: 1Password 7 Version 7.8.4.BETA-1 (70804001)
    Extension Version: 4.7.5.90
    OS Version: MacOS 11.4

  • jpotischjpotisch
    edited May 22

    I've been using 1Password for years on macOS/iOS (and singing its praises to anyone who'll listen!) and it seems like each time I upgrade 1Password or the browser extensions I get a little bit more confused about which extension I should be using. The desktop app seems to prompt me to install the classic one, but the newer one, while still not supporting Touch ID, looks to provide a more integrated experience. At some point I think I accidentally had both installed and form fields would prompt me to unlock 1Password from the top bar but that would unlock the classic extension not the new one. Cmd+\ fires up the old extension whether it's present or not and I can't set the new extension to take precedence on the same hotkey so I have to use the classic hotkey outside of the browser and an alternate one inside it. Sometimes form fields would show the 1Password icon but not populate until I refreshed the page or otherwise act fairly unstable. I just don't know if I'm in a recommended configuration or if I'm out on the bleeding edge testing integrations for you when really I just want to unlock things quickly and get back to doing my job!

    I see various things about whether I should be using the new extension vs. the classic vs. 1Password X and would like to hear official guidance like

    • "If you prioritize stability and Touch ID and use 1Password outside the browser, we recommend the classic extension"
    • "If you primarily use it in the browser and/or Touch ID is not of paramount experience, we recommend the new extension."
    • "Installing both extensions at the same time is not recommended" or alternately "If you install both extensions you'll get these X benefits, but be sure to take these Y steps so they don't conflict."
    • "By Q4 we expect the new extension to reach feature parity with the classic one and at that time we'll recommend everyone move to the next extension"
    • etc.

    Please just let me know where things stand so I can quit my growing side job of installing/uninstalling/reinstalling/configuring 1Password browser extensions!

    Thanks,

    -joel

    p.s. For now I'm on the beta desktop app with (I think?) the classic extension but I've tried every permutation of stable/beta desktop and extensions available in the past few weeks. I tried betas after reading release notes and 1Password posts suggesting a particular release might fix some of the problems I was running. I'd be fine going back to stable for both as long as stable actually felt stable!


    1Password Version: 7.8.4-BETA-1
    Extension Version: 4.7.5.90
    OS Version: macOS 11.3.1
    Sync Type: 1Password family membership

  • How does one revert to an older beta?

  • Thanks, had missed that thread.
    However, after updating the browser extension to current generation (1.24.3), it works again.
    I can't remember why I chose to install the classic extension before, but I'm sure I'll be reminded shortly. :)

  • same with Firefox ..

  • kop48kop48 Junior Member

    Ditto with Edge, and it opens a tab in a different profile to the one that I have active (I have 2 profiles in Edge)

  • miskomisko
    edited May 21

    Instead of filling in user name and password, Firefox opens new tab with same login url and empty input fields.

    I reinstalled classic extension (ver. 4.7.5.90), completely quit 1Password and reboot computer with no luck.
    Same issue in Firefox ver. 88.0.1 and Firefox Developer Edition 89.0b15

    Works in Safari and Safari Technology Preview without issues.


    1Password Version: 7.8.4.BETA-1 (build #70804001)
    Extension Version: 4.7.5.90
    OS Version: macOS 11.3.1, Mac M1,
    Sync Type: Not Provided

  • Good evening. Every time I try to log in using the latest 1Password Extension by using a keyboard shortcut, 1Password does not autofill the username nor password on the website I'm trying to log in. It also opens a new tab with that same website but it does not fill the log in information. This happens with all browsers, Safari, Chrome, Firefox and Microsoft Edge. I'm using the 1Password 7 Version 7.8.4.BETA-1 (70804001)
    Thank you in advance.


    1Password Version: 7.8.4.BETA-1
    Extension Version: 4.7.5.90
    OS Version: macOS Big Sur 11.3.1
    Sync Type: Not Provided

  • 1Password 7.8.4.BETA-1 (70804001)
    Firefox 88.0.1
    MacOS 10.15.7

    Suddenly, the cmd-. I always use to fill a password in Firefox started opening a new tab instead of filling the password. I tried uninstalling and reinstalling, which installed the new 1Password extension. The first time I tried cmd-., it told me I need the classic extension, so I followed the instruction to install that (two times), but cmd-. still opens a new tab rather than fill.

    By the way, I did try the non-classic-extension, and it requires a lot more mousing around than the classic and also exposed the names of web sites where I have identical passwords (a situation forced on my by an organization I must work with), so I do require the classic extension.

    As a side note: I do wish I had the option to get out of the beta track. I needed to be on it to fix a previous problem (more than a year ago), and now there's no way to un-select "Include beta builds" in the preferences.

  • I'm getting the same behavior on my MacOS 11.3.1 laptop.

  • Same problem here.

    MacBook Pro 15" with touchbar (late 2016)

    Microsoft Edge 90.0.818.62

    1Password 7
    Version 7.8.4.BETA-1 (70804001)
    1Password Beta

  • jonlsjonls
    edited May 22

    Ok, maybe this is my fault for turning on beta updates but . . . I have v7.8.4-Beta-1 and as soon as the new beta installed CMD + \ stopped working in both Chrome and Safari for filling in passwords. The extension comes up, let's me see what password to pick, and then opens a new browser window on the same page but fills nothing in. I tried downgrading back to the last full release to fix it, and that just caused the chrome extension to stop working completely. Any ideas?!


    1Password Version: 1Password 7.8.4.BETA-1 (70804001)
    Extension Version: 4.7.5.90
    OS Version: 11.2.3
    Sync Type: 1Password and Local

  • Add me to the list. Both Firefox and Chrome...

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file