autofile broken after 7.8.4.beta-1 just installed

2»

Comments

  • I'm seeing the same here: it started yesterday (05/21/2021) sometime.

    I'm on:
    • Big Sur 11.2.3,
    • Firefox 88.0.1,
    • 1Password 7, Version 7.8.4.BETA-1 (70804001)

    Cmd-\ opens up a new tab, does not enter the password.

  • Same here.

    1Password 7
    Version 7.8.4.BETA-1 (70804001)
    1Password Beta

    Chromium Edge Version 90.0.818.66 (Official build) (64-bit)

    macOS Big Sur 11.3.1 (20E241)

  • +1 to the "open new tab without credentials filled" issue.

    macOS Big Sur 11.3.1
    chrome Version 90.0.4430.212

    1Password 7
    Version 7.8.4.BETA-1 (70804001)
    1Password Beta

  • HRDHRD

    It will good to have an explanation as to why this update was shipped.

  • jessejesse Junior Member

    This issue seems pretty widespread in 7.8.4.BETA-1 (70804001). Appears to impact all browsers except Safari. Forced to downgrade to Version 7.8.3 (70803004).

  • Also seen here with 7.8.4.BETA-1. Downgrading to 7.8.3 also fixed things for me. (I did this by uninstalling, downloading 7.8.3, installing that, opening 1Password and then immediately disabling the preference to "Include beta builds" (see https://support.1password.com/betas/).

    It will good to have an explanation as to why this update was shipped.

    It's a beta release. Sometimes betas have bugs. If that's not a good fit for you, you should disable the option you checked to automatically install beta software. There's a picture of bug right next to the setting.

  • cipherswarmcipherswarm Junior Member

    Desktop version:
    1Password 7
    Version 7.8.4.BETA-1 (70804001)

    I was trying to resolve my in-browser password filling issue (https://1password.community/discussion/121014/autofile-broken-after-7-8-4-beta-1-just-installed), and ran into this.

    Steps to reproduce:

    1. Launch 1Password 7.
    2. Select "1Password" in the menu bar
    3. Select "Install Browser Extensions…"

    This opens https://support.1password.com/cs/1password-classic-extension/, which links to https://chrome.google.com/webstore/detail/1password-extension-deskt/aomjjhallfgjeglblehebfpbcfeobpgk
    ("Version: 4.7.5.90 Updated: January 27, 2021")

    If I manually hunt down the usual starting point for 1Password extension installation via Google, I get https://support.1password.com/getting-started-browser/ which, for Chrome, links to https://chrome.google.com/webstore/detail/1password-–-password-mana/aeblfdkhhhdcdjpifhhbdiojplfjncoa

    (I think this is "1Password in the browser", and is "Version 1.24.3 Updated: May 16, 2021")

    My questions:
    1. Should this link to a different page on support.1pass.com?
    2. Which extension should I be running?


    1Password Version: 1Password 7 Version 7.8.4.BETA-1 (70804001) 1Passw
    Extension Version: Not Provided
    OS Version: macOS 11.3
    Sync Type: 1Password.com

  • zzzambonizzzamboni
    edited May 23

    Hi,

    A couple of days ago I started having the problem that when I try to use 1P's auto-fill on a login screen (either with the keyboard shortcut, or from its browser plugin menu), it opens a new tab with the same page, instead of filling it out. This has happened so far with the 1Password community page, Twitter, 750words.com, and a few other websites I have tried. I noticed this with Brave, but I was able to replicate it with Chrome and Firefox. Safari seems to still work well.

    Any ideas how to fix this?

    Thanks,
    --Diego


    1Password Version: .8.4.BETA-1 (70804001)
    Extension Version: 4.7.5.90
    OS Version: 10.15.7 (19H1030)
    Sync Type: 1Password account

  • cipherswarmcipherswarm Junior Member

    Via the beta notes on "1Password 7, Version 7.8.4.BETA-1 (70804001)" (https://app-updates.agilebits.com/product_history/OPM7#beta)

    1Password in the browser 1.25.5 beta or newer to be installed before you can use it with 1Password for Mac.

    However, 1Password in the browser (hard to find, by the way: see discussion at https://1password.community/discussion/121058/1passwords-in-app-install-browser-extension-site-links-to-classic-extension-for-chrome/p1?new=1) is currently published as Version 1.24.3, Updated May 16, 2021

    Questions:
    1. This seems to be working in spite of the release notes? Or am I missing something?
    2. Is the 7.8.4 beta series requiring moving from the 1Password classic extension to 1Password in the browser?


    1Password Version: 7.8.4.BETA-1
    Extension Version: Not Provided
    OS Version: macOS 11.3
    Sync Type: 1Password.com

  • FogCityNativeFogCityNative Junior Member
    edited May 23

    https://www.westinstore.com/checkout.aspx

    Online e-commerce store. Trying to pay, 1Password will not fill any fields. It is like they are all locked to require manual entry.


    1Password Version: 1Password 7 Version 7.8.4.BETA-1 (70804001) 1Passw
    Extension Version: 1.25.7 BETA
    OS Version: OS X 11.5 Beta 20G5023d
    Sync Type: IPassword

  • HRDHRD

    Hi @coloredfranticwarm

    There is a huge difference between a bug and an App losing one of its principle functionalities.

  • HRDHRD

    Hi @cipherswarm

    Your Q2 requires a definitive answer, as I am also rather confused.

  • FogCityNativeFogCityNative Junior Member

    Won't fill this one either. Something is really wrong between the new Big Sur and your Beta.

    https://weddingshop.theknot.com/checkout/onepage?site=weddingshop

  • vplewisvplewis Junior Member

    @HRD Not in Beta software.

  • I'm having exactly the same problem, just started in the last 48 hours or so... Looking forward to a solution

  • MosabonMosabon
    edited May 24

    Hi, I think all starts with the lastest beta update (1Password 7, Version 7.8.4.BETA-1 (70804001):
    a) Safari extension did not work: I had to reboot the macbook pro; solved.

    b) MS Edge, Google Chrome and also Firefox browsers: I still can not use the browser extensions: Always a new tab of the same web page opens instead of filling out the login fields.

    Cheers, Mosabon


    1Password Version: 7.8.4.BETA-1 (70804001)
    Extension Version: 4.7.5.90
    OS Version: 11.3.1 (20E241)
    Sync Type: iCloud

  • hazmathazmat Member

    Same here. Just commenting because I can't find a way in this forum to simply subscribe to this topic to receive update notifications. I've gone back to 7.8.3 for now.

  • owineowine Junior Member
    edited May 24

    Looks like 7.8.4.BETA-2 is out with a fix. It's working again for me.

  • confirmed fix for me

  • FogCityNativeFogCityNative Junior Member

    Ditto, no improvement. Had to reload the Classic AddOn to fill forms. Still at 1.25.7 BETA from 5/18, although you tried to push an update that never installed... Cannot update 1.25.7 manually either.

  • Can confirm: Version 7.8.4.BETA-2 (70804002) fixed the issue. Thank you very much!

  • Version 7.8.4.BETA-2 (70804002) works here as well. Thanks guys.

  • Can confirm - 1Password 7 Version 7.8.4 (70804003) is also working fine now, filling in the form again instead of opening a new tab. Thanks!

  • ag_anaag_ana

    Team Member

    Thank you all for the updates! And thank you for your patience while we got the latest beta out :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file