Signing in to CalyxOS. using 1password.com. Scan QR code + masterpass and it spins indefinitely.

Setting up a new phone with CalyxOS. Already have 1password.com. I went to launch 1Password on the new phone (Pixel4). Scanned QR code and entered master password. The application spins indefinitely. It says "Please wait while 1password sets up your account." I have been hitting this issue for 3-4 days :( I've tried over a dozen times. Would love support in getting this setup. I feel like I can't use the device without 1password. Much appreciation for assistance.

Note: when I look at app info I see permissions include: Camera


1Password Version: 7.7.7
Extension Version: Not Provided
OS Version: CalyxOS 2.8.0
Referrer: forum-search:calyxos

Comments

  • To clarify. The steps I have taken:
    1. Add account based on 1password.com
    2. Scan QR code
    3. Enter master password
    4. Blue circle spins... indefinitely... >20 min

    If I press < arrow, I get message: "Please wait 1Password configures your account."

    I've deleted and reinstalled 3+ times. I've tried over a dozen times over the span of 3+ days.

  • chrisblechrisble
    edited August 21

    I am having the same exact problem. Also on CalyxOS 2.8.0 on a Pixel 4a. Downloaded via Aurora Store. I have also reinstalled and rebooted.

  • Tried again today for 20 min... no luck.

  • Contingency plan is to switch one of the KeePass products. One of the reasons I got onboard with 1Password was due to reviews suggestion good customer support. If anyone has suggestions as to the best way to find that good customer support, suggestions appreciated.

  • Tried again today for 19 min... no luck.

  • ag_audreyag_audrey

    Team Member

    Hey @sparrowrad10 and @chrisble, I'm sorry you're having trouble logging in to the Android app. This is surely not how 1Password is supposed to work.

    There seems to be an issue where devices running CalyxOS cannot sign into the Android app when the 1Password account has a security key set up. Can you confirm whether or not your 1Password account has a security key set up? If so, can you temporarily disable it through 1Password.com and see if you're able to sign in to your Android app?

  • Thanks @ag_audrey, I did this and then it worked. Now that I've completed the sync, is it safe to re-add my security key?

  • Thank you! Working great.

  • FWIW: I re-enabled security keys and it appears to be working.

  • ag_audreyag_audrey

    Team Member

    @sparrowrad10, thanks for the update! Let us know if there's anything else we can help you with :)

    @chrisble, did you get a chance to re-enable your security key?

  • Just my 2 cents here as GrapheneOS / CalyxOS similarities (see https://1password.community/discussion/123223/running-1password-on-grapheneos-android-11). Assuming that you're running CalyxOS with microG support?

  • ag_timothyag_timothy

    Team Member

    Hello @16dd12298 thanks for adding your voice to the conversation!

    Was the solution @ag_audrey suggested (temporarily disabling a security key through 1Password.com) useful in your situation? If not, lets continue the conversation in the thread you created: Running 1Password on GrapheneOS (Android 11)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file