Desktop app opens to blank window (Fedora 35 beta)

Hello all, seems my local 1Password app now opens to a blank window.

I believe this started happening after upgrading from Fedora 34 to Fedora 35 beta. As this a beta OS it's not super surprising things are breaking and thus not really expecting a direct fix now. That said, I thought I should make a post as a sort of heads up about this potential issue since Fedora 35 full release is less than a month away. (Fedora 35 release schedule)

Notes

  • browser extension works fine by itself
  • have tried stable and beta versions

Please let me know if there's anything I can do to help debug this issue.


1Password Version: 8.2.0-1, 8.2.2~57.BETA-1
Extension Version: 2.1.0
OS Version: Fedora 35 beta (GNOME)

Comments

  • larouxnlarouxn
    edited September 26

    Additionally I've run into and reproduced the following bug in which I cannot import the 1Password public GPG key on Fedora 35 beta after upgrading from Fedora 34 via sudo rpm --import https://downloads.1password.com/linux/keys/1password.asc as described in the install docs.

    Have scoured Google, StackOverflow, and even the RPM source code. Yet to find anything concrete as to why this is occuring. Potentially still a Fedora 35 beta bug as I'm not able to reproduce the bug on fresh Fedora 34 install. That said RPM imports of other GPG keys work fine, as shown below.

    Currently trying to fetch a Fedora 35 beta image (from here) to test adding the key on a fresh 35 beta install. Hoping to determine if the issue is caused by upgrading from 34 or inherent to the 35 beta release.

  • Managed to grab a Fedora 35 beta ISO from here to use as a fresh install, as opposed to upgrading from Fedora 34. Reproduced the same issue importing the public GPG key. I suppose there's a Fedora 35 specific issue with the 1Password public GPG key.

  • 1P_Claudio1P_Claudio

    Team Member

    Hey @larouxn, this doesn't look right at all, and we'd love to look into this so we can get 1Password running normally again.

    Could you write in to [email protected], and reference this post? We'll then pick this up with you and get the ball rolling. :)

  • Hey @1P_Claudio, thanks for your reply. I have sent over an email with a reference to this post as directed. 🙇

  • I had a similar issue at one point where the app windows was blank. This was due to GPU hardware acceleration. You can test this by launching 1Password without GPU acceleration:

    /opt/1Password/1password --disable-gpu

    It might be worth a try.

  • BlakeBlake

    Team Member
    edited September 28

    Thanks for chiming in here @Fooligan @larouxn!

    Generally, disabling the GPU processes can get things rolling, but we'll likely need to upgrade to Electron 15 to get things fixed-up for Fedora 35 completely.

    The team is currently working on this internally, and we should have this resolve in an upcoming build. 💙

  • Thanks for the tip @Fooligan and for the reply @Blake. Interesting, Electron 15 was just released last week. The v15 release notes indeed mention a couple Linux relevant bug fixes. Down to test out upcoming builds anytime.

  • I believe that the fix has been backported to older electron versions: https://github.com/electron/electron/pull/31091

  • BlakeBlake

    Team Member
    edited September 28

    We'll certainly keep everyone posted! :+1:

    Did using the --disable-gpu flag work for you at all @larouxn?

  • I'm on openSUSE tumbleweed with nvidia X11, similar situation, but --disable-gpu crashes with a GPU process isn't usable. Goodbye.

  • BlakeBlake

    Team Member

    @ld6772

    Just to double-check, does this also happen on the latest beta, 1Password for Linux 8.2.2-72?

  • Just tried it after seeing this comment: https://1password.community/discussion/comment/613634/#Comment_613634 All seems to now be well, even without the --disable-gpu

    Thanks!

  • BlakeBlake

    Team Member

    Success! 🥰

    I'm definitely happy to hear that things are back up and running for you now! Thanks for sharing what worked for you!

  • 👋 @Blake, I was able to successfully install and run the 8.2.2.-72 beta on Fedora 35 beta. 🙌 (did not try --disable-gpu)

    Two quick notes.
    1. The "what's new" menu item in the beta 1Password client doesn't seem to do anything.
    2. Still cannot add the GPG key properly via rpm --import. This does work on Fedora 34. Not sure the issue but it's still present. Unfortunately needed to set gpgcheck=0 in order to install the aforementioned beta release.


  • Just want to quickly add that 1PW 8.2.2-72.BETA shows the same behavior as initially posted on Manjaro.

    Works by appending --disable-gpu though.

    DISTRIB_ID=ManjaroLinux
    DISTRIB_RELEASE=21.1.4
    DISTRIB_CODENAME=Pahvo
    DISTRIB_DESCRIPTION="Manjaro Linux"
    
  • edited October 3

    [[email protected] ~] $ sudo rpm --import https://downloads.1password.com/linux/keys/1password.asc
    [sudo] password for derekhanks:
    error: https://downloads.1password.com/linux/keys/1password.asc: key 1 import failed.
    [[email protected] ~] $ sudo sh -c 'echo -e "[1password]\nname=1Password Beta Channel\nbaseurl=https://downloads.1password.com/linux/rpm/beta/\$basearch\nenabled=1\ngpgcheck=1\nrepo_gpgcheck=1\ngpgkey=\"https://downloads.1password.com/linux/keys/1password.asc\"" > /etc/yum.repos.d/1password.repo'
    [[email protected] ~] $ sudo dnf install 1password
    1Password Beta Channel 2.8 kB/s | 833 B 00:00
    1Password Beta Channel 72 kB/s | 4.8 kB 00:00
    Importing GPG key 0x2012EA22:
    Userid : "Code signing for 1Password [email protected]"
    Fingerprint: 3FEF 9748 469A DBE1 5DA7 CA80 AC2D 6274 2012 EA22
    From : https://downloads.1password.com/linux/keys/1password.asc
    Is this ok [y/N]: y
    1Password Beta Channel 3.4 kB/s | 2.0 kB 00:00

    Dependencies resolved.

    Package Architecture Version Repository Size

    Installing:
    1password x86_64 8.2.2~72.BETA-1 1password 81 M

    Transaction Summary

    Install 1 Package

    Total download size: 81 M
    Installed size: 318 M
    Is this ok [y/N]: y
    Downloading Packages:

    1password-8.2.2-72.BETA.x86_64.rpm 13 MB/s | 81 MB 00:06

    Total 13 MB/s | 81 MB 00:06
    1Password Beta Channel 60 kB/s | 4.8 kB 00:00
    Importing GPG key 0x2012EA22:
    Userid : "Code signing for 1Password [email protected]"
    Fingerprint: 3FEF 9748 469A DBE1 5DA7 CA80 AC2D 6274 2012 EA22
    From : https://downloads.1password.com/linux/keys/1password.asc
    Is this ok [y/N]: y
    Key import failed (code 2). Failing package is: 1password-8.2.2~72.BETA-1.x86_64
    GPG Keys are configured as: https://downloads.1password.com/linux/keys/1password.asc
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: GPG check FAILED

  • @derekbhanks, yep that's the same error I'm seeing.

  • Just a quick follow up to my comment here: https://1password.community/discussion/comment/614266/#Comment_614266.

    For me, running inside a VM it seems to be related to the VM not 1PW in general.

    https://forum.parallels.com/threads/npm-electron-gui-white-canvas.353536/

  • SavanniSavanni

    Team Member

    Hey, everyone.

    I'm trying to get my plate cleared off so I can solve some Linux bugs, and certainly I need to ensure that we're good for FC35.

    I can see some of you are installing 1Password without doing the GPG check. Please don't do this, as it's very unsafe.

    Instead, please download the RPM directly from our website. If you go to 1password.com, the SSL certificates can at least ensure that you are downloading directly from us.

    Unfortunately, it does seem that our GPG key doesn't work with FC35, so that's going to be fun to solve. :(

  • larouxnlarouxn
    edited October 6

    👋 Hey @Savanni, thanks for the reply!

    Agreed that disabling GPG check is dangerous and certainly don't want to do that. Unfortunately, unless I'm mistaken though, RPMs are only available for stable releases (not beta releases) and thus I don't believe we can install via RPMs at this time since stable releases still open to a blank screen.

    Unfortunately, it does seem that our GPG key doesn't work with FC35, so that's going to be fun to solve. :(

    Yeah this is a rather peculiar error. Not sure what the issue might be. Package comparison wise:

    34 versus 35
    4.16.1.3 verus 4.17.0 for RPM
    2.2.27 versus 2.3.2 for GPG

    Also --disable-gpu does not seem to help with Fedora 35 + stable 8.2.0.

  • SavanniSavanni

    Team Member

    Oof. You're right. The beta RPM is technically available, but we don't have the URL posted on the website. I checked with CS to be sure, and it's totally okay to share this, and we will look into getting the URL back onto the website.

    https://downloads.1password.com/linux/rpm/beta/x86_64/1password-latest.rpm

    But, also, another forum user bisected the RPM code itself and discovered exactly where RPM stopped supporting our GPG key. That information has given us a path forward, and we will have it fixed pretty quickly. No guarantees on a particular date, but it will be ready by the time FC35 becomes stable.

    Another thing you can do, actually, is to strip the signatures, except for the self-signing signature, from the GPG key, then import the result. This should be safe since you downloaded the GPG key directly from us. I can post command line instructions for that if you like.

  • SavanniSavanni

    Team Member

    Unfortunately, I'm not able to reproduce the blank screen issue, so here's my setup.

    First, I'm in a libvirt VM. I installed FC35 from an image that I downloaded from the Fedora website yesterday, and then installed 1Password 8.3.0, which we released yesterday. I'll keep trying with the betas, and may even update my desktop to FC35 in order to try this out more directly.

    But, could you try out 8.3.0 stable release, or the 8.4.0 beta, and let me know whether you still see the blank screen issue?

  • Thanks for the beta RPM link! Also glad to hear we were able to figure out where the GPG issue lies. Was rather confounding.

    As for the 8.3 stable and 8.4 beta releases, both work perfectly well via RPM install. I am no longer able to reproduce the blank screen issue. Seems that issue was fixed in a later 8.2.x release or the new 8.3 release. :)

    Fedora 35 support seems more or less ready. All that's left is to resolve the GPG key issue.

  • SavanniSavanni

    Team Member

    @larouxn and everyone else here, I'm glad to report that we were able to fix the problem with our key. We re-published the key yesterday after removing the expired signatures that RPM now rejects.

    I am both relieved, and concerned, that the blank screen problem has stopped. I'll have to keep an eye out for this one.

  • @Savanni For me the issue with the blank screen is back, I also have the issue with other Electron apps though and even with Fedora 34 since the latest updates.

  • @Savanni, thanks for all the help. I have confirmed the key imports properly on Fedora 35 and app is running well.

    @the_john19, what version of the 1Password app are you running? I had the same issue until the latest stable/last beta branch (8.2.x).

  • @larouxn I'm on 1Password for Linux 8.4.0 80400002 (BETA Channel). I noticed that I have this issue with all electron apps on Wayland + NVIDIA, but on Arch Linux also with NVIDIA + Wayland I don't have this issue with at least 1Password. I have to add --disable-gpu or --use-gl=egl to fix it

  • @the_john19, ah I see. I too am on Wayland but AMD side graphics wise. If I recall correctly the 8.2/8.3 1Password release included some Electron updates, I believe fixes which were backported from the latest release of Electron 15, which fixed my 1Password blank screen issue. I suspect there may still be some Nvidia specific Electron bugs. Maybe this Chromium issue?

    That said, if you're seeing things working fine with Wayland + NVIDIA on Arch but not another system, I presume Fedora, it sounds like it could be driver related. 🤔

  • SavanniSavanni

    Team Member

    @the_john19 Could you generate a diagnostic report and email it to us? [email protected]

    I still can't reproduce the problem myself, but I want to see if there's anything in the logs, or in the system configuration that I can pin down. Or at least to file so I can look for a pattern. But it does sound like some combination of a Chromium issue and a driver issue.

  • edited October 18

    Hey @Savanni ! I'll be back home tomorrow and will do that, then! But yesterday I noticed that as soon as I install this packages:
    libglvnd-glx libglvnd-opengl libglvnd-devel
    it is fixed. When you install the NVIDIA driver via RPMFusion (https://rpmfusion.org/Howto/NVIDIA) it seams like they are not required (nor are they required by 1Password), but if you want to install the driver that you can download directly from NVIDIA you need those packages (that's how I found out about it). Sorry if it doesn't make to much sense, I'm still very new with Linux.

    I've also noticed something with the Flatpak version, I have to run 1Password with "--disable-gpu-sandbox" or downgrade the flatpak NVIDIA driver from nvidia-470.74 to nvidia-470.63.01 to get it to work.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file