New extension for Safari on iPad doesn’t work

I‘m using 1Password since for quite some time on my iPad without the extension for Safari. In the 1Password news I saw the message about the Safari extension and activated it. But it doesn’t work.

If I tap on the 1Password symbol in the address line a „dialog“ opens but doesn’t load. It hangs even If I wait for 5-10 minutes. See screen shot.

Furthermore, Safari crashes after some time if the extension is activated.

I tried to uninstall and reinstall 1Password on my iPad - didn’t help.

What can I do?


1Password Version: 7.9
Extension Version: Not Provided
OS Version: iOS 15.0.1

Comments

  • ag_anaag_ana

    Team Member

    Hi @Hoelder!

    I would like to ask you to generate a diagnostics report from your iOS device and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Hi ag_ana, I sent via the 1Password app an email to the support. Unfortunately, there was no option „send requested report“ or alike. So I create a new (?) ticket. But I didn’t get any ticket no nor got an email with a confirmation of my inquiry.

  • BenBen AWS Team

    Team Member

    Thanks @Hoelder. I was able to locate your emails in our system and have moved them to the correct spot to get them the appropriate attention. The team will be investigating and will reach back out to you via email as soon as they have further information.

    Ben

    ref: WAN-96218-368

  • Thanks, Ben!

  • BenBen AWS Team

    Team Member

    You're very welcome. :)

    Ben

  • Hi @Ben
    Do you have news on this issue? The 1Password extension still doesn’t work on my iPad.

    best
    Daniel

  • geoff2geoff2 Junior Member

    Hello — just commenting to note I’m having the identical problem. On my iPad sometimes the 1Password Safari integration works because 1Password is logged in, other times it does not because I’m not logged in, if I’m not logged in I can’t log in, and it’s not clear when or why I’m logged in or not.

  • ag_anaag_ana

    Team Member

    @Hoelder, @geoff2:

    Thank you for the updates. I see that our developers are still investigating, so hopefully they will be able to get to the bottom of this soon :+1:

    ref: apple-5510

  • The Safari extension no longer works for iPad OS for any of our Family or Team devices as well. It previously worked at launch, but with the latest update, there is now only a button that says “Open 1Password” which doesn’t function—it just opens the Safari start page.

  • ag_anaag_ana

    Team Member

    @byndpass:

    Since you mentioned an update, what version of the 1Password app are you using right now, and on what version of iOS?

  • byndpassbyndpass
    edited November 27

    iPad OS 15.1, 1Password 7.9.3

    Update: Disabling the extension, restarting the iPad, then re-enabling the extension seems to restore functionality on affected iPad devices.

  • iPad OS Safari extension bug update:

    The extension stopped working after about 24 hours and resorted back to the Open 1Password button that opens a new Safari start page instead of the app.

    The only fix is to manually disable the 1Password Safari extension, force close Safari, force close the 1Password app, and re-enable the extension.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file