Password Histories Missing!

neddyneddy
edited October 28 in v7 Mac Beta

Hi, I just changed a password, and I now need the old password, but the history is nowhere to be found. Has this been removed, or relocated? I'm using 7.9.1.BETA-3

Thanks

(p.s. I'm freaking out a little as this was a password to a corporate router, and if I can't find it then I will have to reset the router, which will be bad...)


1Password Version: 7.9.1.BETA-3
Extension Version: Not Provided
OS Version: macOS 11.2.3

Comments

  • Ok, I am no longer freaking out as I logged into the WebUI and found the history, but it does seem to be missing from the app at the moment.

  • ag_anaag_ana

    Team Member

    @neddy:

    How did you update the password for this item? Was it directly inside the Mac app, or in the browser extension? If it was the browser extension, which version and in which browser?

  • It was directly in the Mac app.

  • ag_anaag_ana

    Team Member

    @neddy:

    Thank you for the confirmation. I tried to update an item in my 1Password app, and the password history feature showed as usual. Are you able to reproduce this, either with the same item, or with a different one?

  • The screenshot above is from the Mac app. The item has no option for password history in the app, but if I log in to the WebUI, the old passwords are there. I have just checked, and the issue is still there.

  • I have just changed a few more passwords and there is no history shown for them either.

  • ag_anaag_ana

    Team Member

    @neddy:

    I have just checked, and the issue is still there.

    Have you tried updating the item again though? I am trying to understand if this is one-time thing, or if this item is broken no matter how many times you try to update it.

  • I have updated another item, and it is the same issue. I am not going to update the router password anymore as I cannot afford to lose that one...

  • Why was this moved to the browser forum? It's an issue with the Mac app?

  • 1Password 7
    Version 7.9.1.BETA-3 (70901003)
    1Password Beta

    Happened to me too

  • No matter how many times I've updated it, the history does not show up on macOS app.

  • ag_yaronag_yaron

    Team Member

    Hey @neddy ,
    I'm testing this here with 1Password 7.9.1 beta-2 and things seem to work ok: http://recordit.co/XNWu7wN6XZ

    Can you please run software update and update your 1Password to beta-2, then restart your Mac for good measures and see if you are still able to reproduce the issue?
    Also - if you create a brand new login item, does the issue occur there as well?

  • @ag_yaron Both @neddy and I are already at 7.9.1 BETA-3. Software Update only gives "You are up to date".

  • ag_yaronag_yaron

    Team Member

    Hey @ylou ,

    Indeed, beta-3 is already available, and looking at its changelog it contains the following:

    Fixed an issue that prevented password history from being available on Server, Database, Wireless Router and Email items.

    Seems like this was a known issue that was fixed in that latest beta. Are you saying you are still not finding the password history button even though your app is on beta-3? Are you trying to find the history in a login item or in one of the above mentioned items (Server/Database/Router etc)?

  • Hey @ag_yaron ,

    Yes, on BETA-3 I cannot find the password history button for a Login item.

  • Updated to BETA-5. Still not seeing password history button for all the Login items I have checked.

  • Hi @ylou and @ag_yaron ,

    Here is a screen recording of what happens on my end.

    https://cln.sh/FPGR9e

    Cheers

  • I have now updated to Version 7.9.1.BETA-5 (70901005) and it looks like this has resolved the issue for me.

  • Updated to Version 7.9.2.BETA-1 and remembered to check again, and password history is back! Yay! Thank you!

  • Hi @neddy / @ylou:

    Glad to hear it's working for both of you again. :smile: If you run into any trouble in the future, please don't hesitate to reach out!

    Jack

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file