Autofill on Android 12 doesn't seem to work

24

Comments

  • Asyd RaynAsyd Rayn Member
    Community Member
    edited December 2021

    I’m going to add a me too here as well, Android 12 and Pixel 6 Pro. It’s almost become useless on Android, I constantly have to open the 1Password keyboard to get to logins that would normally pop up for me to select. Then some pop up, but they don’t fill if selected or I get no pop up at all. TBH I see similar behavior with my iPad running iOS 15, so something is amiss with the handheld version of the app for the phone and tablet. I’d also concur that banking apps seem to have the most problems. But using 1Password is no longer convenient, that’s for sure. I now find myself wondering “will it work this time?”

    I’ve also tried the troubleshooting and it just doesn’t help.

  • bsuvcbsuvc
    Community Member
    edited December 2021

    Thanks @ag_timothy

    I did what you suggested, but still seeing the same inconsistent behavior.

    I have no idea what keyboard I use. It's just the default one that comes with Google Pixel 4a. I checked and it looks like it is GBoard.GBoard

    Apps where this happens are:

    • Fidelity
    • Fifth Third Bank

    It probably happens on others, but I just don't use other apps that much.

    Also, sometimes if I close the app and re open it, it might start working again. Other times (with Fidelity in particular) it is able to fill the password but not the username. But sometimes it works flawlessly.

  • periperi

    Team Member

    @Asyd Rayn Can you let me know what keyboard you're using by default on Android? We've fixed an issue in a recent beta where Autofill wasn't showing up in the Gboard, so if you're using Gboard, the beta may help in your case.

    @bsuvc Unfortunately filling doesn't work in the Fifth Third Bank app, and our developers are aware of this issue. As to Fidelity, do you notice any particular circumstances where it does or doesn't work?

  • bsuvcbsuvc
    Community Member

    @peri actually filling works sometimes in the Fifth Third app, just not consistently.

    For both of these apps (Fidelity and Fifth Third), filling seems to work fine if I haven't used the apps for a long time (several hours). So for example, the first time I open them for the day it works.

    Then if I wait 30 min or so, the 1password autofill is (sometimes) no longer even shown as an option above the keyboard. And if I long press and select Autofill, nothing happens either. I don't think it is 100% of the time, but it is very frequently, maybe 50% of the time this seems to happen. Closing and reopening the app does not help either when this happens.

    Then after several hours, let's say later in the afternoon, I'll open the app and 1password Autofill is working again.

    So it's almost like some kind of timeout is occurring. It definitely has something to do with the amount of time that has passed since I logged in before.

  • Asyd RaynAsyd Rayn Member
    Community Member

    Hi @peri you nailed it, I'm using Gboard as my default keyboard. I'm in the beta group for Android -- what exactly is that build?

    Also -- I'm finding I have to have a login for phone apps and webpages on my phone and an identical login setup for use on my desktop. Is there a reason for that? If I open my Etrade app for example and there are others with this behavior too, it will not prompt, or if it does I have to search for the login. Speaking of search -- it would be really helpful if "Search" was at the top of the dropdown instead of the end.

  • periperi

    Team Member

    Hey @Asyd Rayn. Please update to version 7.9.1 and let us know if that helps with your filling issue. And I'll share your feedback regarding the search bar on to our development team.

    @bsuvc Can you try refreshing the page or closing/relaunching the app and filling again when this issue occurs? Are you able to fill after?

  • Asyd RaynAsyd Rayn Member
    Community Member

    Hi, @peri thanks, I did update and it seems to be working a little better. Thanks for sending the search up the chain, it's just odd that it's at the end when above the keyboard or in the drop-down list when the correct set of suggestions doesn't pop up. It forces you to scroll through a bunch of wrong guesses to get to the login that's needed.

  • ag_timothyag_timothy

    Team Member

    Hello @Asyd Rayn thanks for the update. I'm glad things have been working better since the update.

    If you open the items in 1Password for Android do they have URLs for the appropriate websites listed? For app logins do you see linked apps listed?

  • Asyd RaynAsyd Rayn Member
    Community Member
    edited January 7

    Hi @ag_timothy no, if there were, it would certainly keep me from having to use the search. I wished it worked that way -- as it is now I have two saved loggins, one for apps and one for websites that are dupes. --

  • HarlyFanHarlyFan
    Community Member
    edited January 8

    Does not work on Pixel 6 Pro running Android 12 using either GBoard or Swiftkey. I have tried all the above suggestions.

  • HarlyFanHarlyFan
    Community Member

    By the looks of all these comments it looks like there is no REAL fix to the problem just a bunch of workarounds which for an issue like this is not acceptable, I am still trying to decide if this is for me and if something like this cant be worked out I doubt it is.

  • Asyd RaynAsyd Rayn Member
    Community Member

    @Harley, I'll agree it's annoying as the devil as I have 3 E*trade logins, one that works on the phone, one that works for the web browser that opens on the phone, and another for the Android app AND the nag from the desktop app that tells me I've reused passwords for those three sites. There are others as well but this swells the file unnecessarily.

    The poor search and ridiculousness of having it at the bottom of the drop-down is however mind-boggling because it assumes the app will display the correct log-in and it just doesn't and a lot of site logins and apps on the phone are like that. If it worked, I wouldn't need the login for the Android app or the Chrome browser, and the popup provides a list that needs scrolling and then you get to the search. Not a time saver.

    All my carping aside though, I've used this app on the desktop since 2000 if not sooner (Dave used to respond to my bug emails and questions), that's how long ago it's been. Support is top-notch and responsive. You won't find a better group of developers who listen and internalize feedback appropriately, it was one of the things that impressed me after coming from Windows. As an example, one of my investment accounts used 2FA and the option wasn't there. I raised the issue last Monday and by the end of the week it was there and Saturday I received a follow-up DM on Twitter alerting me that it should be there. :)

  • HelenBubzHelenBubz
    Community Member

    I'm having major problems with Auto fill, which are made worse by my poor dexterity. Example sites that are no-gos are Google, Yahoo, banking sites, Play Store and 100 more logins! I'm on a Samsung Galaxy A7 Lite, Android 11. I've found a way around constantly having to login to 1P - go to Security > and turn PIN Code On but I cannot work out the auto-fill, and I see I'm not alone!

  • HelenBubzHelenBubz
    Community Member

    The real pain in the neck is Google's Play store when you actually want to buy something. Auto fill doesn't work there and I don't want to put my banking details into anything Google!

  • ag_timothyag_timothy

    Team Member

    Hello @Asyd Rayn thanks for clarifying that. After you fill with 1Password for Android and successfully log in to a website or app a link should be created but it sounds like that may not be happening. You can also add a link to a website manually by editing the item and copying the URL in the website field. That might help you cut down on duplicate (and triplicate) items.

    Thank you for your comments regarding our support and development teams! We are constantly working to improve 1Password and to make sure it's working well for 1Password users.

    @HarlyFan thanks for reaching out to us. I'm sorry to hear you're running into filling issues. Are the issues you're seeing with all apps and websites you use or specific ones? I have a Pixel 3a running Android 12 and a Pixel 3a running Android 11 and I haven't noticed a change in filling behavior.

    @HelenBubz thanks for your comments. At this time, 1Password for Android only fills Login items and will not fill your credit card information. This is something we're hoping to add in the future though. For now, you can use split screen mode to drag and drop your credentials:

    You mentioned you were not able to fill on the Yahoo website and many others .I was able to fill credentials in the login page for Yahoo. I'd like to ask you to confirm that you have Autofill and Accessibility enabled from Settings > Autofill. If they're both on you can try turning them off and on again.

  • HelenBubzHelenBubz
    Community Member

    @ag_timothy I can't see where in Settings I have to turn Accessibility on/off.

  • ag_timothyag_timothy

    Team Member

    Hello @HelenBubz thanks for following up with us! You can open and unlock 1Password for Android, tap Settings > Autofill then tap Accessibility. The accessibility settings on your device should then open.

    Depending on the make of your phone you may see 1Password listed under the "downloaded apps" heading or you may need to tap a sub menu such as "installed" or "downloaded services" to find the 1Password setting. You can then select 1Password and tap use 1Password on/off. If you see 1Password shortcut you can leave that off.

  • Asyd RaynAsyd Rayn Member
    Community Member

    @ag_timothy I'm noticing it happens most frequently when clicking a link from an email program that takes me to a website I have a login for but it doesn't show. Oddly, I can click the same email link on my desktop and poof, the login shows up. Happened to me today in fact.

  • ag_timothyag_timothy

    Team Member

    Hey @Asyd Rayn thanks for the additional context.

    Is your default browser on Android different than what your commonly use to browse? If you toggle Autofill Previews off and on from Settings > Autofill do you see any change in behavior?

  • HelenBubzHelenBubz
    Community Member

    I've tried a range of browsers on my Android tablet and none make 1password behave as it does on my desktop Mac - this is specifically reserved for my online banking. I've had to resort to using the apps which don't have quite the functionality of the websites.

  • Asyd RaynAsyd Rayn Member
    Community Member

    @ag_timothy Nope, I use Chrome on my desktop and phone.

  • periperi

    Team Member

    @Asyd Rayn I have an E*Trade account and I just need one login for it, which works across Android and all other platforms/browsers. I'm not sure why you need a separate login for each platform. Try manually resaving the login, and let me know if you can use that new one everywhere.

    @HelenBubz If your problem is specific to a single banking site, then it's possible the problem is with that site rather than Autofill itself. Can you share the website you're having trouble with so we can test it on our end?

  • Asyd RaynAsyd Rayn Member
    Community Member

    @peri me either, but I do otherwise I'd get no pop-up because it won't work for the app on the phone or if I click a link in an email that opens on my chrome browser on the phone.

  • HelenBubzHelenBubz
    Community Member

    Hi @peri,
    It's Lloyds Bank in the UK, but it's also every website that spreads the login process over two web pages, e.g. Google, eBay, Amazon (UK) though I'm imagining it's any Amazon site.

  • periperi

    Team Member

    @HelenBubz Thanks! 1Password can indeed have trouble with logins that are spread out over two pages. We hope to improve this in the future, and I'll pass your feedback along to our team.

    @Asyd Rayn Were you able to resave the login manually as I suggested? Hopefully you can resave it, and use the new one everywhere so that you'd no longer need the others.

  • HelenBubzHelenBubz
    Community Member

    I'm finding that none of the auto-fill logins work on my Samsung A7 tablet, @peri, I'm having to switch between 1Password and whichever app I'm wanting to log into and copy each component onto the clipboard and switch back to the app, paste it in, then repeat the process....... I find 1Password on my Mac absolutely gorgeous to use, it’s the mobile version I have difficulties with.

  • ag_timothyag_timothy

    Team Member

    Hello @HelenBubz thanks for your reply. Do you happen to be using a physical keyboard with your Samsung tablet?

  • HelenBubzHelenBubz
    Community Member

    No I'm not - just the in-built one that pops up when you tap in a text box, @ag_timothy. what's the point of having a mobile device if you have an external keyboard? OK, I have a disability which means a laptop's keyboard is too far away for me to reach without an external keyboard; this renders the laptop very non-portable. I don't want to go down that route with my tablet.

  • periperi

    Team Member

    @HelenBubz I think @ag_timothy was asking if you were using an external keyboard in order to rule out that being a problem here, rather than trying to suggest you should be using one. You should be able to fill on Android with the built-in keyboard.

    If the problem is specific to you Samsung A7 tablet, there may be an issue there. I'd like to ask you to create a diagnostics report from your Android device:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • HelenBubzHelenBubz
    Community Member

    I don't have a Bluetooth keyboard @peri, that is why I reacted the way I did to @ag_timothy. I'll try to get the report to you soon.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file