Autofill on Android 12 doesn't seem to work

j00barj00bar
Community Member

I just got a Pixel 6 Pro and have 1Password set up. 1Password is my autofill service.

When I add a new Google account, I long-press on the password entry widget and select "Autofill" from the bubble that comes up, but nothing happens.

I've tried turning off autofill in 1Password and turning it back on, but still nothing. Any thoughts? Thanks so much!


1Password Version: 7.9
Extension Version: N/A
OS Version: 12

«134

Comments

  • GatoraiderGatoraider
    Community Member

    Just want to chime and say I am having the same issue on Pixel 6.

  • saadsaad

    Team Member

    Thanks for letting us know 1Password does not offer filling using the Autofill service when adding a new Google account on your device. It looks like Autofill has been disabled by Google Play Services on this sign-in screen which prevents 1Password from receiving filling events. I’m sorry about this experience.

    As an alternative method, you can use the 1Password accessibility service to fill your login credentials on this screen. To enable this service, open 1Password and go to Settings > Autofill and turn on Accessibility.

  • ahilleltahillelt
    Community Member

    I have a pixel 6 pro as well, and auto fill doesn't really work anymore in app. It never even pops up to allow me to select an appropriate login credentials. All features in 1password enabled, accessibility rights granted

  • mverdemverde

    Team Member

    @ahillelt is Autofill working for you in some cases but not in others? Or is it not working anywhere?

    If it's the former, could you provide us with the names of the apps where it isn't working? This will help us in tracking down the root cause as to why Autofill isn't working in these cases.

  • tisbutascratchtisbutascratch
    Community Member

    Mentioned on the play store. The auto fill definitely seems to have a problem in android 12.

    What I've found is this mainly happens when an app or website split the login details into two sections. So, enter username, click next, and then enter password. When this happens it will pick up the username, but then fail to pickup the password field.

    What I haven't tested though is removing 1password from auto fill and seeing if android has the same behaviour. As I'm not sure if this is a android 12 bug with auto fill, or a bug for 1password.

    When the fields are together it generally works as expected.

  • lamenamelamename
    Community Member

    I cannot get 1password working at all on my Pixel 6 with Dropbox syncing. After initial Dropbox login, the "Allow" permissions button doesn't do anything, it just stays on the same page. I've tried with Chrome and Firefox for 3 days now with multiple restarts and setting changes. Getting really frustrated as I rely on this app.

  • Hello @tisbutascratch , thanks for writing in with those details. Is there a specific app or website where you're seeing this behavior? We would be happy to do some testing and investigate further.

    Hello @lamename did you receive the error message "The app was not correctly configured and cannot access your Dropbox"? If so, this sounds like an issue we've been tracking in another thread: https://1password.community/discussion/124732/the-app-was-not-correctly-configured-and-cannot-access-your-dropbox#latest

    The thread I linked contains work around steps for this issue. If you're experiencing the same issue give those steps a try and let us know how it goes!

  • lamenamelamename
    Community Member

    @ag_timothy. There are no error messages. The Allow and Cancel buttons just don't do anything. I've tried everything. Screenshot attached.(https://us.v-cdn.net/5020219/uploads/editor/aa/kty9r19l6gjn.png "")

  • jheuristicjheuristic
    Community Member

    Have the same problems as all mentioned here w/Pixel 6 and Android 12.

  • bouncetodrumbouncetodrum
    Community Member

    I'm also experiencing this problem.
    Example apps that don't allow autofill, and I can't find a way to input my logins without slowly switching between apps, copying the login/password separately and pasting one at a time:
    https://play.google.com/store/apps/details?id=com.fatsecret.android&hl=en_US&gl=US
    https://play.google.com/store/apps/details?id=com.fredmeyer.mobile&hl=en_US&gl=US - The 'email address' field. The password field does seem to work with keyboard autofill
    https://play.google.com/store/apps/details?id=com.valvesoftware.android.steam.friendsui&hl=en_US&gl=US
    https://play.google.com/store/apps/details?id=com.visiblemobile.flagship&hl=en_US&gl=US

    Even the accessibility shortcut doesn't seem to work (press both volume keys) (settings menu image: https://photos.app.goo.gl/uyU7QJejcKcNsyAL6 )

  • mverdemverde

    Team Member

    @lamename from the other thread, it seems like you were able to get Dropbox sync working with @peri's suggestion. I'm glad to hear that you're back up and running again. :smile:

    @tisbutascratch we've been investigating this on our end and we're also finding that the issue does seem to be specific to apps that separate the username and login fields onto separate screens. In our testing, we've found that this issue seems to be specific to the inline suggestions shown in Gboard. If you a different keyboard that supports inline suggestions, such as SwiftKey, or if you use a keyboard that doesn't support inline suggestions, then 1Password's Autofill results show up as expected. We're going to report this to Google as it's likely an issue introduced in a recent Gboard update.

    @jheuristic @bouncetodrum could you also try an alternate keyboard such as SwiftKey to see if you find that Autofill works as expected in that case?

    @bouncetodrum the accessibility shortcut is something new that was added to Android 12. It merely enables or disables an accessibility service, but it doesn't actually invoke any functionality. Unfortunately, after updating to Android 12, the shortcut seems to be turned on by default, which is confusing because it makes it look like it's a 1Password feature. My recommendation for most people is to turn the shortcut off in the accessibility settings on your device, unless you really want to be able to enable/disable the 1Password accessibility service on the fly.

  • bouncetodrumbouncetodrum
    Community Member

    Using the swiftkey keyboard gives me the same behavior on the apps I tested. The Fred Meyer app also seems to allow for 1password autofill for the password field, but not the username field, just like the gboard.

  • mverdemverde

    Team Member

    @bouncetodrum do you happen to be using 1Password 7.9.1.BETA-2 on your Android device? There is a bug in that version of the beta that causes some issues with filling into WebViews within apps. I ask because one of my colleagues has informed me that the Fred Meyer app uses a WebView for sign-in.

  • bouncetodrumbouncetodrum
    Community Member

    I'm not subscribed to any betas, and I believe I'm on the latest version available on the play store. The app's 'about' section says Version 7.9, and the App info panel also says 7.9. No more detailed version info that I can see.

  • mverdemverde

    Team Member

    Thanks for confirming those details @bouncetodrum.

  • irkannan1985irkannan1985
    Community Member

    Sam issue as everyone. Pixel 6 withe android 12. Many apps not working. For example most of the banking apps.

  • Hello @irkannan1985 thanks for letting us know.

    If you're using Gboard do you notice any difference switching to SwiftKey or another on-screen keyboard? If you long press a login field and tap auto-fill or three dot menu > auto-fill does a prompt from 1Password appear? If you turn Autofill off while leaving Accessibility on from Settings > Autofill do you notice any change in behavior?

  • jmjmjmjm
    Community Member
    edited November 2021

    Use Gboard beta and the autofill strip 'returns'...see here:

    https://www.reddit.com/r/GooglePixel/comments/qzv9uw/anyone_use_1password/

  • Hello @jmjm thanks for joining the conversation!

    Have 1Password prompts returned to the inline suggestion bar for you since switching to the Gboard beta?

  • jmjmjmjm
    Community Member
    edited November 2021

    @ag_timothy, I am still waiting to take delivery of my Pixel 6 Pro before I can say if Gboard beta "works" with 1Password for me.

  • Thanks for clarifying that @jmjm and letting others know about the Gboard beta.

    I hope your Pixel 6 arrives quickly, I think I'll be upgrading soon too!

  • jeffreydwalterjeffreydwalter
    Community Member
    edited December 2021

    I have a pixel 4xl running the latest of Android 12 and am seeing this issue as well. I did see it mentioned that there was a relation to forms that split user and password fields to separate views. I see this issue in forms with both user and password fields on the same view.

  • mvettosimvettosi
    Community Member

    Hello! I just installed 1password on my Pixel 4 with Android 12, and I also can't seem to get the app working at all.
    I disabled google password manager in Chrome browser, also enabled all the 1password features, also rebooted my device, but when I tap on an empty login form in Chrome (for example, amazon.it) it prompts me Google's saved passwords, and 1password is nowhere to be seen.

    Moreover, I tried enabling the 1password accessibility shortcut that places a 1password icon on the side of my screen, but it doesn't seem to be doing anything, I can move it around but any other interactions does nothing.

    Am I missing something, or is the app just broken for Android 12 atm?

  • Jack.P_1PJack.P_1P

    Team Member

    Hey @mvettosi:

    I've just been doing some testing, by chance are you using Gboard or a different keyboard? With 1Password set as my Autofill provider in Android Settings, I was able to successfully fill my Amazon credentials in Chrome when using Gboard, but if I switched to SwiftKey, I needed to enable the accessibility option for 1Password as well for SwiftKey to show the option to Autofill using 1Password .

    The accessibility shortcut you touched on does not actually trigger filling, it merely turns the accessibility option off and on.

    Let me know how that goes!

    Jack

  • kakyoinkakyoin
    Community Member

    I have been unable to access my passwords on pretty much every app on my pixel 6 pro because of this bug. A lot of people talk about gboard but I don't think it's related to keyboards, it doesn't work on SwiftKey either. My passwords are just stored with my Google account account and I don't use any other software to store or retrieve them so I would have thought it'd be smooth sailing like on my iPad device with the Apple passwords chain. disappointing

  • mvettosimvettosi
    Community Member

    Hi @jack.platten ,
    thanks for your reply! Actually later in the day I tried rebooting the device and everything started to work... Sorry about that!

    And thanks for the accessibility explanation, it really wasn't clear to me what it was supposed to do.

    All good for now!
    Cheers

  • saadsaad

    Team Member

    We are aware of two issues that may be causing problems with Autofill using 1Password.

    If you’re using Gboard, please make sure you have updated to the latest version on Google Play. Recent versions of Gboard had an issue where Autofill suggestions did not always appear on the suggestion strip.

    We’ve also identified an issue in the 1Password Beta where Autofill is not available when signing into an app that uses the Android WebView. This includes apps like Amazon, Outlook, and Fastmail. We plan to have this fixed in the next beta release (7.9.1.BETA-3).

    If you're using the latest version of Gboard and do not use 1Password Beta on Android, please let us know the app or website you’re having trouble with and we’ll do further investigation on our end.

  • saadsaad

    Team Member

    @mvettosi that's so great to hear. Thanks for the update!

  • bsuvcbsuvc
    Community Member

    I'm having the same problem (I think) on Pixel 4a and Android 12. 1Password stops popping up, and LongPress+Autofill doesn't make it appear either. This has been going on for a few months at least, but I'm finally getting annoyed enough to try to see if there is a fix.

    For me it is intermittent. It seems to work fine for a while, then stop working all of a sudden for all apps. But then if I wait a while, it starts working again.

    I do not use GBoard, do not have 1Password Beta (I have version 7.9) and do not have any custom keyboards or any other custom things. I keep my phone pretty simple except for installing a few basic apps, but nothing that customizes the phone itself aside from 1Password.

    Also, when this problem happens and I log in manually, it asks me if I want to save the password in 1Password even though it already is in 1Password.

  • Hello @bsuvc

    To start, you can reset your Autofill settings. Navigate to Settings > Autofill and turn Autofill and Accessibility off. Then restart your device and turn those settings back on. Is filling consistent more consistent after resetting?

    If not, I'd like to ask which keyboard you use and a few of the apps where Autofill is inconsistent. Thanks!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file