Login & Autofill with 1Password 8.7.0 is buggy

Login doesn't work from Safari Browser

See video here: https://www.loom.com/share/91e46f6b8e4c4ae7a965d94d411c1223


1Password Version: 8.7.0
Extension Version: 2.3.3
OS Version: macOS 12.4

Comments

  • SandorFSandorF
    Community Member

    Here is another example why 1Password 8 is buggy: https://www.loom.com/share/81467f2468c746c0817a32cf62ed6a45

  • Joy_1PJoy_1P

    Team Member

    Hey @SandorF! I'm sorry for the delay in getting back to you. The behaviors in your videos are super strange. I'm wondering if the extension has permission to fill on your site. Can you do the following to check on that?

    1. Open Safari > Preferences > Extensions and select 1Password for Safari.
    2. Make sure to provide the extension permission to be functional on all your sites.

    Here's what that screen looks like when the correct permissions are provided: https://share.cleanshot.com/BHQZow

    Additionally, please do the following to check on the Chargebee site in particular:

    1. Open Safari > Preferences > Websites and select 1Password for Safari on the left.
    2. If Chargebee is listed, please make sure it has been set to "allow".
    3. Otherwise, make sure that For Other Websites is set to "allow".

    Here's a screenshot to illustrate those settings: https://share.cleanshot.com/RvILKb

    Please let me know how that goes and if you have any further questions.

  • SandorFSandorF
    Community Member

    Hi, thanks for getting back to me. I know it is super strange. All of the settings are as they supposed to be. This strange issue is still present but seems to happening less frequently.

  • kevin.likevin.li

    Team Member

    Hi @SandorF,

    Thanks for getting back to us.

    Suppose you re-encounter the issue again. Would you try the following workarounds to see if they would improve your state of play:

    1. Open Safari's Preferences and go to the Extensions tab. We can disable and re-enable "1Password for Safari" in the list, then refresh the page/window/tab you were having trouble with.

    2. If toggle 1Password for Safari in the Extensions list didn't work for you. Let's quit Safari by right-clicking its icon in the Dock area and selecting "Quit". Meanwhile, make sure the 1Password 8 desktop app is open & unlocked in the background, then relaunch Safari.

    **Essentially, we always want the 1Password 8 app to start before Safari. This way, we can ensure the proper connection between the desktop app and 1Password for Safari. **

    I'm sorry that the above workarounds are not ideal. Again, I apologize for any inconvenience and confusion it caused.

  • SandorFSandorF
    Community Member

    sure, I will try that and let you know that solves the issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file