Unable to auto-fill username after updating from 1password7 to 1password8

Community Member

After updating from 1password7 to 1password8, I cannot autofill username.

When I select the password field, the input suggestions are displayed, but the login ID (username) does not show any suggestions.
When I was using 1password7, I was able to autofill with no problem.

Here is an example of the site

1Password Version: 8.9.3
Extension Version: Not Provided
OS Version: android13
Browser:_ Chrome



  • WCseVWCu
    Community Member

    Same~ lots of websites cant auto fill username while using 1password 8 andriod.

  • gisky
    Community Member

    Same problem here...

  • Hi @naot, @WCseVWCu, @gisky, thanks for letting us know about the filling issues on your devices. Filling issues can stem from a variety of sources. For that reason I'd like to ask you to create a diagnostics report from your Android device so we can help with each on a case by case basis:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks again!

  • sagark1r1tshah
    Community Member

    I am experiencing same issue. So frustrating. Wish I could get back 1password 7 on my device. But sadly uninstalled it. Got so bad is making me want to use Chrome as a password manager instead of 1pasword.

  • Hi @sagark1r1tshah, I'm very sorry to hear about this issue on your device and I can understand the frustration. I'd like to ask you to send in an email to the address I shared above so we can help take a closer look at the issue and make sure 1Password is working for you.

  • sagark1r1tshah
    Community Member

    Thanks. I have done this, had some helpful responses but didn't address the issue in 1password 8. However the best thing I got was instructions on how to reinstall 1password 7. Have now removed 1password 8 and everything is working gloriously on 1password 7 again.

    Such a shame I needed to upgrade to make autofill work again. By far the most important feature to make 1password usable.

  • Kraptus
    Community Member

    1Password 8 does not auto fill logins anymore on my Pixel 5a. How do I get back to 1Password 7? It's not available on Google Play anymore.
    1Password 8 is now like the little book I kept my passwords in before 1Password!

  • SomebodySomewhere
    Community Member
    edited September 2022

    Same here again.
    First 1PW was not working at all on a Galaxy S8/Android 9.
    Now I tried to vs. 8.9.3, but the problems are:

    • Not one password is entered
    • Passwords are not copied
    • No 1PW icon when logging into a website or app
    • I miss the pin code and have to log in to 1PW every time with my full password instead of a pin code. (5 minutes delay)

    I have setup:

    • Autofill (and permission to 1PW)
    • Show fill suggestions
    • One time copy passwords

    Simply said: 1PW starts but does nothing at all

    Can you please help us out?

  • beeftrash
    Community Member

    Is 1Pass even aware of this issue? Have they made a statement? 8 is not functional on Android.

  • teacy123
    Community Member

    Same here, this is the HTML code of the page, which I feel any heuristic should easily recognise. Tapping the password field will bring up 1PW, but only fill the password, not the username. Tapping the username does nothing. This on a Pixel 5 with Android 13.


            Password: <br />
            <input type="password" name="userpass" value=""><br />
  • I can not good English
    But I can say even the password or the 1PW logo don 't appears.
    It really does nothing.

    I have put on 1PW 7 and that works as I wish.
    To send a report to 1PW I have to install 8 again, which I do not like.

    The Samsung S8 is not a special smartphone.
    It's a standard model so it can not be ver difficult for the developpers I think.

    I have to wait till it works as it should be.

  • Hi @sagarkiritshah, @Kraptus, @SomebodySomewhere, @beeftrash, @teacy123, thanks for reaching out and letting us know this has been an issue for you. Autofill is certainly a key feature on the mobile apps and I completely understand the frustration when it isn't working as expected.

    Autofill issues can stem from a number of different sources and it can be hard to diagnose what might be going wrong for any one person here in the community forum. Please feel free to send us a message to the address I shared about with or without diagnostics. We would be happy to troubleshoot with you.

    We are regularly working to optimize Autofill with 1Password and resolve issues as they emerge. One issue we're currently working to resolve may help with some of the issues mentioned in this discussion. In short, on some devices after tapping a sign in field the time it takes to load Autofill data is exceeding the system limit (~5 seconds) so it is cancelled by the system. Our team has begun testing some ways of reducing the load time from our side and we hope to have this change in an upcoming version.

    This does not appear to be a universal issue or impact all devices. The issue would be more pronounced on older devices, devices with lower processing speed and devices with numerous programs running. Anecdotally, I have no problem filling with the three devices in front of me at the moment: a Pixel 3a , 4a and Samsung S22. That being said, Autofill issues can still occur on these devices.

    If this might be effecting your device, reducing system usage by closing unused apps and tabs as well as turning Show filling suggestions off in 1Password under Settings > Autofill may help. We've also found that switching to Firefox or DuckDuckGo instead of Chrome helps with more consistent Autofill behavior on effected devices.

    @teacy123, apologies if I missed something, which webpage is that HTML code from?

    Thanks again.

  • sagark1r1tshah
    Community Member


    Here are the instructions I received to go back to 1pw7. I have reverted back to 1pw7 and will not install 1pw8 until I'm confident the autofill issues are resolved. Experience was so bad with 1pw8....

    As long as you had installed 1Password 7 for Android on one of your devices via the Google Play Store at some point, you can install 1Password 7 for Android on the device again by following the steps below:

    Open the Google Play Store
    Tap the profile icon in the top right (usually your initials)
    Tap Manage apps and devices
    Tap Manage
    Tap Installed, then tap Not Installed
    Tap 1Password 7 - Password Manager, then tap the green Install button.

  • beeftrash
    Community Member

    @ag_timothy, why does autofill work in 7 and not at all in 8? Seems fishy that it all of a sudden doesn't work in 8. The developers just forgot that it was working?

    Now that I have downgraded to 7 on my S20 Ultra it does not autofill anything. Was working 10 days ago before I upgraded to 8 and now.....nothing.

    You are about to lose a customer that has been here two years. I am going to start looking into alternatives like Last Pass.

  • ssimeonov
    Community Member

    Same problem here with Samsung S22 Ultra - so processing power is out of the question. All worked fine with v7 and after upgrade to v8 - autofill is gone.

  • Thanks for sharing those steps @sagark1r1tshah. I'm sorry to hear about your experience with 1Password 8 so far but I appreciate that you're following along with updates.

    @beeftrash, @ssimeonov, thanks for following up with me. Assuming the same issue is at hand, we think the main culprit may be the use of IconView in AutofillService when generating a response for a fill request. Using IconView seems to be pushing the response time beyond the 5 second window on some devices causing the fill request to be cancelled. While the requests are getting regularly cancelled on some devices, this is not case all the time or for everyone. Generating a response for a fill request was implemented differently with 1Passowrd 7 which could explain the change after updating. We are working to get an update out to address the extended load time but I don't have a date to share at the moment.

    I am very sorry for the trouble. If there's anything I can help with at this time, please let me know. Thanks again.

  • ollie3686
    Community Member

    I am also having this issue. S22 and 1Password 8. Do I have followed the instructions (logs) you suggested originally but suspect this is in hand already

  • nspeaks
    Community Member

    Thank god I am not alone. I got myself a new phone today and ended up installing v8 on it. On the older phone, I had v7 so everything was working fine but couldn't figure out why it stopped working now. I was blaming the updated Android version somehow. Took me some time to find out that 1Password is at fault. Please fix this issue.

  • Wilhelm
    Community Member

    Same problem here. What worries me more is the inconsistency of the app. It works one moment, and the next it doesn't. @ag_timothy - this seems to be escalating quite a bit. Any news on that update you mentioned a week ago? (Appreciate that you shared the issue with us! Thanks for being transparent. It goes a long way.)

  • benmenadue
    Community Member

    I have the same (or similar) problem on a Galaxy S8.

    With 1Password 7, most of the time when clicking on a username or password field it would give me a drop-down to pick a login (or pop up an overlay to search for it if it didn't find a matching one). When that failed (occasionally) to happen you could long-press on the field and select "auto-fill" there to trigger the same thing.

    However, with 1Password 8 there doesn't appear to be any indication that it's even been invoked. Clicking on the username and password field just brings up the keyboard. There's never any drop down to select an login from or trigger the search overlay, and long-pressing the fields no longer presents an "auto-fill" option (it does give me an option to paste, so I can still at least copy/paste from the main 1Password app, but that's pretty inconvenient).

    I've tried disabling and re-enabling 1Password in the device's autofill service settings, and have also tried various combinations of the settings in 1Password's autofill settings in the app.

  • SomebodySomewhere
    Community Member

    Same here.
    And many fields on laptop or S8 will not be filled in.

  • DaftCynik
    Community Member

    I am feeling way less crazy now that I've found this thread. I updated to 1password 8 and everything is clunky, on both my Xperia 5ii, and also on my browser. My wife also has issues on her iPhone. Our subscription just posted, but I'll be honest, with all the headaches this is causing, I'm strongly considering switching to another service. Took me a while to convince her to switch over, and now I don't have a great solution for our problems. For what it's worth, the new layout of the app is not something I'm a fan of. There should be a permanent search bar at the top on all pages. Having to back out or search at the bottom while the auto fill is broken has been such a pain.

    Side note - I was unable to create a community account on my phone due to a repeated failure of the Captcha, so I had to log in a retype this from my computer. Very frustrating.

  • jerryziggy2004
    Community Member

    I was having the same issue after the update to v8, and resolved it on my device. If anyone is still having trouble with autofill on their mobile device, try the following steps.
    1) click the profile icon in the upper right corner
    2) go to settings...
    3) click autofill (6 down from the top in the settings menu)
    4) make sure the autofill switch is on. I have all on to be safe.

    If the following steps don't work try uninstalling the 1password app and follow the steps again.

  • dmpaul1
    Community Member

    I have the same issues with 1password 8.9.6-11 not filling in user name field in apps. It will autofill the password field. 1password 7 is no longer downloadable from google plays store, so there is no way to go back to a working android password manager.

  • DaftCynik
    Community Member

    For reference I did change the auto fill options before posting this. This forum is where I read that solution but after it still didn't work, I registered to voice my concers.

  • ZaitsevGR
    Community Member

    I have the same problem. I have tried on OnePlus 9pro and OnePlus 6.
    I have deactivated and reactivated the autofill but didnt work either. I tried Reinstalling and removing the beta but it didnt work.

  • ag_timothy
    edited October 2022

    Hello all, thanks for the continued feedback here. Reading through the recent posts it sounds like some of you may be running into a few separate issues. As always I am sorry for inconvenience and any frustration.

    In case it's been missed, if you're using a Xiaomi, Redmi or Poco device, please check out this post: If you're encountering Autofill issues with 1Password 8 on a Xiaomi device

    @ollie3686, @nspeaks, @Wilhelm. Today's beta, 8.9.7-7, includes some of the work done to cut down on Autofill response time by changing how we load icons that I mentioned above. This is not a "silver bullet" to address all Autofill issues but a step in the right direction for devices effected by the intermittent filling prompts. If 8.9.7-7 is not currently available to you, please check back soon as Google Play rolls it out. If you get the chance to try out the beta, let us know if you see any change in behavior.

    If you're interested in trying the beta you can find steps to update here:

    I will preemptively note that we've found a regression on some devices with the 8.9.7-7 beta wherein Autofill suggestions may not be displayed when the setting is on (you will just see "Open 1Password" and not your linked items). We are currently investigation this issue.

    @DaftCynik, my apologies for the clunky start to 1Password 8. As you've mentioned running into issues with 1Password for Android, iOS and in the browser I'd like to ask you to reach out to us directly via email at [email protected] so we can make sure each is resolved. You can include a brief description of the issue with your email. After emailing in, you'll receive a reply from BitBot with a support ID that looks like [#ABC-12345-678]. Post that here, and I'll be able to locate your email and make sure it's gotten to the right place.

    @SomebodySomewhere, as you're also running into issues with both 1Password for Android and 1Password in the browser you can reach out to us directly with the steps I shared for DaftCynik above.

    @dmpaul1, is 8.9.6-11 not filling in user name fields in apps only or in browsers as well? Could you share a few apps and, if applicable, websites where you've seen this?

    @ZaitsevGR, just to make sure we're on the same page, could you tell us a little more about the filling behavior you're seeing with 1Password 8.

  • dmpaul1
    Community Member

    Generac mobile link app will not accept a username, but will autofill password. This with a samsung galaxy Tab S8 and android 12.

  • ZaitsevGR
    Community Member

    Well I only get the option to autofill the password and not the Username. There is no icon of 1 password on the Username field.

  • SomebodySomewhere
    Community Member

    Same here.
    And at bank sites it doesn't fill in anything.

    In the laptop version of 1PW the same on bank sites

    Android 9