Rich Icons missing in List View

Kh0rnKh0rn
Community Member

I have a problem with the Rich Icons cross all platforms with 1Password8

In the list view, for roughly 50% of the logins the rich icons are not shown, but if I select a login the icon is their on top of the entry.
Is this a caching problem, or related to Icon resolution?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided

Comments

  • ag_mike_dag_mike_d

    Team Member

    Hi @Kh0rn,

    Thanks for your message. I'm sorry to hear of the troubles you've been encountering with Rich Icon in 1Password 8.

    Based on your description, I understand some of the rich icons are not appearing in the item list, but those same icons do display as expected in the item detail window (the right pane)?

    If you haven't already, you could try unchecking/re-checking the following setting: Settings (Ctrl + Comma) > Privacy > Show app and website icons. Then completely quit 1Password 8 from the system tray icon and sign back in to 1Password 8.

    Looking forward to your reply.

  • Kh0rnKh0rn
    Community Member

    This was one of the first things I tried.

    Same behavior on all apps, iOS, macOS and Windows, all up to date.
    Only on the website the icons are shown correctly in the list.
    Example:

    As a test I also already tried to created a new entry in a new vault, same problem.

  • MrCMrC
    Volunteer Moderator

    I noticed this also today, on my iPad, while trying to auto fill a login into an app. I have two logins which I use multiple times a day, and the site icons have always been present in the list. Not today.

  • ag_mike_dag_mike_d

    Team Member
    edited October 14

    Hello @Kh0rn and @MrC,

    Thanks for your updates here. Sorry for the continued issues. It's seems we've had at least one other report internally and I've filed this with the development team to take a look.

    In the meantime, I'd like to ask each of you to create a diagnostics reports from your devices:

    Sending Diagnostics Reports

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks!

    ref: dev/core/core#18063

  • DenalBDenalB
    Community Member

    I don't have this issue. Could it be that this is because I'm using custom icons for my entries? I disabled the setting to show app and website icons. So only my custom icons are shown.

    I'm using 1Password for Windows 8.9.7-17 beta build.

  • Joy_1PJoy_1P

    Team Member

    Hey @DenalB, you're correct. If you use custom icons, then your experience would be different. Only your custom icons would show.

  • MrCMrC
    Volunteer Moderator

    I've sent in my diagnostic report and screenshots, but haven't received a BitBot reply.

  • ag_tommyag_tommy

    Team Member

    Thanks MrC. We've got it.

    ref: ZCT-95534-599

  • MrCMrC
    Volunteer Moderator

    ZCT-95534-599

  • ag_mike_dag_mike_d

    Team Member

    Thanks, @MrC! 👍

  • nprnpr
    Community Member

    Is this bug on your roadmap to fix? Even deleting items where this is happening, and setting them up again as new, still no icons in the list view.

  • ag_mike_dag_mike_d

    Team Member
    edited November 15

    Hello folks and @npr - after some debugging, in most cases the team has found this to be an issue where we have an Item Detail-sized icon available but not a list-size variant for rich icons.

    I've looked back and found some instances where 1Password 8 is now showing the list icons correctly. If you're willing, could you please send an email message addressed to [email protected] with the URL(s) of affected items where rich icons appear in item detail view only?

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks!

    ref: dev/core/core#18063

  • MrCMrC
    Volunteer Moderator

    I sent a nice long list of problematic list view icons vs. detailed icons.

    VWM-59375-754

  • ag_mike_dag_mike_d

    Team Member

    Thanks, @MrC! We'll back in touch soon.

  • foxxerofoxxero
    Community Member
    edited November 22

    I'm experiencing the same issue exactly as described by @npr. Custom icons always show, though.

    Checking and unchecking "Show app and website icons" and restarting the app fixed some icons, but not all.

  • ag_mike_dag_mike_d

    Team Member
    edited November 22

    Hello @foxxero,

    Thanks for your message! We’re aware of this issue related to some rich icons and are working on fix. While I can't provide a timeframe, I've added your report the issue were tracking internally.

    In the meantime, the use of a custom icon should help:
    1. Select the item you'd like to update.
    2. Click Edit.
    3. Click the icon and Choose new icon... to add a .png/.jpg from your device.

    Please let us know if you have any further questions.

    ref: dev/core/core#18063

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file