1 Password keeps changing my security setting from NEVER ask for a Password to EVERY 30 DAYS

DubDub
Community Member
edited November 22 in Mac

I use 1 Password on Apple computers with Mac Ventura.My preferences are set to open 1Password with a fingerprint or an Apple Watch and NEVER ask for a password.
But each time I turn my computer off, when I turn it back on, 1Password has changed my preference to ask for the Password to every 30 days and on random occasions to every 2 weeks.
This is SUPER ANNOYING!
Is this a bug in the current software?
Please help!!!!


1Password Version: 1Password for Mac 8.9.8
Extension Version: 2.4.1
OS Version: MacOs 13.0.1
Browser:_ Safari

Comments

  • DubDub
    Community Member
    edited November 22

    P.S. I have tried all the different possibilities with 1Password opening on log in, not opening on log in, quitting 1Password before turning the computer off, leaving 1 Password running when turning the computer off and none of these things make any difference..

  • fuchsrfuchsr
    Community Member

    I feel your pain. I have no idea what the logic is behind 1PW prompts for passwords. The only thing I know for sure is, they happen way too often, especially on the Mac. iOS feels less frequent.

  • Dave_1PDave_1P

    Team Member

    @Dub

    I'm sorry that the "Require Password" setting is changing after a restart. That definitely doesn't sound right and I'd like to investigate further. Please do the following:

    1. Change the "Require Password" setting to 30 Days.
    2. Change the "Require Password" setting to "Never" and note the time.
    3. Restart your Mac.
    4. Check the "Require Password" setting and make sure that it's been changed. Note the time and the value that it was changed to.

    I'd then like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    The report will be in zip format. Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • Dave_1PDave_1P

    Team Member

    @fuchsr

    You can configure how often 1Password locks by following this guide:

    If you've already tried this then can you tell me what your settings currently are and how often 1Password is locking on your Mac? 🙂

    -Dave

  • DubDub
    Community Member

    Per your instructions:
    1. I changed the "require password" setting to 30 DAYS and after that I changed it to NEVER at 9:19 AM PST
    2. I restarted my Mac and the "require password" setting changed all by itself from NEVER to 30 DAYS. The time was 9:20 AM PST.

    I sent the email with the information you requested and attached the diagnostics report.

    The support ID number is: [#KIK-57351-122]

    I will be waiting for your response, hopefully with a solution to the problem.

  • DubDub
    Community Member

    My lock settings are:
    Lock on sleep, screensaver or switching users (this setting is checked).
    Lock after computer is idle for 10 minutes.

  • DubDub
    Community Member

    I would like to add that I have the exact same "require password" problem with two other Macs, so it is a pervasive problem on multiple machines.

  • fuchsrfuchsr
    Community Member

    My settings are Require Password Never. Auto-lock off. Lock after idle Never.

    Can't really say how often it is locking, it seems to happen every few days for no apparent reason. I know that's not helpful but I can't find a pattern.

  • pineconepinecone
    Community Member

    I'm having to enter my password often also. Cannot find a pattern. Same settings as @fuchsr .

    Ventura 13.0.1
    version 8.9.8

  • andrew.l_1Pandrew.l_1P

    Team Member

    @Dub,

    Thanks, I can confirm we've received your diagnostic report. I've replied to your email so keep an eye out for that!

    @fuchsr and @pinecone,

    Sorry to hear you're experiencing something similar. If you set "Require password" to "Never" and then reset your device, can you tell me if the selection remains? If not, I'd also like to ask you to send in some diagnostics so we can take a look at what's going on under the hood:

    These can be attached to an email sent to [email protected]. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can link the conversations.

    Let me know if you have any questions!

    ref: dev/core/core#18707
    ref: KIK-57351-122

  • fuchsrfuchsr
    Community Member

    Reset, as in reboot?

  • andrew.l_1Pandrew.l_1P

    Team Member

    Oops, good catch @fuchsr! I should've said restart there:

  • DubDub
    Community Member

    Andrew: Thank you for looking into this and thank you for your email.
    Just so everyone else is informed:
    Andrew.I_1P is able to reproduce the issue. It appears that this is something that requires 1Password developers to get involved in order to fix it.
    Hope they fix it soon!

  • fuchsrfuchsr
    Community Member

    I did the restart, and the setting remains at Never.

  • andrew.l_1Pandrew.l_1P

    Team Member

    Happy to help, @Dub! Looking forward to sharing updates once we have them.

    @fuchsr,

    Thanks for testing this! Odd that it behaves a bit differently for you. The next time you notice the setting change, please feel free to generate and send over that diagnostic report. Likewise if you notice any patterns in when this happens. I apologize for any interruption this is causing you and really appreciate you helping us report this!

  • Monkey121Monkey121
    Community Member

    I am on the beta build and I am seeing the same issue.

  • andrew.l_1Pandrew.l_1P

    Team Member

    Hi @Monkey121,

    Sorry to hear you're experiencing something similar. Could I confirm if restarting your device changed this setting? Either way, the next time you notice it, you're welcome to send over a diagnostic report so we can investigate further:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can link your conversations.

    I apologize for any interruption this is causing you and appreciate you helping us report it. Let me know what you find. 🙂

  • sofsof
    Community Member
    edited November 29

    I’m experiencing this as well, both on macOS and iOS. Setting to never and killing the app from the app switcher on iOS then relaunching it within a few seconds sees the setting switched back to 30 days every time. Similarly, setting the setting on macOS, quitting the app from menu bar, then immediately relaunching it sees the setting go back to 30 days.

    In addition, faceID never works on the iOS safari extension (not autofill password, extension itself) so I’m made to retype my password every day, sometimes within multiple minutes of each unlocking in the same safari session. Really frustrating especially with a long master password.

  • Dave_1PDave_1P

    Team Member

    @sof

    I'm sorry that the setting is also being reset on your Mac. I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    The report will be in zip format. Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    In addition, faceID never works on the iOS safari extension (not autofill password, extension itself) so I’m made to retype my password every day, sometimes within multiple minutes of each unlocking in the same safari session. Really frustrating especially with a long master password.

    We've recently released an update that should have improved things. Can you please make sure that you're using 1Password 8.9.7 and iOS 16.1 or later:

    -Dave

  • sofsof
    Community Member

    Support ID: #ILC-11637-463 for macOS issue

    re: the iOS issue, I'm already on the latest 1Password and iOS 16.1. Not fixed for me.

  • Dave_1PDave_1P

    Team Member
    edited December 1

    @sof

    Thank you for the Support ID. I've located your ticket and I see that my colleague has responded, I recommend continuing the conversation over email so that the team can investigate the iOS issue as well. My colleague will follow-up with you over email as soon as possible. 🙂

    -Dave

    ref: ILC-11637-463

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file