1Password on Mastodon

Issue with system authentication service

feaxfeax
Community Member

I'm trying to use my laptop fingerprint sensor to unlock 1password.
Running Arch with i3 and fprint.
My fingerprint sensor is working well to unlock my computer (lightdm) or with the command line when authentification is required.
Since I clicked the system authentication service option in 1password I can see a fingerprint option on my 1password login screen. So far so good.
However when I try to use the sensor to login literally nothing happens as if I wasn't using the fingerprint sensor at all.

the 1password polkit policy seems in place:
$pacman -Ql 1password | grep -i polkit
1password /usr/share/polkit-1/
1password /usr/share/polkit-1/actions/
1password /usr/share/polkit-1/actions/com.1password.1Password.policy

No Polkit related errors in the logs when I try to login.
INFO 2022-12-15T13:46:02.225 op_executor:invocation_loop(ThreadId(25)) [1P:op-app/src/app/backend/lock.rs:90] Lock state changed: Locked
INFO 2022-12-15T13:46:02.225 op_executor:invocation_loop(ThreadId(25)) [1P:op-app/src/app/backend/lock.rs:105] Locked. Reason: Manual.
ERROR 2022-12-15T13:46:02.228 tokio-runtime-worker(ThreadId(136)) [1P:/builds/dev/core/core/ui/op-main-menu/src/lib.rs:1502] ItemWithIdNotFound(ItemId(1115))
ERROR 2022-12-15T13:46:02.229 tokio-runtime-worker(ThreadId(136)) [1P:/builds/dev/core/core/op-ui/src/item_action/mod.rs:159] ItemWithIdNotFound(ItemId(1115))
ERROR 2022-12-15T13:46:02.229 tokio-runtime-worker(ThreadId(136)) [1P:/builds/dev/core/core/ui/op-main-menu/src/lib.rs:1502] ItemWithIdNotFound(ItemId(1115))
ERROR 2022-12-15T13:46:02.232 tokio-runtime-worker(ThreadId(136)) [1P:/builds/dev/core/core/ui/op-main-menu/src/lib.rs:1502] ItemWithIdNotFound(ItemId(1115))
ERROR 2022-12-15T13:46:02.232 tokio-runtime-worker(ThreadId(136)) [1P:/builds/dev/core/core/op-ui/src/item_action/mod.rs:159] ItemWithIdNotFound(ItemId(1115))
ERROR 2022-12-15T13:46:02.232 tokio-runtime-worker(ThreadId(136)) [1P:/builds/dev/core/core/ui/op-main-menu/src/lib.rs:1502] ItemWithIdNotFound(ItemId(1115))

polkit.service is running fine

Can you help?
Thks,
F


1Password Version: 8.9.8
Extension Version: Not Provided
OS Version: Archlinux 6.0.11-arch1-1
Browser:_ Not Provided

Comments

  • AliH1PAliH1P

    Team Member

    Hey @feax, thanks for reaching out. If you unlock 1Password with your account password, then manually lock 1Password and unlock it again, is your account password still requested on the second unlock, or do you receive a system authentication prompt?

    You mentioned that you're seeing the fingerprint icon next to the account password field, if you click on this icon does the system authentication prompt appear? If so, does your fingerprint unlock work then?

    Looking forward to hearing from you!

    Ali

  • feaxfeax
    Community Member

    Hi Ali,
    1) Account Password still requested on the second unlock.
    2) When I click on the fingerprint icon it behaves as if I was entering the wrong password (the window shakes a bit). After pressing the fingerprint icon 3 times I’m only left with the input field for my account password. The fingerprint icon being replaced by an arrow to validate the account password.
    Best,
    Francois

  • AliH1PAliH1P

    Team Member

    Hey @feax, that's definitely some strange behaviour. To investigate further, I'd like to ask you to create a diagnostics report from your device:

    Sending Diagnostics Reports (Linux)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    We'll look forward to hearing from you.

    Ali

  • feaxfeax
    Community Member

    done

  • GreyM1PGreyM1P

    Team Member

    @feax – Thank you! We've received it and one of the team will reply to you as soon as they can. :)

    ref: YLL-66725-973

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file