1Password feels autofill is turned off but it isn't on my Samsung Phone

Community Member

I am using the latest version of 1Password on my Galaxy S22 Plus. I have all the required permissions in place including the autofill. It works as expected. But every once in a while the autofill does not work so when I open the app, it gives me a notification that autofill is turned off.

This is really weird for two reasons
1. I never turned off autofill for 1Password
2. When I go to the autofill settings, 1Password is always selected. But for some reason 1Password feels autofill is turned off.

The workaround I do is, deselect and set to None and then reselect 1Password. Only by doing this procedure it works.

PS. I have already set 1Password to "never sleeping apps" on my phone.

1Password Version: 8.10.16
Extension Version: Not Provided
OS Version: Android
Browser: Not Provided


  • BrendanR1P
    edited October 5

    Hi @nullptr7,

    I'm sorry to hear you're encountering this issue with autofill being shown as turned off within the 1Password for Android app even though 1Password is still enabled as the system autofill service.

    This issue can occur due to battery optimization settings on some devices. I can see you've set 1Password to never sleeping on your phone. Could you please try the following steps below to see if they resolve the issue?

    Lock the 1Password app in Recent apps

    1. Open Recent apps.
    2. Find 1Password
    3. Long-press/ single tap on some devices, the 1Password app icon.

    Set 1Password to Don't Optimize in Battery Optimization settings

    1. Open your device settings
    2. Tap Apps -> 1Password -> Battery -> Battery optimization -> All apps -> 1Password -> Don’t optimize.

    I hope this helps.

    -- Brendan