Safari Extension on iOS and iPadOS not respecting lock or re-authorisation timers...

Hi,

Is anyone else finding that in order to unlock the 1Password Safari extension on iOS (and iPadOS) requires going to the 1Password login page each time? The extension does not seem to be respecting my lock-out timer (currently set at 8 hours) nor is it respecting the re-authorisation timer (2 weeks) each time I try and click on the face-id icon (before it disappears and says "Sign in with Passkey") it says it cannot connect with the 1Password app (despite it being unlocked).

Running the most recent beta release of the App.

iOS is up to date (as is iPadOS, where the same issue is happening)

Thank you


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser: Not Provided

Comments

  • gussic
    gussic
    Community Member

    bump

  • Hello @gussic! 👋

    Thank you for helping us test the beta version of passkey unlock for 1Password! I'm sorry that you're being prompted to sign in with your passkey more often than expected. It sounds like 1Password for Safari is having trouble authenticating. Please try the following steps:

    1. Fully close Safari on iOS.
    2. Fully close 1Password on iOS.
    3. Open and unlock the main 1Password app from your home screen.
    4. Open Safari and go to any webpage.
    5. Tap on the AA icon in the address bar.
    6. Tap on 1Password in the menu.
    7. Follow the prompt to unlock 1Password for Safari.

    Does this resolve the issue or do you still see the same message and behaviour? I look forward to hearing from you.

    -Dave

  • gussic
    gussic
    Community Member

    Hello @Dave_1P

    Apologies for the delay in responding. Yes I've tried all of those methods multiple times and still get the same error...

    I'm not sure if this helps but here are the version numbers of the App and Extension:

    iOS App:
    1Password for iOS 8.10.26 81026038, on BETA channel

    iOS Safari Extension:
    1Password browser extension version 2.20.0
    22000002, on STABLE channel

    Hope this helps

    Cheers

  • Dave_1P
    edited February 15

    @gussic

    Thank you for those details, I've shared your report with the team and we're investigating. We've been able to reproduce the issue on our end as well and no other information from your end is needed for now.

    Thank you again for helping us catch bug like this in the beta, hopefully the issue will be fixed soon.

    -Dave

    ref: dev/core/core#22920

  • gussic
    gussic
    Community Member

    @Dave_1P

    Thanks for letting me know - good (but also bad haha) that it wasn't just me having this issue!

    Is there a way to sign up to a notification service for when this bug has been fixed?

    Cheers

  • Hi @gussic 👋

    To stay up to date with when a fix is released, you can keep an eye on our release notes here: 1Password Releases

    In the meantime, I'd highly recommend making sure to keep 1Password up to date so that you get a fix as soon as it's released.

    Let us know if you have any questions.

    -Trevor