Create Password Causes Glitch

elijahw
elijahw
Community Member
edited March 10 in Windows

Hi all,

Edit: I've seemingly resolved the problem, see my next post below.

Original post:

I've been using 1Password for Windows for ages without a problem and recently encountered a weird bug. When trying to create or generate a new password, the password generator window does not appear as it gets glitched "inside" the 1Password app.

To demonstrate, here is the app where I'm editing a login entry, before clicking the "Create a New Password" button:

And here is what happens immediately after clicking it. The password generator box doesn't show and the main menu goes blank. The list of logins in the middle (between the main menu and the individual login fields/details) is not affected:

The reason I say the password generator field gets glitched "inside" the app is because if you left or right click the mouse anywhere inside the app, the screen below will flash for less than a second (I had to record a video and extract the one frame to get the screenshot below):

I found that if I use keyboard shortcuts to tab my way through the fields and hit enter, it'll generate the password. So the "password generator" window is showing and it has focus, its just kind of hidden/glitched inside the app. The window isn't hidden behind the main app, I've moved the app window and there's nothing behind it.

I'm on Windows 10, 1Password 8.10.27 (production channel) but did try nightly with no change. I've clean uninstalled the program and reinstalled but the bug persists. I was on the previous version when it started and updated when 8.10.27 dropped with hopes this bug was addressed but it wasn't.

With nobody else reporting this, its surely something to do with my specific setup but I'm unsure what to try as I don't know what the app needs. Is there a certain C++ Redistributable I can download to see if it'll kick it back into gear? Any help would be massively appreciated!

Thanks all,
Elijah


1Password Version: 8.10.27
Extension Version: Not Provided
OS Version: Windows 10
Browser: Not Provided

Comments

  • elijahw
    elijahw
    Community Member

    I seemed to resolve the problem ... after all the messing about, of course it happens right after I post! πŸ˜… Below is a complete list of the steps I went through but the short version is that I think installing 1Password 7 and then updating to 1Password 8 (nightly build) ended up fixing whatever problem I had.

    Full list of steps taken:

    1. Downloaded 1Password 7 from the link recommended in this forum post
    2. Uninstalled 1Password 8
    3. Installed the recently downloaded 1Password 7 and logged in to my account
    4. I found previous 1Password 8 versions (nightly build) on this site
    5. I downloaded version 8.10.24-29.NIGHTLY (build #81024029) – released 2024-01-04. I just randomly chose a version by picking the first release in 2024 as I knew it was working back then
    6. Installed the recently downloaded 1Password 8 nightly
    7. Note: It failed to open, giving a generic error. I noted that it "upgraded" my installed 1Password 7, they aren't installed side-by-side. I opened Windows Explorer to %localappdata% and renamed the folder titled "1Password" to something else (or optionally delete it)
    8. Attempt to run 1Password 8 again, this time it loaded and let me login
    9. After login, I tested the "Create a New Password" button worked. I had a notification at the bottom about 1Password self-updating and offering a link to close and update. Click that to relaunch
    10. Now running the latest version: 8.10.28 (build #81028036). Tested the "Create a New Password" button, it still works
    11. Signed into my second account (now signed into 2 total accounts) and tested it still works
    12. Exited 1Password completely, relaunched, signed in, tested again and it still works

    I hope this helps someone, somewhere with a problem they're facing. I hate searching for help with a problem and seeing a post saying "nevermind fixed it" πŸ˜…

    Thanks all,
    Elijah

  • Hello @elijahw! πŸ‘‹

    I'm sorry that you ran into an issue where 1Password's main window didn't function properly. This is a known issue that our development team has investigated and is currently testing a fix for in the latest beta and nightly versions of the app.

    If anyone else runs into the same issue then I recommend the following workaround until the fix makes it to the stable version:

    1. Open and unlock the 1Password app.
    2. Click your account or collection at the top of the sidebar and choose Settings.
    3. Choose Appearance.
    4. Uncheck "Tags" under the Always show in Sidebar section.

    Alternatively, if you'd like to help us test the fix you can update to the latest beta version: Use 1Password beta releases

    Let me know if you have any questions.

    -Dave

    ref: dev/core/core#28117

  • elijahw
    elijahw
    Community Member

    Thanks @Dave_1P, its good to know that 1Password is aware of it. Turning off tags was neat and I did it away. Is there any chance it's possible to pin specific Logins to the sidebar? Like ones that we use a lot, etc? I know its off-topic but thought I'd ask if you knew.

    Thanks Dave,
    Elijah

  • @elijahw

    Thanks for the question! There isn't a way to pin specific logins to the sidebar but you can favorite logins and access them by clicking Favorites from the sidebar: Organize with favorites and tags

    Alternatively you can quickly open logins by using Quick Access: search for a login and then press Ctrl + Shift + O to open that login in 1Password.

    I hope that helps. πŸ™‚

    -Dave

  • @elijahw

    I wanted to drop a note that our developers have released an update to the stable version of 1Password that includes a fix for an issue where using certain tags could result in visual issues or cause the app to become unresponsive. If you'd like, you can revert back to the stable version from the nightly:

    Let me know if you have any questions or run into any issues. πŸ™‚

    -Dave