Blank square appears on screen when clicking on "Open 1Password"

Options
more_cowbell
more_cowbell
Community Member
edited May 23 in 1Password in the Browser

Is this just me? I can't enter password from the extension path. Just get black screen.


1Password Version: 8.10.32
Extension Version: 2.23.3
OS Version: Win11
Browser: Edge

Comments

  • sunshinemu
    sunshinemu
    Community Member
    Options

    I am having the same problem when using the built in SSH Agent. This started today after the update.

    1Password Version: 8.10.34
    OS Version: Win11
    SSH Agent: Active

  • more_cowbell
    more_cowbell
    Community Member
    Options
  • Dave_1P
    Options

    Hello @more_cowbell and @sunshinemu! 👋

    I'm sorry that 1Password's unlock window isn't rendering correctly. So that I can investigate this further, please reproduce the issue again and then I'd like to ask you to create a diagnostics report from your Windows PC:

    Sending Diagnostics Reports (Windows)

    Attach the diagnostics to an email message addressed to support+forum@1password.com.

    With your email please include:

    Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    -Dave

  • more_cowbell
    more_cowbell
    Community Member
    edited May 22
    Options

    Uninstalled both the 1Password app and browser extension last week and it fixed things, but short lived. It went back to black screen yesterday. Also updated the app today and it's still an issue.

    [#MHR-56658-562]

  • Dave_1P
    Options

    @more_cowbell

    I'm sorry that the issue came back. I see that my colleague sent you a response and that they're currently reviewing the logs that you sent in. You'll receive another reply soon, please continue the conversation over email.

    -Dave

    ref: MHR-56658-562

  • phne
    phne
    Community Member
    edited May 23
    Options

    Same thing happened to me. I fixed it by doing this:

    1Password browser extension->Settings->General->Integrate this extension with the 1Password desktop app->Switch off->Switch on

    and then I locked 1Password to test and could see it worked again.

  • Dave_1P
    Options

    @more_cowbell and @phne

    Our team has received a few other reports of the issue and we're investigating this behaviour. For the time being, you might be able to workaround the issue without having to turn off app integration by following these steps in the desktop app:

    1. Open and unlock 1Password 8.
    2. In the top left, click ⋮ > Settings > Advanced.
    3. Uncheck the option to Use Hardware Acceleration.
    4. Fully quit and restart the app with Ctrl + Q or by right clicking the icon in the system tray > Quit.
    5. Relaunch 1Password and test whether you can still reproduce the black window.

    Let me know if that helps. 🙂

    -Dave

    ref: dev/core/core#29932

  • more_cowbell
    more_cowbell
    Community Member
    Options

    Turning off acceleration:

    Oddly on another Win11 machine unlocking from browswer looks different and this is how this problem pc looked for a couple days after reinstalling app/ext before it went black again. It only opens 1 window with password prompt vs 2.

  • Dave_1P
    Options

    @more_cowbell

    Thanks for the reply. It looks like turning off hardware acceleration allows you to workaround the issue, did I understand correctly?

    Oddly on another Win11 machine unlocking from browswer looks different and this is how this problem pc looked for a couple days after reinstalling app/ext before it went black again. It only opens 1 window with password prompt vs 2.

    It looks like the integration between the browser extension and the desktop app is either turned off or not working on that PC. Are you still seeing that behaviour now or did it completely go away once you reinstalled 1Password?

    -Dave

  • more_cowbell
    more_cowbell
    Community Member
    Options

    Yes, for the time being it’s working but looks different. What will be lost with acceleration disabled?

    Not sure I fully follow your 2nd question, but on the pc having this issue but integration is enabled and I’m able to enter password from the browser icon but I see 2 windows open vs 1.

  • sunshinemu
    sunshinemu
    Community Member
    Options

    This worked for me as well. Such a strange defect.

  • phne
    phne
    Community Member
    Options

    disabled hardware acceleration. So far so good. Will report back if it reappears.
    Thanks Dave_1P!

  • Dave_1P
    Options

    @more_cowbell

    If app integration is turned on then the expected behaviour is to see a small window for the 1Password app since it'll launch to complete the unlock process. Temporarily turning off hardware acceleration until the issue is fixed shouldn't result you in seeing a noticeable impact.

    @sunshinemu and @phne

    I'm glad that the workaround helps. 🙂

    -Dave

  • more_cowbell
    more_cowbell
    Community Member
    Options

    So the password prompt should be 1 single window opening…not 2?

  • phne
    phne
    Community Member
    Options

    Just wanted to report back that Dave_1P's suggestion to turn off hardware acceleration has worked perfectly. Thanks again Dave! 😊

  • Dave_1P
    Options

    @more_cowbell

    It's normal to see two windows, the browser extension calls the desktop app which then authenticates 1Password. If you'd like to have the browser extension authentication itself then you can turn off app integration in the browser extension's setting page.

    @phne

    I'm happy that the workaround worked for you as well. Hopefully the issue is permanently fixed soon. 🙂

    -Dave

  • more_cowbell
    more_cowbell
    Community Member
    Options

    I wouldn’t call disabling hardware acceleration a permanent fix. Also, on the 1 vs 2 windows. When I first reinstalled all 1 password components after removing…why did it open with only 1 password prompt window for about a week? App integration was always on.

  • Dave_1P
    Options

    @more_cowbell

    Turning off hardware acceleration is a workaround for now until our developers release a permanent fix that doesn't require this workaround.

    When I first reinstalled all 1 password components after removing…why did it open with only 1 password prompt window for about a week?

    It sounds like app integration may not have been working properly even if it was enabled which resulted in the browser extension falling back to its own lock screen. Do you still see this issue?

    -Dave

  • more_cowbell
    more_cowbell
    Community Member
    Options

    No, I do not. Not sure I’d say it failing since it was unlocking both browser and app. Very strange, unexplainable stuff I guess.

  • david.m_1P
    Options

    It's good to hear that you're no longer seeing the issue @more_cowbell! Hopefully there will be a fix soon! If you encounter the issue again, let us know, and we can troubleshoot further.

    -David