Thurs 20 Jul Update Breaks 1Password/Opera

MacOS Sierra Version 10.12.6
Opera Version 46.0.2597.57
1Password Version 6.8 (680014)
Mac Mini

Note: I've updated three other Macs so I'm going to have a long day ahead if this breaks 1Password. I'm holding off updating my iMac until it works and will tell the rest of my family to do the same.
Note2: When you save a draft in this forum board, you can not post it later as it won't let you choose the category and then errors out saying you have not chosen a category.

So, on to the error:

I was just notified by Apple that there was an update available to both 1Password as well as OS X.
I updated and allowed it to install everything and reboot.

Opera:
Now 1Password errors out when trying to open Opera with "1Password can't save or fill in Opera"
I've added the ~/Library/Application\ Support/Chrome
Still get the error.
I added (touch) a file inside the Chrome directory just to make sure I could write to it and that worked.
I can no longer use 1Password in Opera on this machine.

I did have an entire writeup about Safari as well but while I was writing it I got the "Compare this number with the one in 1Password" and the extension is now working in Safari.

Here are screenshots of trying to make Opera work with the new version of 1Password


1Password Version: 6.8 (680014)
Extension Version: Not Provided
OS Version: MacOS 10.12.6
Sync Type: iCloud

Comments

  • Update:
    I just caught that I dropped the "Google" when creating the directory from my home directory's Library. Added that.
    Big thing is to wait after updating everything and making that directory. It took 2-3 minutes then I got a "extension requires authorization" message.

    Now it works :)

  • rudyrudy

    Team Member
    edited July 2017

    @tridandroid,

    Unfortunately it didn't work in the best way possible, that you're being prompted for authorization means you're still on the old communication pathway, which will go away at some point in the future landing you back here again.

    Since you're using the Mac App Store version you'll want to Help -> Troubleshooting -> Restart mini after creating that ~/Library/Application Support/Google/Chrome directory path. Then restart Opera; if it all worked you should see a process called OnePasswordNativeMessageHost in Activity Monitor, and the extension should still function as before.

    Rudy

  • It seems that all of them I updated now have a directory:

    NativeMessagingHosts

    and have

    OnePasswordNativeMessageHost

    in their activity monitors along with the mini and main program where they're open.

    One really weird thing is I'm seeing stuff I deleted close to a year ago. The new stuff is there too but one of these machines has not been sync'd in forever. Wow.

  • BenBen AWS Team

    Team Member

    Thanks for the feedback, @TriDanDroid. Sorry to hear about the old stuff reappearing. Hopefully you were able to get that sorted out?

    Thanks.

    Ben

  • Yup. My guess is the one machine either choked or went off the grid with the iCloud stuff and just updating it brought it back, then everything else thought, "Hey, this is new stuff, lemme propagate..." That machine is one I'm not on frequently but is nice to have around when I want to try something that may very well kill off everything.

    Easy enough to go through and weed, just look for dupes or things I have no idea what the heck they are.
    Now everybody's happy, holding hands and singing kumby-ya again.

    I do appreciate the responses.

  • edited July 2017

    I really need to look for another avatar.
    (edit) Much better!

  • JacobJacob

    Team Member

    On behalf of Ben and the team, you're welcome. :) We're here if you have some other questions!

This discussion has been closed.