1Password X touch id?

I have 1Password X (1.11.8) installed and it works in Edge Chromium, Chrome etc. I use a MacBook Pro 2016 with touchbar.

Touch ID works for 1Password 7, but I see no way to configure it in 1Password X.

Question 1: How to set up touch ID in 1Password X?

I also have 1Password 7 (7.4.4 Beta) installed. It keeps telling me to install the Chrome addin.

Question 2: Do I still need 1Password 7 on my system? Why does 7 not know that X is installed...

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Macos 10.15.2
Sync Type: Not Provided



  • ag_tommyag_tommy

    Team Member
    edited March 2020


    Touch ID works for 1Password 7, but I see no way to configure it in 1Password X.

    You would use the Touch ID settings in 1Password 7 for Mac, 1Password X uses those settings. Check your settings in 1Password X > Enable Desktop Integration.

    1. For Touch ID to work, yes, you will need to keep the 1Password 7 Mac app installed on your system. It sounds as if you may have the standard/traditional extension installed. Check chrome://extensions and make sure only one 1Password extension is enabled at one time.

    Quit 1Password X, and 1Password for Mac, then start both, if you accidentally had both enabled at the same time.

    Why does 7 not know that X is installed...

    Desktop integration is not enabled and 1Password X was designed for use in the absence of the desktop app in some situations. 1Password for Mac does not communicate with 1Password X unless the desktop integration is enabled.

  • tormodgtormodg
    edited March 2020

    Where is "1Password X > Enable Desktop Integration."

    If you meant the 1Password 7 setting, then it is turned on:

    There was indeed an old version of the extension installed in Chrome. I removed it, added Password X, and Password X works fine in Chrome.

    But it's not working in Edge Chromium. I tried to remove 1PX and reinstall it, but the behaviour is the same - no touch id support.

  • tormodgtormodg
    edited March 2020

    Scratch that. It's not working in Chrome either, not sure why it worked at first.

    I mean 1Password X works like a charm. It's just not supporting touch id on my Mac.

  • ag_tommyag_tommy

    Team Member
    edited March 2020


    You need the beta version of 1Password X, your screenshot shows 1.18, the current beta is 1.18.8 - https://chrome.google.com/webstore/detail/1password-x-beta-–-passwo/khgocmkkpikpnmmkgmdnfckapcdkgfaf?hl=en

    Edit: I am going to move your topic to the 1Password X area for follow up, to help you get the attention of the 1Password X team. If I recall correctly there were some special steps with Edge. They may be able to assist with it.

  • I have a similar problem (let me know if you want me to start a new thread).

    • MBP with latest Catalina
    • 1Password 7 Version 7.4.3 (70403001)
    • 1Password X 1.18.8
    • 1Password 7 running, set up to use TouchID (and works as one would expect)
    • 1Password X checkbox to enable integrations is set to On
    • 1Password X shows a red-bordered box saying that it is unable to establish connection with the desktop app
  • ag_anaag_ana

    Team Member


    I believe you will need the beta version of the 1Password for Mac desktop app too. If you are using 1Password 7.4.3 stable, I don't think Desktop App Integration will work.

    Do you see the same behavior if you update to the 1Password for Mac beta channel?

  • I'm also having a problem with the 1password X beta 1.18.8 integrating with 1password 7.5 Beta. I've uninstalled and reinstalled both apps and restarted chrome. Still no luck.

  • MTriMTri
    edited March 2020

    Installing the Beta desktop app and restarting Chrome sorted this out for me. Thank you! (I suggest making the instructions clearer as they suggest a pretty old minimum desktop app version, leading one to believe that a newer stable version would be adequate).

  • ceceliacecelia

    Team Member

    @mikeylikesrocks I'm sorry to hear that. If you're up for it, I'd love to ask you to collect some console logs from the extension's background page so we can see which, if any, errors are being thrown and go from there. Here are the instructions for collecting those logs: - 1Password Support - Extension console logs -

    @MTri - Excellent! I'm glad that sorted things out. Definitely! Clearer instructions can never hurt. Can you let me know which instructions you're referring to so I can edit them myself or request that it be done by the appropriate party?

  • Turns out I just needed to do a full system reboot. 1password X immediately connected with 1 password app after opening Chrome and touch id now works.

  • ag_anaag_ana

    Team Member


    Thank you for the update! I am glad to hear this :)

  • rudyrudy

    Team Member


    I have updated the line to indicate that 1Password for Mac Beta that is 7.3.BETA-4 or newer is required.

  • Cool, thank you!

  • ag_anaag_ana

    Team Member

    On behalf of rudy, you are welcome @MTri :)

  • So what exactly is the status of this at the moment? I'm running the latest 1Password for Mac non-Beta, so 7.5 and the latest 1Password X beta so 1.20.0 and this still isn't working. 1Password X says

  • rudyrudy

    Team Member


    You must have the beta of both 1Password for Mac and 1Password X. Release versions are not sufficient, this is likely to remain the case for the foreseeable future.

  • Thanks rudy, installing the beta did it!

  • ag_anaag_ana

    Team Member

    Thank you for the update @nigital! I am glad to hear this :)

  • When will the new version allowing for Touch ID be fully released? It's been in beta for more than a year from what I can tell.

  • BenBen AWS Team

    Team Member

    Unknown; sorry @neket01. As soon as it is ready. I understand that isn't an incredibly satisfying answer, but its the best one we've got.


  • I'm confused. I have beta of both 1Password 7 desktop app and the 1Password X extension (in Brave). Touch ID worked fine until some weeks ago and now it doesn't, I always get prompted to enter the master password.

    Is there any procedure I can go through to get this working again?

  • ag_anaag_ana

    Team Member


    Sorry for the confusion. Desktop app integration was temporarily removed from the 1Password X beta. Please see this forum announcement for all the details about this:

    Temporarily removing Desktop App Integration

  • Hello everyone.
    I still can't activate touch ID in 1Password X for Chrome.
    Chrome extension: 1.22.3
    macOS Client: 7.7 (70700016)
    Somebody could help me?

  • ag_yaronag_yaron

    Team Member

    Hey @eucciferri ,

    Touch ID in 1Password X is currently not available yet, as you can see in the link above your message where it says "Temporarily Removing Desktop App Integration".

    We hope to release it again quite soon, so keep your apps up to date and hopefully you'll have Touch ID unlock before long.

  • Thank you very much @ag_yaron!

  • ag_tommyag_tommy

    Team Member

    On behalf of Yaron, you're welcome.

  • I know you guys are working on this. But it would be good to know when we can expect it to be back. Will it be within next 2-3 months? Will it be end of this year? Is there no way you can enable it in the beta?

  • ag_anaag_ana

    Team Member


    We don't have a date to share at the moment I am afraid. We all hope it is going to be very soon though, since many of us were also fans of the integration :)

  • Any update on this?

    BTW, other than the lack of integration, the new extension is great!!

    Thank you!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file