1Password beta desktop integration gets stuck locked

After some time, the 1Password extension gets stuck locked. I'm not sure exactly what triggers it, only that it seems to happen after the browser has been running for a while (hours). Restarting the browser, or even just toggling desktop integration, fixes the issue until it happens again. 1Password Mini works fine (but doesn't seem to recognize the browser). Here's a video of what the issue looks like when it happens. Hope this helps!

Edge v90.0.818.56 (extension installed via the Chrome web store)


1Password Version: 7.8.2.BETA-0
Extension Version: 1.25.6 beta
OS Version: macOS 11.3
Sync Type: 1Password Account

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @Coder256 ,

    Can you please try turning off the integration in the extension's settings, then turn off the auto-lock feature at the top of the settings page? After that, turn integration back on and see if you are able to reproduce the issue.

    In case you encounter the issue again, please grab the extension's log and send it to us via email to [email protected] Here's how to get the log: https://support.1password.com/cs/extension-console-log/

  • Hi,

    Thanks for the response! I tried the workaround for the past few days and I think it might have worked, or at least I haven't noticed the bug since I did it. Since this is so tricky to reproduce, I'm really not sure. Either way, the bug still exists.

    To clarify my original report: the problem isn't per-se that it gets stuck locked. Rather, the extension just completely stops responding as if it were frozen (except there's no beach ball or other sign of being actually frozen). In the settings page (which still works while "frozen"), my 1Password account is unchecked and the checkbox doesn't work. It stays like this even after unlocking the native app, but toggling the "Integrate with 1Password app" fixes it temporarily.

  • ag_yaronag_yaron

    Team Member

    Thanks for the clarification @Coder256 .

    Sounds like something with the integration broke and put the extension in a loop trying to connect to the desktop app without success.
    We have some improvements coming on that front soon, which should disconnect the extension from the desktop app automatically if it times out.

    Thanks again for reporting this! Let us know if it keeps happening after the next update or two.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file