How to change the UI language

Hi, first of all THANK YOU for releasing the Linux version! Very good stuff.
In order to make the experience even better I'd like to address an issue I noticed:

When I go to Settings > Region & Language, my system Language is set to English (US) and Formats are set to Brazil.

I believe since the field Language is set to English then the 1Password native client UI should also be displayed in English (as it works for all the other apps), right?

Thank you in advance.
- M


1Password Version: 8.0.34
Extension Version: Not Provided
OS Version: PopOS 20.10
Sync Type: Not Provided

Comments

  • I'm having the same problem, the solution in my case was to add OP_LOCALE=en_us to the /etc/environment file and login again.

    The original topic where the solution was proposed is here: https://1password.community/discussion/120950/how-to-change-language#latest

  • BlakeBlake

    Team Member
    edited May 18

    Thanks for sharing @leandrojmp 🤝

    Let us know if that works for you @monique_live!

  • Hi, thanks for the feedback guys!

    I assumed that the prefix OP in OP_LOCALE would refer to "One Password", so instead of setting this env var globally I limited its consequences:

    Now it's working correctly, even though I still believe 1Password GUI should get the system's LANGUAGE or LANG env vars in order to choose its UI translation.

    Thanks again, I love the new app!

  • Erik_1PErik_1P

    Team Member

    @moniquelive thank you for your reply. You are correct, the UI language should follow the LANG and LC* and not LOCALE environment variable. An oversight on our part. I've created an issue to have this corrected in a future update.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file