Fields not detected properly in edge(chromium)

kinwolfkinwolf
edited June 8 in 1Password in the Browser

Hi, when I use Edge(chromium version) to access an intranet system, 1password cannot autofill the username/password. But if I use firefox, the autofill works fine. So I suspect the fields are not detected properly in edge. The problem was already there in the v1 extension, before the v2 update, so it's not a new problem with v2.

Is there a way in 1password to debug fields problems like that?


1Password Version: Not Provided
Extension Version: 2.0.1
OS Version: windows 10 1909
Sync Type: Not Provided

Comments

  • argh, I posted this in the wrong channel, if a mod could move it to the browser extension section.. thanks!

  • ag_anaag_ana

    Team Member

    Hi @kinwolf!

    I have moved the discussion to the correct section of the forum :)

    For confirmation, do you use the same version of the 1Password browser extension in Firefox and Edge?

  • Well, it's 2.0.1 in edge and 2.0.2 in firefox, but the problem has been there for a while, I simply didn't have time to come here to ask about it :-P
    Not sure if it makes a difference, but I only use the extensions on my work computer. The main 1password app is not installed on that one.

  • Well, it's 2.0.1 in edge and 2.0.2 in firefox, but the problem has been there for a while, I simply didn't have time to come here to ask about it :-P
    Not sure if it makes a difference, but I only use the extensions on my work computer. The main 1password app is not installed on that one.

  • ag_anaag_ana

    Team Member

    @kinwolf:

    Thank you for the confirmation. Since we don't have access to that website, we can try looking at the page details. Please see these instructions from my colleague Yaron to see how to collect them :+1:

  • It seems to confirm that in edge the fields aren't seen by the extension
    Here is the result taken from edge:

    {   
        "unparsedUrl": "https://<edited>/OA_HTML/AppsLocalLogin.jsp",
        "title": "Authentification pour l'ouverture d'une session",
        "frames": []
    }
    
    

    and here is the same taken from either chrome or firefox

    {
        "unparsedUrl": "https://<edited>/OA_HTML/AppsLocalLogin.jsp",
        "title": "Authentification pour l'ouverture d'une session",
        "frames": [
            {
                "direction": "ltr",
                "fields": [
                    {
                        "formOpid": 0,
                        "htmlId": "usernameField",
                        "htmlName": "usernameField",
                        "htmlClass": "inp",
                        "opid": 0,
                        "type": "text",
                        "label": "Nom d'utilisateur",
                        "labelBefore": "Nom d'utilisateur"
                    },
                    {
                        "formOpid": 0,
                        "htmlId": "passwordField",
                        "htmlName": "passwordField",
                        "htmlClass": "inp",
                        "opid": 1,
                        "type": "password",
                        "label": "Mot de passe",
                        "labelBefore": "Mot de passe"
                    },
                    {
    <rest of the fields sniped for clarity >
        ]
    }
    

    Edge version is 91

  • ag_anaag_ana

    Team Member

    @kinwolf:

    Thank you! I am checking with the team to see if someone else has already seen this before :+1:

  • ag_michaelcag_michaelc

    Team Member

    Hey @kinwolf. That's certainly an interesting case we've got here. :smile: Just to confirm: is this site publicly accessible in any way, or only while on that local network? The easiest thing to debug this is if we could access the URL directly, but if that won't work, an archive of the webpage would also do. To save an archive of the webpage,

    • Go to File > Save Page As…
    • Choose Webpage, Complete for the Format

    Then, create an archive (ZIP) of the resulting folder and .html file and send that our way. Be sure to remove any sensitive information on the page, and do not fill anything on the page before saving.

    In both cases, letting us know the URL or sending the page structure (but especially the latter!) would best be done by email. You can send this directly to the extensions team by writing to [email protected] with a link to this post so we can "connect the dots" on our end. Let me know if you have any questions about this.

  • Hi, I found out why it's not working while trying to send the html page. I was trying to save the webpage in edge, but there was no save option! On any other tabs, I could save the webpage, but not that one. In chrome or firefox, , no problem to save that url page either. So I digged to see what was going on, and... our organization, in it's infinite wisdom, configured a GPO to tell edge to load that url in Internet Explorer mode. That's how I discovered Microsoft still has that dreaded mode, even in the chromium version of edge... That's probably why the extension is not seeing anything. I cannot even turn it off in edge since they disabled that option(old, unrelevant GPO that still get applied ). I will contact our GPO team to ask them to turn it off for that website.

    So, case closed, it's not 1password :)

  • ag_chantelleag_chantelle

    Team Member

    Thanks for following up @kinwolf! We're glad to hear you were able to get to the bottom of things. If you have any other issues, feel free to reach back out and we'll get right on it! ;)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file