Mac Chrome presents 2 login windows and lags

mcdonnp1mcdonnp1
edited July 14 in 1Password in the Browser

Hi,

Here's the process when I try use the Chrome extension since updating to the latest version.
1. Cmd+shift+x opens both dialogues below
2. I enter my password into the one on the left which brings me back to the loading on on the right
3. After 10+ seconds it logs in for a split second then closes
4. When I hit the browser extension again I sign in and it loads for another 10+ seconds
5. Every time I try the process again I'm back to the start

I've since downloaded the latest beta and still getting the same issue.

Any advice?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: OS X 11.2.3
Sync Type: Not Provided

Comments

  • ag_chantelleag_chantelle

    Team Member

    Hey @mcdonnp1

    First, let's check that integration is properly enabled:

    1. Right click the 1Password icon in your browser toolbar and choose Settings.
    2. Under General, toggle "Integrate with 1Password app" off and on again.

    We'll then want to make sure we fully quit and relaunch both 1Password and your browser:

    1. Quit 1Password completely by holding down the Control and Option keys on your keyboard and choose 1Password > Quit 1Password Completely from the menu bar beside the  logo.
    2. Quit your browser.
    3. Open and unlock 1Password.
    4. Open your browser and test again to see if the issue is resolved.

    Let me know how it goes.

  • Thanks for the response @ag_chantelle , still having the same issues unfortunately. Fully quit both programs after following your steps.

  • Actually, I removed the extension after and reinstalled and it looks like for now it might be working as expected

  • ag_chantelleag_chantelle

    Team Member

    @mcdonnp1

    Great! I'm glad to hear things are working for you now. :)

  • @ag_chantelle looks like I spoke to soon, issue is immediate reoccurring.
    Version 2.0.4 on Chrome 91.0.4472.114

  • ag_chantelleag_chantelle

    Team Member

    @mcdonnp1

    Can you try the beta version of 1Password for your browser and let me know if it helps? Use 1Password beta releases

    If it's still not working, I'd like to ask you to create some reports from your Mac:

    Console log from your browser: https://support.1password.com/cs/extension-console-log/
    Diagnostics report from 1Password for Mac: https://support.1password.com/diagnostics/

    Send the reports to us at [email protected] with and include a link to our current discussion. Someone from our team will take a look and let you know what we find.

  • JoeDoomJoeDoom
    edited July 19

    I'm also having these issues with the browser extension on Mac OS 10.14.6 running the latest Chrome Beta (92.0.4515.107), 1Password Beta (7.8.7.BETA-0 (70807000)), and 1Password in the browser (2.0.5).

    The browser pop up sometimes just hangs and spins, then sometimes two login windows come up and after logging into both, 1Password in the browser immediately goes back to locked. In its current state, it's completely unusable. I've reinstalled and relaunched 1Password in the browser and the standalone 1Password app.

    The stand alone apps works perfectly though.

  • ag_yaronag_yaron

    Team Member

    Hey @JoeDoom ,
    I'd like you to try the following:

    1. Open and unlock the 1Password 7 desktop app.
    2. Click the "1Password" menu on the top left next to the Apple logo and select "Preferences".
    3. In the preferences window that pops up, Select the "Browsers" tab and enable the "Always keep 1Password extension helper running" option.
    4. Test and see if the issue persists now.

    The extension helper is a background service that is needed to keep a live connection between the desktop app and the extension even when the desktop app is closed. If it is disabled, the extension will first have to launch the desktop app and wait for it to launch the extension helper which might get you into that loop.

    Let us know if that was it.

  • Thank you, that totally seems to have fixed it! I wonder why it only started being an issue recently when I don't think that box was checked before and everything was running fine?

    Either way, thanks again!

  • ag_yaronag_yaron

    Team Member

    Glad to hear that helped :)

    We've recently added a feature to the extension in which it will connect to the desktop app and work with it, but it can only work with the desktop app if the extension helper is running in the background. :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file