Can't connect the app with the browser extension in ubuntu

AudunSvanteAudunSvante
Community Member

Ubuntu 22.04 LTS. 1Password for Linux 8.9.4. Have two browsers installed: Firefox and Vivaldi. The problem occurs in both browsers, they do not connect to the desktop app. I need to insert the password every d...ed time I open the browser even when the desktop app is logged on and open. Small problem, Big Nag! This is with both browsers


1Password Version: 8.9.4.
Extension Version: 2.4.6.
OS Version: Ubuntu 22.04 LTS
Browser:_ Vivaldi 5.4.2753.51-1
Referrer: forum-search:app connection ubuntu

Comments

  • AliH1PAliH1P

    Team Member

    Hey @AudunSvante, thanks for reaching out. I believe there may be two different issues at play here.

    Firefox:

    Is your Firefox browser the on that's installed by default in Ubuntu 22.04? If that's the case, this default installation is packaged using Snap which sandboxes Firefox and would prevent any browser extensions (like ours) from communicating out to a desktop app like 1Password for Linux. If you're using the default Firefox installation, it would explain the issue you're experiencing.

    Vivaldi:

    First, I should let you know that Vivaldi isn't one of the browsers for which we officially support browser integration - but you're not out of options. There is still a way to set this up. Here's what to do:

    1. Ensure that browser integration is enabled from Settings → Browser.
    2. Close 1Password completely.
    3. Open a terminal, and run sudo mkdir /etc/1password (if you've done this already, you can skip it).
    4. Run cd /etc/1password.
    5. Run sudo gedit custom_allowed_browsers.
    6. Paste in the appropriate browser code - in this case vivaldi-bin. (ie the binary name)
    7. Save the file.
    8. In the terminal, run sudo chown root:root /etc/1password/custom_allowed_browsers && sudo chmod 755 /etc/1password/custom_allowed_browsers
    9. Run 1Password - it will read the new config file and make the appropriate connections.
    10. Launch your browser!

    Let me know if this helps!

    Ali

  • AudunSvanteAudunSvante
    Community Member

    Hi Ali o/ Thank you for helping. I ran the commands in terminal but after the "sudo gedit custom_allowed_browsers" where i got a new window, inserted "vivaldi-5.5.2805.35", saved and came back to terminal shock full of warnings. I took a screenshot and attached to this message. The language is norwegian but i think you get the meaning.

    In afterthought, maybe i should have used the puctuation marks ( . ) when entering letters and symbols in terminal?

  • FrankyO1PFrankyO1P

    Team Member

    Hi @AudunSvante,

    Thank you for the reply with the screenshot.

    When you run the command sudo gedit custom_allowed_browsers do you see a text editor window pop-up? If so the warnings are to be expected. When you open apps as sudo in the terminal it will show the silent warnings users won't usually see.

    If you see the editor feel free to continue the steps and let me know how things go.

  • AudunSvanteAudunSvante
    Community Member

    Hello o/, And Yes, I did get a text editor window pop-up, but very difficult read to what you type into it. . I saved and continued the final command in terminal. Opened 1Password app in ubuntu, opened vivaldi but still had to log on to 1Password in browser. Sorry.
    -When that's been said; Can this problem be related to XDG-open? Let me explain: The first time i installed 1Password in ubuntu i tried to verify using vivaldi and log in to 1Password online, then the XDG-open thing, "1Password wants to use XDG-open" and by clicking open (excuse: i am not very much into computers) this put me into a loop. Everytime i entered my mail address in the login field it just opened a new login window - how ever much i tried. By clicking "cancel" nothing happened. This scared me a bit, it being about my personal password vault. Ended up verifying using my phone.
    Maybe it is related or maybe i should have mentioned that last bit as another request?

  • FrankyO1PFrankyO1P

    Team Member
    edited October 24

    Hi @AudunSvante,

    Thanks for the reply with the screenshot, I am sorry for the confusion with gedit.

    If you hit Enter at the end of the line you should be able to see the text. Make sure you are writing vivaldi-bin specifically.

    Here is a screencap of what it will look like:

    image

    Once you have that saved in the /etc/1password folder feel free to continue the steps and let me know how things go.

  • AudunSvanteAudunSvante
    Community Member
    edited October 13

    Hello o/. I Sorry that i have report the situation to be the same, even after following the steps i still have to log in to 1Password everytime i open the vivaldi browser.
    Brgds

  • FrankyO1PFrankyO1P

    Team Member

    Hi @AudunSvante,

    To investigate further, I'd like to ask you to create a diagnostics report from your Linux PC:

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    We'll look forward to hearing from you.

  • AudunSvanteAudunSvante
    Community Member

    OK,
    I just want to write this in case someone else has a similar problem:
    The answer given by AliH1P at the beginning of this string is the right solution.
    If it haven't been for me making a mess of it writing typos in the text editor window.
    The team has gone the extra mile to help me solve this and i humbly apologize for the extra work i have caused.
    The 1Password extension now communicates with the 1Password app in Ubuntu 22.04 when i open Vivaldi.

  • AliH1PAliH1P

    Team Member

    Hey @AudunSvante, I'm glad to hear the provided steps ended up working for you! We all make typos so it's completely understandable and we're always happy to help 😄

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file