1Password Mac, unlock with Apple Watch inconsistent

buckZor
buckZor
Community Member
edited May 2023 in Apple Watch

System: Macbook Pro 14-inch, 2023 (Apple M2 Max)
MacOS: Ventura 13.3.1 (a)
1Password v8.10.7 latest beta build

My Apple Watch (series 7) consistently unlocks my macbook, but pretty consistently does NOT unlock my 1Password. I work with the macbook lid closed using a Caldigit dock, external keyboard/mouse/display. My morning routine is to wake my mac (either from display sleep or system sleep, I've been rotating), then I have to open my macbook lid, then click the thumbprint logo use touchid to unlock 1Password. Then I close the lid of my macbook and THIS TIME, I'll get the apple watch unlock and go about my day. I've turned to Amphetamine to prevent my system from locking throughout the workday because I have to go through this annoying routine again. I'd PREFER not to run this way, my Watch should always unlock my macbook, that is what I want, that is what I pay for. My watch unlock was very consistent with 1Pass 7 and my previous macbook.

Please help me.


1Password Version: 8.10.7 81007011 BETA channel
Extension Version: n/a
OS Version: Ventura 13.3.1 (a)
Browser:_ n/a
Referrer: forum-search:apple watch

Comments

  • Hello @buckZor! 👋

    I'm sorry that Apple Watch unlock is sometimes not working to unlock 1Password on your Mac. The behaviour that you described sounds similar to an issue that our developers have identified with macOS and reported to Apple. The next time that you're unable to unlock 1Password using your Apple Watch can you try the following troubleshooting test so that we can narrow down the problem:

    1. Click on the  in the menu bar.
    2. Click System Settings.
    3. Click Privacy & Security.
    4. Click Advanced.
    5. As a temporary troubleshooting step, turn on "Log out automatically after inactivity".
    6. You'll now see a macOS system prompt asking you to confirm the action. You should receive a double-tap notification on your Apple Watch.

    Are you able to use the Apple Watch to authenticate the macOS system prompt? Once this test is complete you can turn off "Log out automatically after inactivity" if you wish.

    I look forward to hearing from you. 🙂

    -Dave

    ref: dev/core/core#18393

  • buckZor
    buckZor
    Community Member

    Yep. I received the tap on my watch to approve the "Log out automatically after inactivity" enable. Approved it through the watch and then disabled it again because that would be awful. As I described, this is not a sometimes not working. It's consistently not working. Every morning I have to open the stupid lid of my macbook and then the arrow of the password field reveals the thumbprint, then I click the thumbprint, unlock with Touch ID, close the macbook lid, which locks my stupid mac again, and my watch again unlocks it on mouse movement and this time the watch icon appears next to the password field, so I can click it and unlock with the watch and on about my day I go. I've been doing this routine for months and I'm OVER IT. Little things like this slowly kill your soul.

  • @buckZor

    Thank you for the reply and I'm sorry for the delay in responding. The test confirms that Apple Watch unlock is working with macOS system prompts and so we'll need to dig deeper to see what might be going wrong with 1Password. Before we do so can you try the following steps:

    1. Disable Apple Watch Unlock in 1Password for Mac (1Password > Settings > Security > Uncheck "Apple Watch"). (If you don’t see the Apple Watch option in 1Password then skip this step.)
    2. Disable Apple Watch Unlock for your Mac (In the MacOS menu bar:  > System Settings > Touch ID & Password > Uncheck your Apple Watch under "Use your Apple Watch to unlock your applications and your Mac")
    3. Turn off your Mac.
    4. Restart your Apple Watch: Restart your Apple Watch - Apple Support
    5. Turn on your Mac.
    6. Enable Apple Watch Unlock for your Mac (In the MacOS menu bar:  > System Settings > Touch ID & Password > Check your Apple Watch under "Use your Apple Watch to unlock your applications and your Mac")
    7. Enable Apple Watch Unlock in 1Password for Mac (1Password > Settings > Security > Check "Apple Watch").

    If that still doesn't resolve the issue then let me know and I can help further.

    -Dave

  • buckZor
    buckZor
    Community Member

    Ok, I've performed the requested steps and the first time I tried to unlock 1Password I had to unlock with Password (before unlocking with Apple watch) which was fine, so I unlocked both of my accounts. I locked my Mac by active corner screensaver, waited 5 seconds. Then woke the mac, my watch unlocked the mac automatically and I did receive the 1Password apple watch prompt and was able to unlock. I tried again and the watch unlock was gone. I had to do the Force Quit trick on 1Password, and then I got the watch prompt to unlock. I'll see over the next few days if this has made a difference, but I am doubtful that it has.

  • @buckZor

    If, or when, the issue occurs again I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    The report will be in zip format. Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    -Dave

  • buckZor
    buckZor
    Community Member

    This has been done.

  • @buckZor

    Thank you for sending in the diagnostics report. I've moved the ticket to the right team and one of my colleagues will send you a reply as soon as they've finished reviewing the report. Since we now have a communication channel open over email I'm closing this thread.

    -Dave

    ref: SDQ-57358-748

This discussion has been closed.