1Password for Safari isn't working reliably on macOS Sonoma

Community Member
edited October 5 in 1Password in the Browser

I have been a 1Password user for more years than I can count. I use 1Password personally and for business, Mac and Windows. Updated to Sonoma and 1Password is not working well, if at all, many times. 1Password for Safari-non-existent. The software used to be ready for updates ahead of time or immediately afterwards but not so much lately. I pay a rather large monthly fee and am considering looking elsewhere. Anyone have a recommendation for alternative managers?

1Password Version: 8.10.16
Extension Version: 2.15.1
OS Version: 14.0
Browser: Safari


  • @jheath

    Please describe your issue and we'll try to be of assistance.

  • jheath
    Community Member

    The primary issue has occurred after updating to Sonoma on multiple computers. The Safari extension Autofill has not worked reliably and now doesn't work at all. I have Uninstalled and Re-Installed. It works somewhat for a little while then doesn't work at all.

  • @jheath

    Can you confirm if the built-in password manager of Safari is enabled? It might happen with the upgrade to Sonoma and it would interfere with 1Password in Safari. Here're the steps:

    1. Open Safari and click Safari in the menu bar
    2. Choose Settings.
    3. Click the AutoFill icon.
    4. Turn off all the AutoFill web forms settings.

    Let me know if that helps.

    -- Kevin

  • jheath
    Community Member

    All off. Already checked that.

  • Hey @jheath,

    I'm sorry to hear about the trouble. Just to confirm, what exact steps are you taking when using 1Password to Autofill? Do you have any issues clicking the 1Password icon in Safari's toolbar and then clicking the "Autofill" button? Does your Login items not appear as suggestions to Autofill below a username/email/password field?

    Looking forward to hearing back.


  • jheath
    Community Member

    It will Autofill from the icon but no Suggestions

  • pbrody
    Community Member

    I have followed these directions, it made no difference. Any other trouble-shooting tips?

  • jaws56
    Community Member
    edited November 1

    **Okay--nevermind! It just now started working again, (although I hadn't done anything between the time of my post and just trying to log into the website I'd been using to test on again)--and this time it worked on that website, as well as a few others I just tried. Who knows why?

    I am having the same problem. Based on suggestions from a different post, I cleared my complete Safari history, uninstalled and then reinstalled the extension, and although this time the extension did finally unlock, no log-in or password suggestions appear on any website. It also won't "auto-fill" on any website. This all started after my recent update to the public beta of macOS 14.2

  • elDub
    Community Member

    I'm not trying to "pile onto" things, but I do have to say that 1Password within Safari on macOS Sonoma has been a terrible experience for the past month or so. (I'm also a 1Password for Business user.) I wish I could produce repeatable examples, but even that is challenging.

    • The in-form icon is very erratic as to whether it shows up, and if it does it frequently doesn't respond to clicks.
    • The toolbar trigger usually works, but even that sometimes requires me to restart Safari.

    I'd love to provide my computer and time to 1Password to share what is happening if that could help.

  • Bryan Hoffman
    Bryan Hoffman
    Community Member

    Chiming in with similar issues, also not to pile on, but to make sure AB knows this is still an issue for some of us.

    As others have said, it's been hard to nail down repeatable issues, but here's a screen recording showing one of the issues I've been having: https://share.zight.com/7KuXodKK

    I also periodically have the same issues with other browsers...

  • e2ct3z
    Community Member

    I'll add my voice to the mix. 1Password is completely useless with Safari since I upgraded to MacOS Sonoma. I've tried all the recommendations, to no effect. I hope there will be a fix soon.

  • stainy
    Community Member

    Same here, annoying random issues for the past month. Can't believe this hasn't been addressed so forgive me if I don't apologize for piling on.

    At least once a day one or all of these:

    1. Icon doesn't show up user/pwd fields.
    2. Nothing happens clicking on the icon in user/pwd fields.
    3. Clicking the toolbar button shows the website details, but autofill will not work.
    4. Clicking the toolbar button gives an error message saying 1Password needs to be reloaded and after doing that still have problems 2 and 3.

    Only way to fix it is to restart Safari. I've tried enabling/disabling the extension, re-installing the extension, and the problems always come back.

    1Password for Mac 8.10.18 (81018040)
    1Password for Safari 2.16.0
    Safari 17.0 (19616.

  • barrybrad
    Community Member

    Hi, I'm having the same problems. It's to the point that I changed my default browser to Edge, which filled in the passwords from 1Password. But I prefer Safari over edge. I hope this gets rectified soon.

  • djurgensen
    Community Member

    I think I'm having the same problem. When I open up a web page in Safari, the only password help is from iCloud keychain, no option to get passwords from 1Password. I do see the icon for 1Password in the Safari, but it's locked and clicking it just gives a blank browser page. However if I open the page that I want to log into with Firefox, then it's able to provide the username and password as it should. Is there any workaround for Safari?

  • pauljmartinez
    Community Member

    Similar issue for me. Post-upgrade to Sonoma, 1Password will only autofill if I use the toolbar icon. Clicking the 1Password icon in form fields does not work.

    • I've uninstalled/reinstalled the '1Password for Safari.app'
    • I've confirmed that all of my auto autofill settings are off
    • I've done a clean restart

    Any help would be greatly appreciated!

  • Chaosphere
    Community Member

    1Password in Safari with Sonoma is a disaster. As noted by so many users, the extension doesn't work despite having tried all the recommendations above. We're now forced to use alternative browsers, which is not a viable option for Apple users.

    How is 1P getting the Sonoma Safari support so wrong and when will it be fixed for good?

    The problem has been ongoing for months. 1P is an expensive service and we have a fair expectation that problems should be resolved quickly.

  • kzolnowski
    Community Member


    I have exactly same symptoms as @stainy It's very annoying.

  • frankly
    Community Member

    I am so tired of seeing posts like this and then having people from 1Password ask the users to do a bunch of work for them providing examples, screen recordings, log files, etc. There is NO WAY that these issues wouldn't show up in testing in QA at 1Password if they had comprehensive QA going on. The app shortcuts and autofills just worked for so many years that it is agregious how bad the app behaves these days. I put up with it because I really need the secure storage of my password information. The UI/UX is so bad in some cases that I have to resort to simply copying and pasting the data from the app to my browser.

  • elDub
    Community Member

    I received this reply from the 1P support department:

    Thanks for testing those for us. I've just checked with our development team and learned that a recent change in Safari now limits a feature 1Password previously used to enable functionality like filtering the inline form autofill menu. We've raised this concern with Apple, and our team is looking into other ways we may be able to resolve this. I don't currently have any indications of if or when this may be resolved, so for the time being, your best option will be to rely on the 1Password icon in the Safari toolbar when visiting a site with many logins that need to be filtered, or you can consider using a different web browser.

    This made sense to me when I originally received it as I would expect Apple to make changes that protect privacy and such. However, my coworker is having no such problems using 1Password 7 and version 7.9.11 of the Safari extension. This would mean that the feature is possible, but version 8 and its associated extension is either doing something wrong or has explicitly chosen to implement the feature using tools that don't work as well. Without an explanation of why the new approach is more desirable or offers some other benefit I hope they might reconsider and just make the feature work.