1password shows on Safari in the field but doesn't work. It does work on Google Chrome

Options
jnoiva
jnoiva
Community Member

I use Safari from Sonoma 14.5, and the ID and password field show the 1password icon but it won't autofill. I try the same website on Google Chrome, and the autofill for 1password works fine. Does anyone know what could be wrong? Safari Setting or a 1 password setting? Thanks


1Password Version: 8.10.33
Extension Version: 2.24.2
OS Version: 14.5
Browser: Safari

Comments

  • david.m_1P
    Options

    Hi @jnoiva, thanks for reaching out!

    I'm sorry that you're experiencing trouble when attempting to autofill with 1Password for Safari. Can you elaborate on what you're seeing when trying to autofill in Safari? For instance, is the Login item suggested but unresponsive once clicked, or are you only seeing the 1Password icon appear in the field? Are you using Safari profiles?

    Additionally, can you let me know what happens when you click on the 1Password icon in your Safari browser's toolbar? Is there a notable delay or any error messages? If your items are accessible here, does clicking the "Autofill" button work?

    I look forward to hearing from you!

    -David

  • jnoiva
    jnoiva
    Community Member
    Options

    Hi David,

    I go to the sign in screen on say, Chewy.com, and at the Email Address or Password fields the 1password icon shows in the right hand side of the field, I click it to have the 1password app authentication show up and then autofill the fields, but nothing happens. It just has a bubble that says unlock 1password. But the same page in Google works fine.

    I am not using Safari profiles.

    In the Safari toolbar, I click the 1password icon and kind of the same action or inaction happens, it expands to say open 1password, but clicking it does nothing.

    I am not sure if it happened after one of the recent Mac OS updates or not, I am thinking they may have changed a safari default to some new setting that I am unaware of.

    Thanks,
    Jeff

  • ag_tommy
    Options

    Hey @jnoiva

    It sounds like your describing what occurs during an update of 1Password or an update of 1Password in the browser. During an update, the communication between the browser extensions and the app is severed by macOS. The following steps will restart that connection.

    Can you try the following?

    1. Look for our helper in the menu bar near the WiFi indicator and the clock. Right-click (Option-click or Control-click) on the helper and select Quit.
    2. Fully quit your browser. There should be no light on underneath the Dock icon.
    3. Wait a few seconds and then open 1Password from the Dock or the Applications folder and unlock.
    4. Open your browser.
    5. Check for proper operation.
  • jnoiva
    jnoiva
    Community Member
    Options

    Hi David,

    That fixed it, Thank you so much for your help!

    Thanks again,
    Jeff

  • ag_tommy
    Options

    You're most welcome. Have a great weekend.

  • rcostain
    rcostain
    Community Member
    Options

    I experience the same issue quite regularly. Following

  • ag_tommy
    Options

    @rcostain

    Did the steps above help your resolve the situation you encountered?

  • rcostain
    rcostain
    Community Member
    Options

    @ag_tommy It turns out I had to disable Profiles in Safari. So far, that has resolved the issue, but it's not entirely satisfactory since I am now unable to use the Profiles feature.

  • ag_tommy
    edited June 12
    Options

    @rcostain

    My colleagues on the extension team are working with a couple of issue around profiles. I'll get your report added to the list. Thanks for letting me know I appreciate it.

    ref: dev/core/core#24280