Autofill for my Bank won't work anymore; manual save doesn't fix

Options
denbarth
denbarth
Community Member

I've had trouble with my bank login before; the drop down login menu on the home page won't work with 1Password, but there's another login page that would work. But now it won't. This is true no matter what browser I use. 1Password fills in the user name and password, but when submitting it, the site returns an error saying one needs to enter a password in the password field! I tried manually saving a new login. No change.

I notice that the box around the password field is grayed out after 1 Password fills it in and before submitting the login. (I have a screen shot of that but don't know how to submit it in the forum.) The only work around is to manually copy the password from 1 Password and paste it into the password field. Then it works.

Here's the website: https://securekitsap2.onlineaccess1.com/kitsap1/Authentication/Login.aspx

Any idea what is going on? I suspect there is some attribute the website is using that is weird.

Comments

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @denbarth‌

    Banks are always a pain because we can't just create a test account to see what you're seeing.

    There is something I'd like you to try for me please based on the limited experimenting I could do.

    What happens if you create a basic Login item from within 1Password using that URL. So it would be a Login item with no web form details saved, does that behave any better for you? I think it might but it's really hard for me to test submission of my utterly fake login details :wink:

  • denbarth
    denbarth
    Community Member
    Options

    That worked! I created a new login with that URL, typed in my id and password, and enabled submit always. I have no idea why, but I'm grateful for your suggestion!

  • arnabdas
    arnabdas
    Community Member
    Options

    I'm having the same issue. The username and password for my bank won't be filled by 1Password because the bank requires you to either use a virtual keyboard or manually type the password. Now this problem doesn't happen when I'm using 1Password on the iPad or iPhone. Just an issue with 1Password on the Mac.

    _System Details:
    _
    1Password
    Version 5.0.2 (502006)
    Mac App Store

    OSX Yosemite 10.10.1

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @denbarth‌ I'm glad to hear it's working for you again :smile:

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    @arnabdas‌

    Is it possible that you're being sent to a mobile version of the site on your iOS devices? Given the differences in the platforms maybe they aren't making you jump through as many hoops on your portable devices in contrast to on your Mac.

    It's just a thought.

    If you're willing to supply the URLs somebody can take a look, see if there is anything that can be done.

  • arnabdas
    arnabdas
    Community Member
    edited December 2014
    Options

    @littlebobbytables‌ that would be great. The URL is : axisbank.co.in

    Also, I'm not using the mobile version of the website on my mobile devices. They have just one website and it's desktop only.

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Can you verify that URL for me please @arnabdas‌ I'm getting an "Unknown host" error.

  • arnabdas
    arnabdas
    Community Member
    Options

    @littlebobbytables that's the one. You can alternatively visit this link and click on "Continue to Login". It will lead you to the same page. http://www.axisbank.com/pre-login/internetbanking_prelogin.aspx

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @arnabdas‌

    On 1Password for Mac can you try the following for me please.

    Edit the Login item for your bank and click on the show web form details button.

    I believe you will see four entries

    • CorporateSignonCorpId
    • CorporateSignonPassword
    • EnableVirtualKeyboard
    • mylist

    Delete the EnableVirtualKeyboard and mylist entries. I believe that will sort out your issue. Please do post back here if it doesn't (although if it does it would be nice to know we've resolved your issue too :smile:)

  • arnabdas
    arnabdas
    Community Member
    Options

    @littlebobbytables‌ you're awesome! :) That does work!

    I couldn't find a "my list" option but I deleted the Enable Virtual Keyboard. And that seems to have done the trick.

    Weird thing is, the username and password does get autofilled but I have to hit "Submit" to log in. Unlike other sites where the I'm automatically logged in once I use 1Password to fill up the login details. This isn't an issue, but I wondered if it can be fixed.

  • Hi @arnabdas‌,

    The auto-submit in 1Password works by faking that the user hit the "Return" key on their keyboard. It looks like their website is handling the return keystroke but not actually submitting the form. Unfortunately I don't think there's more that we can do from our end.

    Rick

  • arnabdas
    arnabdas
    Community Member
    Options

    @rickfillion‌ even then, this is much better now. At least I can use my bank's website now. Thanks a lot for the help.

  • @arnabdas no problem. Let us know if there's anything else we can lend a hand with.

This discussion has been closed.