1P Not filling in non-username/password fields

Options
rtgibbons
rtgibbons
Community Member

Example site: https://my.rackspace.com

Safari 8.0.2
1P 5.1.BETA-15 (510015)
1P Extension 4.2.5.b2

I have moved to the non-beta versions of both and see the same behavior.

It fills in my username and password, then i have to go back to the login, click other web form details and copy the account number out to paste it in. It has been broken for a while, and I'm not sure when it actually broke.

Comments

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    edited December 2014
    Options

    Hi @rtgibbons‌

    I think if you create a new Login item using the Saving a Login Manually guide that should sort you out. I don't have a MyRackspace account to fully test it but I can get all three fields to populate that way. You'll want to go and edit the Login item afterwards though and add your account number as a custom field. The information is stored in the web form details but for something more visible a custom field as well is probably a good idea.

    Let us know how you get along.

    As for why it stopped working, they may have subtly changed the site, tweaked a field ID or something and then it causes us problems.

  • chrissnell
    chrissnell
    Community Member
    Options

    I came here today to report this very same problem on the very same website. My account number used to fill properly for this site but no longer fills. I guess it's been broken for about three weeks. I verified that the field ID in questions hasn't changed. Super annoying because I log into this portal many times a day.

  • rtgibbons
    rtgibbons
    Community Member
    Options

    @littlebobbytables‌ I did try that before and it didn't work. I tried it again though to see if something might of changed and that did work. So while that is a work around; I have a lot of forms that use this, and I really don't want to go in and manage all these duplicates. Is there any way to prevent this?

  • rtgibbons
    rtgibbons
    Community Member
    Options

    FWIW, I didn't create a "New Login" last time; when the save prompt came up; I tried updating the existing login already there.

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @rtgibbons‌

    If you still have the old broken Login you could compare the web form details for the two Logins, see if they differ at all. If a field ID/name has changed then the website must have altered the page at some point. If that's the case then your two options would be to manually edit each one and alter the field name in the web form details or create a new Login and remove the old one.

    If the page has changed then there isn't anything you can do to prevent it, you just have to roll with the punches I'm afraid. Thankfully it isn't too likely they a site will change a login page too often.

    Let us know if that is the case.

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    @chrissnell‌

    Did you create a new Login using the Saving a Login Manually guide as I suggested in post #2? As I was just saying to rtgibbons, if the login page changed at some point in the past what we've recorded at the time of the Login creation wouldn't work any more.

  • rtgibbons
    rtgibbons
    Community Member
    Options

    @littlebobbytables‌ FWIW, the latest 4.3 beta for the Safari plugin still doesn't work; but this time instead of leaving the account number blank. It fill in my username in both fields.

    I've compared the field names with the Web Form Details and they haven't changed and still match. When comparing the New Manually created on vs the existing I see no different inside 1Password.

  • chrissnell
    chrissnell
    Community Member
    Options

    So creating a login manually "fixed" it but I still feel like this is a regression in 1P. Here's one thing I noticed: when you click on "Show web form details", the field names and contents between the working and non-working (older) login are identical. The only thing I noticed that was the older login used the account number as the username in the username/password fields at the top part of the 1P Mini window (right above the strength meter). I don't know what's up with this. It worked before and I've verified that nothing has changed with the my.rackspace.com page.

    I've also noticed this same behavior on a couple of other websites but can't recall which ones. If I run into it again, I will post up. I would still appreciate 1P investigating this.

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @chrissnell‌ & @rtgibbons‌

    This is a screenshot of my test item.

    It works with both the stable and beta extension and fills in all three fields as it should.

    @rtgibbons‌ I would expect yours to differ from mine if it's filling in the username in two fields, specifically in the web form details section.

    @chrissnell‌ I can't explain why your old Login item is using an account number for the username. Investigating issues like this are remarkably hard without being able to view everything as it was at the time of creation. It might be they've tweaked the underlying code or corrected an error in a naming convention and that's just two possibilities that spring to mind. To better understand we'd need the source page for then and now so we could compare - tough to do.

    If you find other sites and a simple Saving a Login Manually doesn't work please do post here in the forums. Again, discovering why it no longer works may be hard to tell but we will help as much as we can to create a Login item that does.

  • rtgibbons
    rtgibbons
    Community Member
    Options

    Hey @littlebobbytables thanks again for the updates. Just wanted to let know more of what I see. I'm now on 4.3.0b4 extension and 5.1.BETA-25

    The old entries for rackspace now don't fill in anything. The new ones work perfectly. Both of the entries look identical to the screenshot you posted. I'm keeping the old ones around to test with; so if you have any questions or I can help with anything else please let me know.

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @rtgibbons‌

    If you're using both the 1Password for Mac beta and the extension beta you may notice a lot of changes going on as I think the extension has been seeing some attention. Keep an eye on the beta forums too!

  • rtgibbons
    rtgibbons
    Community Member
    Options

    Yeah; I tried switching to it to see how it was working. I've seen several remarks to changes in the changelog. Originally; I did try moving to the non-beta's and the issue was still there. Moving back to the beta's, I've noticed the new entries that were manually created have worked consistently; But the old ones are working differently across releases.

  • rtgibbons
    rtgibbons
    Community Member
    Options

    FYI, I've submitted an issue via the extension. I found a post saying this was now included. Thanks again for the help!

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Glad we could help :smile:

This discussion has been closed.