1Password not opening anything in "Open and Fill" link. Not even opening a browser.

Options
Jared99
Jared99
Community Member

1Password is not doing anything when I click on the website open and fill link. Not even opening a browser. Tried several logins that were working.


1Password Version: 7.0.7
Extension Version: Not Provided
OS Version: 10.13
Sync Type: Not Provided
Referrer: forum-search:1Password not opening anything in "Open and Fill" link. Not even opening a browser.

Comments

  • rebg
    rebg
    Community Member
    Options

    It seems like others are having an issue like this. Mine might be related? I have a 1password license and been trying to use open-and-fill with 1password 7 on a MacBook Pro (after syncing from 1password 6 on my home/MacBook Air), but when I try to open-and-fill, I get a popup asking me to either subscribe/sign in or providing me the option of a license. I already have the license, though, and as mentioned, have synced (seemingly successfully) with 1password on my home computer.

    In short, although I am able to manually select and copy-and-paste username and passwords from the 1password 7 database on my MacBook Air, open-and-fill won't work, and instead prompts me to get a subscription or license. Maybe I'm missing something simple?

  • rudy
    Options

    @rebg,

    It sounds like you haven't purchased a license for 1Password 7, the license from 1Password 6 isn't valid for 7.

  • rudy
    Options

    @jared99,

    do you have something sane set as your default Browser in System Preferences -> General?

  • Jared99
    Jared99
    Community Member
    Options

    I am not seeing anything to set default Browser in System Preferences

    I have an annual subscription so wouldn't I have the latest version? I just recently moved from one hard drive to another using Migration Assistant. After the move the 1Password icon in the dock opened something like 1Password 3. I went to the folder where I keep 1Password downloads and there was a 1Password 7 app. Just dragged that to the dock and it opened with the current password I've been using. Click on a link however and it doesn't open anything. Have tried several that should be working and same thing.

  • Stephen_C
    Stephen_C
    Community Member
    Options

    @Jared99 have you installed the relevant extension for the browser(s) you are using? If not, in 1Password 7 go to 1Password 7 > Install Browser Extensions.... 1Password will not work to fill logins if you do not have the relevant browser extension installed.

    Stephen

  • Jared99
    Jared99
    Community Member
    edited July 2018
    Options

    Yes Browser extensions are installed. Have done that a couple times and just did again. Same results.

    ref: IHP-67618-685

  • JadC
    JadC
    1Password Alumni
    Options

    Hi @Jared99, in the System Preferences > General, you should see a browser set under the "Default browser" section like this:

    If you do not have one set, this is the most likely culprit. Try selecting the dropdown menu and selecting your preferred default browser.

    Secondly, did you install 1Password 7 from the app store or from our website?

  • Jared99
    Jared99
    Community Member
    Options

    In System Preferences > General I don't see any browser selection.

    I believe from your website. I have been using 1Password for a while and changed over to a subscription a little while back. Use it on Mac Pro and iPhone. It was working fine on the Mac Pro until I put in a new hard drive and used Migration Assistant.

  • Ben
    Options

    @Jared99

    Sorry for the confusion. You’re looking at 1Password > Preferences > General, not  > System Preferences > General. The option to set a default browser is part of the macOS operating system, not 1Password.

    Ben

  • Jared99
    Jared99
    Community Member
    Options

    OK - just looked in the right spot and Firefox is set as default.
    Tried quitting Firefox then clicking on a link in 1Password. It opened a browser window but only to the default home page - Google in my case

  • Lars
    Lars
    1Password Alumni
    Options

    @Jared99 - OK, thanks for verifying. Can you tell us where you have both Firefox and 1Password 7 installed on your mac? The specific file paths, please. Are they both in /Applications? Or is one or both of them somewhere else?

  • Jared99
    Jared99
    Community Member
    Options

    That was it. 1Password was in another folder. Moved it to Applications and it's working OK. Thanks

  • Lars
    Lars
    1Password Alumni
    Options

    @Jared99 -- that'll do it, every time! :) The deal there is that in version 7, for the first time in our history, we have made 1Password (the version available from our website) sandboxed, just like the Mac App Store version has always been. Apple is in the process of tightening up dramatically their rules for third-party apps; in the future, you won't be able to install non-sandboxed apps without disabling Gatekeeper. We've tried to get ahead of that curve by complying with sandboxing rules now, so we'll be prepared for the eventualities, and one of those restrictions is that apps MUST be in /Applications. Glad we were able to assist! :)

  • dlettvin
    dlettvin
    Community Member
    Options

    I have a similar problem. I have a subscription and am UTD on OS, browsers etc. However, I must have a Chrome browser window open and not minimized to the Dock for IPassword to work. Both 1Password and Chrome are in the /Applications folder, and System Preferences lists Chrome as the default browser. The 1Password extension was installed from the Chrome extension shop and is active and working (of course it is since the browser is open).
    In addition, if a browser window is NOT open the Application just opens the 1Password extension mini-window to the top of the list. I can scroll down to the item clicked but clicking with just the miniwindow open also does nothing.
    I would like to be able to have 1Password launch a Chrome window or (preferably) a tab when minimized. Any pointers?

  • Lars
    Lars
    1Password Alumni
    Options

    @dlettvin - not directly, no. This behavior is something we're aware of, but can't address as it would have to be done on Chrome's side. If you have Chrome windows minimized into the dock (and none active/visible), OR you have Chrome running but no windows at all open, you'll run into this.

    I do have one potential work-around, and that's to use the ⌘H keyboard command to hide Chrome instead of minimizing it. This will result in the behavior you hope for/expect instead of the one you've been getting with minimized windows. Hope that helps.

  • dlettvin
    dlettvin
    Community Member
    Options

    That's a bummer. I was hoping that it was something simple. I wanted to be able to run the links from !Password in Alfred whether or not there was an active Chrome window. I'll have to try to change my deeply ingrained habits. But thanks.

  • Lars
    Lars
    1Password Alumni
    Options

    @dlettvin - sorry it wasn't better news, but thanks for stopping and asking.

  • RonaldW
    RonaldW
    Community Member
    Options

    Hi. I'm having the same problem: 1Password 7 won't open links in Safari when I click on links in items in my vault. Is there a known issue with Safari 13? I ask because if I set my browser preference to Chrome or Firefox, the links will work. I'm running 1Password 7, which I downloaded from your website, on a MacBook, which is running OS 10.14.6. Thanks.

  • Ben
    Options

    Hi @RonaldW

    1Password 7 is compatible with Safari 13. If you open Safari and look in Preferences > Extensions do you see 1Password 7 listed? Is it checked?

    Please let us know.

    Ben

  • RonaldW
    RonaldW
    Community Member
    Options

    That was the problem. (I couldn't figure out why it worked on my iMac but not my MacBook.) Thank you very much.

  • ag_ana
    ag_ana
    1Password Alumni
    edited October 2019
    Options

    @RonaldW, on behalf of Ben, you are very welcome! I am very happy to hear things are working as expected now.

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

This discussion has been closed.