Microsoft Edge extension not working

The Microsoft Edge extension doesn't seem to work consistently; it's really frustrating that I have to keep switching to Chrome or manually copy credentials from the Windows app to get to my account info.


1Password Version: 7.1.567
Extension Version: 7.2.575
OS Version: 17134.167
Sync Type: 1Password
Referrer: forum-search:microsoft edge extension doesn't work

«13

Comments

  • GregGreg 1Password Alumni

    Hi @Patriot,

    I am sorry for the troubles with 1Password! You did the right thing by contacting us.

    First of all, could you please specify what do you mean by "doesn't seem to work consistently"? Please provide more information about the steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action.

    Additionally, please create a Diagnostics Report from 1Password 7 on your PC, so we could take a closer look at your setup. Attach the Diagnostics Report to an email message addressed to [email protected].

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report on our side. Thank you! :+1:

    Cheers,
    Greg

  • Hi Greg, the extension doesn't work when I click on it. I've tried disabling the extension and re-enabling it; but that doesn't always work. I've also tried logging into the desktop app and trying again but that doesn't always work either. the only way to get the extension to work in Edge is to close the browser and restart!

    Reference: [#AYF-68295-227]

  • GregGreg 1Password Alumni

    @Patriot: Thank you you for the additional info!

    We will take a closer look at the report you've shared and get back to you via email. Thank you again! :+1:

    ref: AYF-68295-227

  • Hello, I am having the same problem. I prob have a 50/50 shot on any given day if the extension works. Closing a restarting the browser doesn't consistently work for me either. My only recourse is to open the full app and copy/paste the user/pw. When I click on the extension icon, nothing happens. I'm trying to attach my log but I get an error "File format is not allowed". This happens if I attach the native file or zip.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @TheBryce,

    Thanks for reporting this.

    Please email it to us at [email protected], we intentionally disable file uploads here because it is a public support forum, anyone can see what you share here.

  • Boom, bang, boom, NOT REPRO ANYMORE WITH YESTERDAY'S BUILD 17741!
    I have extension 7.2.575 and 1pw 7.2.576 on Win10 RS5 17741 x64 Pro German.

  • I have the updates and I still have this issue with Microsoft Edge. Even if I'm logged into the Windows app, the extension won't launch. Sometimes if you turn the extension on/off it will work, but it's intermittent. Usually I have to close and restart the browser.

  • Interesting. I can only speak for my PC and here it's gone. Hopefully it will be fixed for everyone soon :)

  • I am facing the issue too since 1Password 7.2 update. I have send you the diagnostic report.

  • GregGreg 1Password Alumni
    edited August 2018

    @sniem: I don't think that @supergenius and @Kristian are on Insider builds as well, so this might be the difference here.

    @supergenius, @Kristian: If you kill all Edge processes every time you close it, does the issue with the 1Password extension remains the next time you open it?

    Thanks in advance!

    Cheers,
    Greg

    ref: RSH-49216-983

  • @Greg I am running Windows 10 Pro 1803 stable (not an insider build) on a Surface 4 Pro. Edge is my default Browser. With 1Password 7.1 it worked as you described. I have to quit all edge processes from time to time to make 1Password run again. With 1Password 7.2 Update it has stopped working. Even Edge restarts take no effect.

  • AGAlumBAGAlumB 1Password Alumni

    @Kristian: Hmm. I think you may be mistaking one thing for another. Does this only happen after initially unlocking 1Password? If you give it about 30 seconds, does it respond normally after that? If I'm way off base, can you be more specific about the steps you're taking and what is (or is not) happening as you expect?

  • @brenty Sadly it won't work all the time since 1P 7.2. I have restarted my Device, the Edge processes and the 1Password processes several times. It never worked. I see the 1Password Extension Icon in Edge, but it is not clickable. Before 7.2 update it worked stable (except of the needed 1p / edge restarts from time to time).

  • I'm not on an insider build either. I'm running Windows 10 Home 1803. I have the desktop app run at Windows startup. I unlock the app first and then launch the browser. The extension doesn't respond. Closing and restarting the browser is hit or miss. Sometimes you can restart once and the browser extension will work. Sometimes you need to close the browser multiple times.

  • @brenty Sadly it won't work all the time since 1P 7.2. I have restarted my Device, the Edge processes and the 1Password processes several times. It never worked. I see the 1Password Extension Icon in Edge, but it is not clickable. Before 7.2 update it worked stable (except of the needed 1p / edge restarts from time to time).

    I reinstalled the 1p edge extension from the store again and now it works. Confusing, but never mind, I am happy, that it works again :)

  • AGAlumBAGAlumB 1Password Alumni

    @Kristian: That doesn't make any sense to me, but I guess let's just be happy about that. :) The good news is that if it's working for you now, it should get even better with the efficiency improvements we're working on for the next update. ;)

  • AGAlumBAGAlumB 1Password Alumni

    @supergenius: While I can't account for reinstalling the extension helping Kristian, there are still definitely some performance bottlenecks in 7.2 with all the features we've added, especially right after unlocking. If you give it 30 seconds or so, do you notice that it becomes responsive again?

  • Not really. The extension is really unresponsive now, even after reinstalling it. Turning it off and on has helped in the past, but not anymore it seems.

  • @supergenius - I've had some issues with 1password and edge too, and recently, I've had success with the following steps:

    1password is set to launch with windows.
    1. start edge.
    2. click the icon for the 1password extension in the browser. on my system, 1password crashes and the tray icon disappears.
    3. try to invoke the 1password extension again, and 1password app re-launches (tray icon reappears).
    4. try to invoke it one more time, and it'll prompt for a password, and should work normally after authentication.

    of course, this isn't to say this is acceptable behavior for edge and/or 1password, but these steps have worked on both of my windows 10 machines.

  • AGAlumBAGAlumB 1Password Alumni

    @supergenius: Right, if performance is slowed due to a number of background tasks in 1Password shortly after unlocking, that will also affect the extension until it's finished, as the extension is handled by 1Password as well.

  • AGAlumBAGAlumB 1Password Alumni

    @cvvorous: Agreed. We're not happy with it either, and we're actively working on an update to address many of the performance issues. Edge seems to be less tolerant in this regard, so I suspect it will help with that too. But I'm also fairly certain that some issues will remain; we'll have a better chance of narrowing down the cause to address additional issues with others out of the way.

  • cvvorouscvvorous
    edited September 2018

    Yeah, I'm just happy you guys nailed that edge default browser bug from a couple mos back. I submitted a ticket this evening to add some extra info if you guys need it

  • AGAlumBAGAlumB 1Password Alumni
    edited September 2018

    Sounds good. Thank you! Updates to Windows 10 help a bit too. :)

    ref: AGU-83755-299

  • @cvvorous, I've been using the same tactic; I find that if I click the extension repeatedly the taskbar icon eventually crashes and the extension comes to life. Really frustrating that this is so flaky in Edge. Incidentally, I don't use any other browser in Windows 10.

  • AGAlumBAGAlumB 1Password Alumni

    Between us and Microsoft, I'm sure it will get smoothed out in time. Thanks for your patience. :)

  • I really hope so because this is not a great experience at all.. :( I also can't stand the 300 Edge browser "connections" that show up in the 1Password settings. I hope this gets resolved soon.

  • MikeTMikeT Agile Samurai

    Team Member
    edited October 2018

    We do understand and we would love to not have adopted support for Edge until the experience is better but there are no plans from Microsoft to improve Edge for offline desktop programs. We will continue to work with them to find alternatives and there is one that may work but requires extensive redoing of our code that will take some time to finish.

  • sniemsniem
    edited October 2018

    Honestly I don’t use Edge if I don’t have to and I suppose that’s the case for many other people, too. I reported the issue because there is an issue but not because I’m keen to use 1pw with Edge. Say, for me it’s no problem if it takes time.

  • I do use Edge as my primary browser so this is important to me, but that's the difficulty of software dev is that you can't please everyone all the time :)

  • GregGreg 1Password Alumni

    @WinPass: Thank you for chipping in! :+1:

    We will continue working with Microsoft and will post more news once we have them. Please stay tuned.

    Cheers,
    Greg

This discussion has been closed.