why does using 1Password on Safari Technology Preview on Catalina open separate Safari window?

Safari Technology Preview is my default browser, using 1Password 7 with STP opens a Safari window.


1Password Version: 7.3.2
Extension Version: 7.3.2
OS Version: OSX 10.15.1
Sync Type: iCloud
Referrer: forum-search:safari technology preview

«1

Comments

  • ag_anaag_ana

    Team Member

    Hi @byaruhaf! Welcome to the forum!

    Can you please share a complete list of steps to trigger this behavior so we can test it here too?

  • Hi @ag_ana

    Step1: Open Safari Technology Preview
    Step2: Try to use 1PassowrdX

    you will notice the Safari app opens automatically, not sure why.
    I mead a video to show you.

  • ag_anaag_ana

    Team Member

    Thank you for the video @byaruhaf!

    I was able to get Safari Technology Preview to work as expected with the 1Password extension here. I could only reproduce your issue if I had Safari (or any other browser) configured as the default browser in my macOS Preferences.

    I know you mentioned that you already have Safari Technology Preview configured as your default browser, but can I ask you to check your macOS Preferences again to make sure that is still the case? Under macOS Preferences > General, you should see this:

    Once you do this, things should be working :)

  • mattpoppymattpoppy Junior Member

    I have had the same issue as well and I did confirm I have Safari Technology Preview set as the default browser. I did also try to set default to another browser and re-set back to STP and same issue.

  • ag_anaag_ana

    Team Member

    @mattpoppy:

    Can you please confirm what macOS version, 1Password version, Safari version and Safari Technology Preview versions you are running at the moment?

  • mattpoppymattpoppy Junior Member

    OS 10.15.1 beta, 1P 7.4 Beta-0, Safari 13.0.3, Safari Technology Preview Release 95 (13.1)

  • Hey @mattpoppy, thanks for the details. I was able to reproduce this on my end. I've asked one of our Mac devs about this — I'll let you know what I find out, when/if I find out anything.

  • I've had the same issue. If I set the default to Safari and then try to use 1P in Safari Tech Preview instead of bringing up the 1P window (after clicking on the icon) on Safari Tech Preview it brings it up in Safari.

    If I set the default to Safari Tech Preview the reverse also happens. Instead of bringing the window up in Safari it brings up the window in Safari Tech Preview.

    MacOS 10.14.6, 1P vs 7.4 (70400014), Safari Version 13.0.1 (14608.2.11.1.11), Safari Tech Preview Release 93 (Safari 13.1, WebKit 14609.1.5)

  • ag_anaag_ana

    Team Member

    Thank you for the additional information!

  • maculamacula Member
    edited November 2019

    Confirming the issue, which is longstanding in my case, indeed since the early days of Mojave up until the latest Mojave patch (10.14.6).

    My reproduction is slightly different in that the 1P extension always triggers the plain Safari, not the Developer Preview, irrespective of the default browser setting.

  • Thank you for sharing that data point with us, @macula. :smile:

  • Would like to add up to the thread at I can't get 1password to work with STP either. It would launch the stable Safari instead. I, too, would like to use 1password with both of them. Could Agilebits team help us on this issue?

    1password 7.3.2
    macOS Catalina 10.15.1

  • ag_anaag_ana

    Team Member

    Certainly @wattachai, our developers have been made aware of the issue ;)

  • Hello Agilebits team, I am still having this problem. Is there any solution now?

    • MacOS version 10.15.4,
    • 1Password version 7.4.4 (70404001),
    • Safari version 13.1 (15509.1.20.111.8),
    • Safari Technology Preview Release 104 (Safari 13.2, WebKit 15610.1.8.3).
  • edited June 2020

    I am also still having this problem!

    MacOS version 10.15.6 Beta (19G46c)
    1Password version 1Password 7 Version 7.6.BETA-3 (70600003)
    Safari Version 13.1.2 (15609.3.2)
    Safari Technology Preview Release 109 (Safari 14.0, WebKit 15610.1.17.2)

  • ag_anaag_ana

    Team Member

    @mingtian, @howardellacott:

    Not yet, sorry :(

  • Same problem:
    MacOS 10.15.5 (19F101)
    STP Release 109 (Safari 14.0, WebKit 15610.1.17.2)

    Setting STP as the default browser actually breaks autofill 1P in Safari and STP, even with the extensions enabled in Safari and in STP, or alternatively, disabled in Safari and enabled in STP. I emailed a report.

  • BenBen AWS Team

    Team Member

    Hi @Nebes

    I'm not seeing any recent emails in our inbox from the address you have in your forum profile. Did you get a support ID back from BitBot when you emailed in? Please let me know.

    Ben

  • Is this still a problem for macOS 10.15.6 with Safari Technology Preview 14? Or user error?

    I have STP set as the default browser.

    The menubar icon always gives me the "Open Extension Preferences in Safari" button -- with the purple STP icon. The extension is correctly activated.

    The STP toolbar icon just blinks when I click, with nothing happening.

    Obviously supporting prerelease software isn't (and shouldn't be) a priority but if it can work easily that would be useful.

    Thanks,

    Andrew

  • ag_anaag_ana

    Team Member

    @a.jaffe:

    Please see this post from my colleague Ben for the latest update on this :+1:

  • Thanks and sorry I missed that other post.

  • ag_anaag_ana

    Team Member

    No worries @a.jaffe! We are always happy to help :)

  • Hello !
    Same problem here, Safari is always opened.
    For information, it works well with Firefox : I have FF and FF Developer Edition, and when I use the browser extension in the Developer Edition, it does not open FF (even if it's my default browser).
    So it seems related to Safari and STP.

  • Please note that this might be a little off topic since it’s Big Sur 11.1. Yet, let me chime in.

    Unlocking 1Password on STP still opens Safari. However once, 1Password has been unlocked, it would work flawlessly on STP.

    We have some progress here. Really looking forward to a complete support.

  • kaitlynkaitlyn

    Team Member
    edited December 2020

    @oziade – Thanks for sharing your experience in Firefox! Safari and Firefox are completely different beasts, so it's really difficult to compare the two at all. I am wondering what macOS you're running, though, as Ben mentioned that 1Password isn't going to work with STP on macOS Catalina in the comment that Ana linked to here.

    @wattachai – That's peculiar, but it does seem to be a step in the right direction when compared to 1Password not working at all in STP. That said, I haven't run into any issues myself, so I'm curious about it. Here are the steps I took when trying to reproduce the issue with STP opening Safari:

    • Start out with 1Password locked
    • Set STP as default browser
    • Open STP
    • Enable the 1Password extension (if it isn't already)
    • Click the 1Password icon in the STP browser toolbar
    • I was asked for Touch ID, and 1Password unlocked immediately

    Now I'm wondering if you had Safari open at all – it was open for me (it's where I'm writing this response to you, so I can't close it quite yet), but not in the foreground. I'll give it another shot with Safari closed, but let me know if you're able to reproduce the issue after following the same steps as me.

    Edit: I got the same results when Safari was closed – I was able to unlock 1Password on STP, and Safari never opened unexpectedly for me. 🤔 I'll admit that I'm using the beta version of 1Password, but now I'm even curious how your test goes.

  • @kaitlyn Thanks for your message ! Yes FF and Safari are quite different, I did not try in Chromium browsers by the way :).

    I'm on Big Sur 11.1.
    I had the same steps as yours, except that I used keyboard shortcut to autofill, not the 1password icon (with Safari closed or not, I can reproduce the problem).
    I just tried and it works when I use the icon.
    So it seems related to the shortcut use:

    • Open STP
    • Use the shortcut to autofill fields or display 1password
    • Touch ID window is displayed in Safari and not in STP (even if Safari was not opened before)

    As @wattachai mentioned, once 1password has been unlocked, everything works fine in STP (icon and shortcut use).

  • @kaitlyn i forgot to mention that STP is not my default browser. This might be the deciding factor of the behavior discrepancy.
    @oziade do we have the same default browser setting?

  • @wattachai Yes we have the same settings : Safari is my default and STP is for work.

  • kaitlynkaitlyn

    Team Member

    Ah, sorry for the confusion @wattachai and @oziade. Safari Tech Preview must be set to the default browser in order for filling in STP to work properly from the start. That's a limitation that's outside of our control, unfortunately. I hope that helps get to the bottom of it!

  • @kaitlyn Thanks for the clarification. Hope there is a way to provide a seamless support for both Safari and STP in future.
    @oziade We have the same use case! Looks like we are a big fan of Safari. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file